-         

Kommentare

  1. Avatar von Moppi
    Ich bin mit meinem 3D-Drucker noch nicht ganz im Reinen, deshalb habe ich den zunächst mit einem All Metal Hotend modifiziert, bei dem der PTFE-Schlauch nicht mehr bis an die Düse heranreicht (Ender 3 und Co.).

    Ich habe ein Chassis konzipiert, das nun ca. 28cm im Durchmesser groß ist, bin aber mit der Größe nicht so glücklich, weil ich das alles in 3D ausdrucke. Hier bin ich auf eine Idee gekommen, wie ich das ändern könnte. Weil bei Änderungen an Teilen müssen diese oft neu gedruckt werden. Jedenfalls habe ich das in der Vergangenheit so gemacht. Aber nun soll das neue Konzept flexibler werden, ohne das ich Unmengen an Material verdrucke, was - bei großen Teilen, ja auch immer dann gleich Tage dauert.
  2. Avatar von Moppi
    Wenn es einen gepackt hat, muss man es heraus finden, sonst findet man keine Ruhe.

    Gruß
  3. Avatar von Searcher
    Zitat Zitat von Moppi
    Bau selber so ein Teil, geht schneller.
    Ich bin bald weich. Weil ich beim Dekodieren hänge, habe ich heute bei schönstem Wetter die Urversion mit der 9V Batterie auf 2,4V (2 X AAA NiMh) umgebaut. Ist etwa 5mm flacher geworden. Es hat aber unheimlich Anstrengung gekostet, die Bauteile auf dem noch engeren Raum halbwegs gesittet unterzubringen. Haupsächlich lag es an der viel größeren E-Magnet Spule, die mehr Windungen mit auch noch dickerem Draht als die alte benötigt um bei der geringeren Spannung noch stark genug zu sein. Außerdem hab ich da noch Eisenstückchen angebracht, damit ich Magnetfeldlinien besser unter den Speed Sensor an eine optimale Stelle bekomme. Ist übrigens die Empfangsspule für die Datenpakete von dem Foto oben. Da brauch ich jetzt auch noch 'ne Neue.

    Die Urversion hatte ich schon im Praxiseinsatz. Hat sich gut bewährt - der Tacho hat meinen Puls wunderschön aufgezeichnet. Es fehlt zwar die Abhängikeit zur Geschwindigkeit, da ja immer die gleiche Radgeschwindigkeit simuliert wird. Ist aber von Anfang an einkalkuliert gewesen. Die Zuordnung zur veronnen Zeit und Höhenprofil paßt jedoch.

    Bei der Dekodierung der Pakete denke ich immer stärker daran, die Daten wie die Darstellung an einem Oszilloskop zu visualisieren. Da fällt einem vielleicht direkt was ins Auge. Weiß nur noch nicht wie. Wenn ich da erst ein Programm für machen muß, ist der Sommer vorbei

    Gruß
    Searcher
  4. Avatar von Moppi
    So was war auch meine Vermutung, dass der vor allem dieses Signal sendet, mal von der ID abgesehen.
    Dass Du Dir das antust! Meine Herren...
    Bau selber so ein Teil, geht schneller.

    MfG
  5. Avatar von Searcher
    Hallo Moppi,
    ich habe zwei neue Aufzeichnungen am thread angehangen. Mein Eindruck ist, daß die Zeit einerRadumdrehung gemessen wird und im Paket zum Tacho geschickt wird. Der Tacho verrechnet das mit dem Radumfang und mittelt das Ergebnis mit vorherigen Messungen vor der Anzeige. Mal sehen, was was ich noch so alles aufzeichnen kann

    Gruß
    Searcher
  6. Avatar von Moppi
    Vielleicht hilft es, zu analysieren, was unter welchen Voraussetzungen bzw. in welchen Fällen gesendet wird. Also was wird gesendet wenn: der Computer neu eingeschaltet wird. Was, wenn das Rad das erste mal rollt. Was, wenn es weiter rollt. Was, wenn es anhält. Was, wenn es nach dem Anhalten weiter rollt (erste Umdrehung hier). Was, wenn es dann weiterrollt (2 und weitere Umdrehungen). Auch müsste herausgefunden werden, was bei unterschiedlichen Geschwindigkeiten gesendet wird. Ich könnte mir vorstellen, dass mitgeschickt wird, wie schnell sich das Rad dreht.

    MfG
  7. Avatar von Moppi
    Ist es auch mit Regelung nicht hinzubekommen?
    Nein, ist es nicht. Da ist das, was ich mehrfach probiert habe. Eine Scheibe hat 20 Löcher, die kann ich gut zählen. Habe ich auch mit dem Nano gemacht. Beide Motoren drehen eine bestimmte Zeit, danach bekomme ich ein Ergebnis. Anschließend folgt eine Korrektur, über die Zeit (die die Motoren drehen), also dass einer kürzer dreht als der andere, um Unterschiede auszugleichen. Vom Prinzip funktioniert das auch. Wenn es gut läuft, pendelt das Gefährt zwar etwas, findet aber so immer die Gerade wieder, auf der es theoretisch fahren müsste. Bloß habe ich oft das Problem, dass ein Motor ganz stockt, hängt evtl. mit dem 293D zusammen, dann kommt das dermaßen aus dem Tritt, dass es nicht zu gebrauchen ist. Dazu kommen Probleme mit der Griffigkeit der Räder, auch bei sehr geringem Gefälle. So haut das dann immer nach einer Richtung ab und ist nicht einzufangen. Ich hatte auch eine andere Methode ausprobiert: ich messe die Geschwindigkeit (Zeit) über die Lochscheibe und wenn ein Motor langsamer dreht, habe ich das über das PWM-Signal ausgeglichen. Das funktioniert genau so bescheiden.

    Blöd ist, dass ich von Anfang an mit Schrittmotoren hantieren wollte, bloß die sind groß und schwer und passten nicht ins Konzept, so habe ich das dann mit diesem TT-Motoren-Chassis versucht.
    Die Spur muss schon in gewissen Grenzen gehalten werden, besser wäre sicher ein Getriebe, mit einem Motor und einer Lenkung.
    Nun schaue ich nochmal mit Schrittmotoren, ob ich die in einem Chassis mit geeigneter Größe unterbringen kann. Die habe ich da und Treiber auch, das wird dann verlässlicher. Ich habe jetzt auch keine Lust, ein paar unterschiedliche Motoren zu kaufen und zu sehen, mit welchen es wohl besser funktioniert.

    MfG
  8. Avatar von Searcher
    Zitat Zitat von Moppi
    Leider ist es in der Konfiguration nicht hinzubekommen, dass das Chassis mit den Motoren geradeaus läuft.
    Hallo Moppi,
    Du hast doch Enkoder. Ist es auch mit Regelung nicht hinzubekommen? Vielleicht versuchsweise noch eine extra Batterie nur für die L293 und Motore draufpacken? Die Logikspannung für L293 kann ja bei 5V bleiben.
    Gruß
    Searcher
    Aktualisiert: 21.03.2020 um 19:13 von Searcher
  9. Avatar von Moppi
    So, heute nun der letzte Versuch, mit den TT-Motoren. Leider ist es in der Konfiguration nicht hinzubekommen, dass das Chassis mit den Motoren geradeaus läuft. Das wohl größte Problem ist das Gewicht und die Verteilung auf den Motoren, in Zusammenspiel mit dem L293D. Dreht ein Rad etwas durch, wird eins mehr belastet oder wird ein Rad durch den Untergrund etwas gestoppt, laufen die beiden Motoren unterschiedlich schnell, so dass das Gefährt in eine Richtung zieht. Also werde ich das nicht weiter verfolgen und alles demontieren, die Teile im Schrank einsortieren.


    ENDE
  10. Avatar von Moppi
    Hier noch ein Bild von der fertigen Verkabelung. Schöner ist es nicht hinzubekommen, zum einen, weil die Kabel nicht unendlich lang sind und zum andern, weil wenig Platz ist und sich viele Kabel kreuzen und in verschiedenen Richtungen übereinander liegen.



    Heute habe ich die US-Wandler durchprobiert. Nachdem ich eine Klasse dafür geschrieben hatte, funktionierte erstmal nichts. Jetzt dachte ich die US-Wandler wären defekt, also einen Neuen aus dem Schrank geholt und probiert, dasselbe Ergebnis: nichts. Im Laufe der nächsten zwei Stunden habe ich dann bemerkt, dass ich lange nicht in der Materie drin war, seitdem ich die letzte Klasse, mit ihren Methoden, für die serielle Datenübertragung programmiert hatte. Da habe ich ganz schön lange gesucht, wo der Haken ist, so was habe ich selten. Nun, letzten Endes, funktioniert es aber, nur einen Wandler habe ich ausgetauscht, damit habe ich keinerlei Werte bekommen. Und das Anschlusskabel habe ich gleich mit getauscht. Also funktionieren 4 Wandler und die IR-Abstandsensoren für Linienerkennung auch.
    Aktualisiert: 21.03.2020 um 04:35 von Moppi
  11. Avatar von Moppi
    Heute habe ich Zeit gefunden, die Verkabelung am Nano fertig zu stellen. Trotz größter Aufmerksamkeit, im Strippengewirr, habe ich mich gewundert, dass der Nano gegrillt wird. Also alle Kabel nochmal durchgegangen und siehe da, ich habe zeitweilig die Plus- und Minus-Anschlüsse der Sensoren, US-Wandler etc. vertauscht. Habe es geändert und der Nano erledigt nach dem ersten Eindruck seine Arbeit, ohne zu heiß zu werden. Werde demnächst alle Sensoren überprüfen, um sicher zu stellen, dass alles einwandfrei arbeitet. Eine Außenhülle für das Gefährt, zur Probe, habe ich auch schon mal gedruckt.



    Das Display steht noch auf dem Kopf, das ist aber per Software schnell geändert.
    Aktualisiert: 18.03.2020 um 05:49 von Moppi