-         
Ergebnis 1 bis 2 von 2

Thema: Hilfe bei PWM mit PIC32MK...

  1. #1
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    02.08.2006
    Ort
    Würzburg, Germany
    Beiträge
    713

    Hilfe bei PWM mit PIC32MK...

    Anzeige

    Hallo,

    ich arbeite mich gerade in die PIC Controller ein. Ich hänge gerade beim erzeugen eines PWM-Signals. Ich möchte damit einfach eine LED dimmen, die über einen Transistor am Ausgang hängt. Folgendes habe ich konfiguriert:

    Klicke auf die Grafik für eine größere Ansicht

Name:	PWM_config.jpg
Hits:	7
Größe:	57,7 KB
ID:	35784

    Und hier ist mein Code:

    Code:
    int main ( void )
    {
        /* Initialize all modules */
        SYS_Initialize ( NULL );
    
        MCPWM_Initialize ();
        MCPWM_ChannelPrimaryDutySet (0, 50);
        MCPWM_ChannelPrimaryDutySet (1, 50);
        MCPWM_Start ();    
        
        while ( true )
        {
            /* Maintain state machines of all polled MPLAB Harmony modules. */
            SYS_Tasks ( );
        }
    
        /* Execution should not come here during normal operation */
    
        return ( EXIT_FAILURE );
    }
    Der Pin bleibt aber auf Low. Kann mir jemand einen Tipp geben, was noch fehlt?

    Viele Grüße
    Andreas

  2. #2
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    02.08.2006
    Ort
    Würzburg, Germany
    Beiträge
    713
    Hallo,

    ich habe die Ursache gefunden. Die Reihenfolge machts. So funktioniert es:

    Code:
    int main ( void )
    {
        /* Initialize all modules */
        SYS_Initialize ( NULL );
    
        MCPWM_Start ();    
        MCPWM_ChannelPrimaryDutySet (MCPWM_CH_1, 50);
        
        while ( true )
        {
            /* Maintain state machines of all polled MPLAB Harmony modules. */
            SYS_Tasks ( );
        }
    
        /* Execution should not come here during normal operation */
    
        return ( EXIT_FAILURE );
    }
    Viele Grüße
    Andreas

Ähnliche Themen

  1. Balancierender Roboter(HILFE!!SOS!!!HILFE!!)
    Von snoopy82 im Forum Microcontroller allgemeine Fragen/Andere Microcontroller
    Antworten: 3
    Letzter Beitrag: 25.11.2014, 21:40
  2. Hilfe, Hilfe, ist das Zumo-Reflectance-Sensor-Array fehlerhaft ???
    Von oderlachs im Forum Sensoren / Sensorik
    Antworten: 6
    Letzter Beitrag: 23.01.2014, 08:57
  3. Antworten: 7
    Letzter Beitrag: 27.11.2013, 16:44
  4. hilfe Anfänger braucht hilfe beim start
    Von thomas3 im Forum Robby RP6
    Antworten: 26
    Letzter Beitrag: 20.09.2010, 21:07
  5. Hilfe Hilfe Schnelle es qualmt
    Von Larzarus im Forum Motoren
    Antworten: 32
    Letzter Beitrag: 07.06.2006, 14:04

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  

Labornetzteil AliExpress