- 12V Akku mit 280 Ah bauen         
Ergebnis 1 bis 3 von 3

Thema: Raspberry mit spi lcd display - Ich hab keine Ideen mehr :(

  1. #1

    Frage Raspberry mit spi lcd display - Ich hab keine Ideen mehr :(

    Anzeige

    LiFePo4 Akku selber bauen - Video
    Moin!

    Mir wurde dieses Forum empfohlen um hier meine Frage zu stellen.

    Ich bin einem guid auf github gefolgt, der sehr gut erklärt wie man einen rpi zero w in eine alte gameboy advanced sp hülle stopft. Dafür wurden auch gerber dateien dazu gegeben um sich ein pcb von z.b. jlc pcb drucken zu lassen. Also hab ich alles fröhlich bestellt, die ganzen Kleinteile heruas gesucht und habe drauf los gelötet. Der git post gibt auch eine fertige version von Retropi mit, in der schon alles richtig eingestellt ist.

    Das problem ist nur, dass das Display nicht funktioniert. Es hat einen ili9341 chip, 3.2" mit 320x240px. Ich habe zwei pi zero w probiert, einen 3b und einen 1er. Ich habe 3 displays von 3 verschiedenen Verkäufern gekauft, und die alle überall aus probiert. Der eine zero w ist nicht auf der bestellten Platine verlötet, und ich habe den direkt mit den Displays verdrahtet genau wie den 3b und 1er, aber auch ohne Erfolg.
    Ich habe 3 verschiedene sd karten mit 3 verschiedenen betriebsystemen probiert. Einmal die originale Software aus dem guide, dann eine neue installation von retropie und einmal ein blankes debian. Ich habe verschiedene Wege probiert die Displays anzusprechen: das fbcp-ili9341 gedöne von github, über modprobe (hat mir mein debian zerschossen) ich habe versucht ein eigenes python script zu schreiben, aber da bin ich an nicht mehr unterschtützten und nicht dokumentierten modulen gescheitert. Ich bin auch mehreren guides, tutorials und so gefolgt, aber konnte nichts erreichen.

    Ich habe auch schon auf reddit gepostet, aber auch die ganzen Kommentare dort konnten mir nicht helfen. Mir wurde empfohlen das Kernel auf eine version unter 4.19.xx zu downgraden, da die neueren scheinbar nicht immer mit den Displays funktionieren, hab ich gemacht, ohne Erfolg.

    Bei all den Versuchen hab ich immer sicher gestellt, dass spi in der raspi-config aktiv ist.

    Die displays funktionieren, das hab ich mit einem ESP8266 wemos d1 mini überprüft, bei dem lief alles ohne Probleme.

    Ich würde mich nicht als besonders inkompetent was so nen kram an geht bezeichnen, deshalb wundert und frustriert es mich langsam echt, dass ich da so überhaupt keine Fortschritte mache.
    Ich will doch einfach nur meine alten gamboy Spiele spielen, so wie früher!

    Wie würdet ihr vor gehen? Was könnte das Problem sein? Was habe ich noch nicht robiert?

    Das ganze Projekt hat mir jetzt schon ca 130€ und nen haufen Nerven gekostet, deshalb würde ich mich sehr freuen, wenn ihr noch irgendwelche tips habt.

    Vielen dank an euch alle, ich hoffe ihr könnt mir helfen.
    Danke! Moritz

  2. #2
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    18.01.2012
    Beiträge
    484
    Hallo,
    herzlich willkommen im Forum.
    Vielleicht hilft das weiter?
    http://www.netzmafia.de/skripten/har...RasPi_SPI.html

    Gruß
    AR

  3. #3
    Moin!
    Danke für die schnelle Antwort!
    Ich lese mich mal durch den Artikel und hoffe dass ich da was verstehe
    Danke, Moritz

Ähnliche Themen

  1. [ERLEDIGT] Atmega32 ==> Atmega1284p - keine Anzeige mehr im Display
    Von tc-maxx im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 3
    Letzter Beitrag: 16.05.2011, 15:01
  2. RNBFRA keine 12V mehr auf Ausgangsports
    Von Keksdose im Forum Elektronik
    Antworten: 9
    Letzter Beitrag: 31.03.2007, 12:46
  3. Antworten: 14
    Letzter Beitrag: 29.10.2006, 11:33
  4. Pic nimmt keine progs mehr an
    Von Smi im Forum PIC Controller
    Antworten: 5
    Letzter Beitrag: 23.06.2005, 23:06
  5. Plötzlich keine Verbindung mehr zum AVR
    Von Spurius im Forum AVR Hardwarethemen
    Antworten: 1
    Letzter Beitrag: 24.12.2004, 10:01

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  

LiFePO4 Speicher Test