-         
Ergebnis 1 bis 3 von 3

Thema: Entwicklungsumgebung Microchip Studio (Atmel Studio 7) - Setup für atmel2560

  1. #1

    Entwicklungsumgebung Microchip Studio (Atmel Studio 7) - Setup für atmel2560

    Anzeige

    Hallo zusammen,

    ich schreibe euch aus purer Verzweiflung...
    Ich kämpfe seit Tagen! mit dieser besch.... IDE. Muss mir eingestehen... leider brauch ich eure hilfe

    Ausgangssituation:
    Möchte ein kleines Projekt realisieren und habe mich für den Atmel2560 entschieden mit dem Arduino Board bzw, Elegoo R3.
    Da ich schon so manches Projekt hinter mir habe ... kam für mich die Nutz von Arduino IDE nicht in Frage und bin schnell auf die IDE von Atmel gestossen..

    Problem:
    Konkret habe ich Probleme beim einbinden von include Files... Es will mir einfach nicht gelingen!

    Es gibt verschiedene Möglichkeiten ein Projekt anzulegen für ein Arduino Board in Microchip Studio.
    Bitte korrigiert mich wenn ich falsch liege:

    1. Create project from ARduino sketch
    Finde ich eher unpraktisch da man nicht in der main arbeiten kann. Man wird gezwungen immer mit dem sketch.cpp zu arbeiten. Kann man das umgehen?

    2. C++ Projekt anlegen
    Hier treten die oben genannten Probleme auf mit den includes...




    Wie ihr mir helfen könnt:
    Gibt es eine Anleitung von euch wie man ein Projekt aufsetzt für Arduino? Ohne mit Sketch.cpp zu arbeiten?
    Lösen meiner Fehlerbeschreibung

    Addon: Habt ihr eine Anleitung für git(oder github) in Microship Studio?
    Wie sind eure Erfahrung damit?#



    Vielen Dank euch

    Klicke auf die Grafik für eine größere Ansicht

Name:	2020-12-22_09h42_26.jpg
Hits:	6
Größe:	44,9 KB
ID:	35370

  2. #2
    Erfahrener Benutzer Robotik Visionär Avatar von oberallgeier
    Registriert seit
    01.09.2007
    Ort
    Oberallgäu
    Beiträge
    8.373
    .. aus purer Verzweiflung .. Ausgangssituation: .. Probleme beim einbinden von include Files .. in Microship Studio? ..
    Windows ?? vermutlich W 10 pro/home/??

    Versuch mal PN (ABER: 8bitter!, kein 2560er).
    Ciao sagt der JoeamBerg

  3. #3
    Erfahrener Benutzer Robotik Einstein Avatar von wkrug
    Registriert seit
    17.08.2006
    Ort
    Dietfurt
    Beiträge
    2.147
    Ich benutz auch Studio 7 auf Windows 10 Professional.
    Ich nehm üblicherweise ein C olso kein C++ Projekt.
    Bei mir geht das include ohne Probleme.
    Allerdings zickt bei mir der Simulator rum ( Interrupts werden nicht simuliert ).
    Seit das Ganze bei Microchip liegt hat sich da einiges verschlechtert!

    Ein 2560 ist ja auch ein 8 Bitter.

    Hast Du die Dateien auch im richtigen Ordner ?
    Für Dateien aus des System Lib werden normalerweise die < > Tags verwendet.
    Für Dateien im Projekt Ordner die " ".
    Beispiel:
    Code:
    #include <avr/io.h>
    #include <avr/interrupt.h>
    #include <avr/pgmspace.h>
    #include <util/delay.h>
    #include <string.h>
    //#include <stdlib.h>
    
    #include "ssd1306xled.c"

Ähnliche Themen

  1. Atmel Studio 7.0 VAssistX
    Von Bibermann im Forum C - Programmierung (GCC u.a.)
    Antworten: 1
    Letzter Beitrag: 03.01.2020, 16:27
  2. [ERLEDIGT] RP6 und Atmel Studio 6 (wieder mal)
    Von basteluwe im Forum Robby RP6
    Antworten: 9
    Letzter Beitrag: 11.04.2014, 15:32
  3. Atmel AVR Studio 5.1 einrichten
    Von mikk_11 im Forum Robby RP6
    Antworten: 13
    Letzter Beitrag: 16.02.2013, 14:16
  4. RP6 und Atmel Studio 6.0
    Von bernd01 im Forum Robby RP6
    Antworten: 2
    Letzter Beitrag: 24.07.2012, 11:37
  5. Atmel Studio 6
    Von Roboternetz-News im Forum Neuigkeiten / Technik-News / Nachrichten / Aktuelles
    Antworten: 4
    Letzter Beitrag: 14.03.2012, 17:23

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •