-         
Seite 1 von 5 123 ... LetzteLetzte
Ergebnis 1 bis 10 von 44

Thema: Arduino mp3/wav Modul gesucht

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    31.03.2014
    Beiträge
    72

    Arduino mp3/wav Modul gesucht

    Anzeige

    Praxistest und DIY Projekte
    Hallo,
    ich habe mehrere unterschiedliche mp3-Player-Module getestet, die man mit - und teilweise sogar standalone ohne - Arduino nutzen kann. Die Module funktionieren zwar, aber leider ist kein einziges darunter, welche keine Nebengeräusche produziert. Auch ein separates mp3-Modul von ELV (läuft komplett ohne Arduino) reiht sich in diese Nebengeräusch-Liste ein. Zu diesen Nebengeräuschen zählen diverse Brumm- und Knackgeräusche, die definitiv auf den verwendeten Originalaufnahmen nicht enthalten sind, sondern von den Modulen kommen. Habe das mit mp3 und wav getestet und konnte da keinen Unterschied feststellen. Die Nebengeräusche bleiben und sind vermutlich systembedingt an die jeweiligen Module/Hersteller gebunden.
    Für meine Anwendung Suche ich allerdings etwas, was keine Nebengeräusche produziert. Ich denke, ich habe alle derzeitigen Module getestet, aber vielleicht habe ich welche übersehen. Kann mir von Euch jemand ein Modul nennen, welches keine Nebengeräusche produziert? Das kann auch unabhängig OHNE Arduino laufen.


    Andi

  2. #2
    Erfahrener Benutzer Robotik Einstein Avatar von Moppi
    Registriert seit
    18.03.2018
    Beiträge
    1.891
    Blog-Einträge
    12
    Nimm mal Dateien mit geringem Datenaufkommen. Nichts mit 44kHz Stereo bswp. Ich würde mit 8khz bis 10khz versuchen und dann Mono und auf Normalmaß komprimieren. Dann nochmal schauen. Und zum Ausprobieren nur aus Batterie speisen, ohne andere Geräte an derselben Versorgung.

    MfG

  3. #3
    Erfahrener Benutzer Robotik Einstein Avatar von 021aet04
    Registriert seit
    17.01.2005
    Ort
    Niklasdorf
    Alter
    32
    Beiträge
    4.903
    Ich könnte mir gut vorstellen das es mit der Versorgung zu tun hat (Masseschleifen u.Ä.).

    Ich würde zuerst nur mit Batterien/Akkus testen. Wenn man einen uC verwendet von der Versorgung einmal zum MP3 Modul und einmal zum uC, also nur direkt an der Versorgung verbinden.

    MfG Hannes

  4. #4
    Benutzer Stammmitglied
    Registriert seit
    31.03.2014
    Beiträge
    72
    Mit der Stromversorgung war auch eine meiner Vermutungen, aber das ist nicht die Ursache. Habe es mit Batterien probiert, selbes (schlechtes) Ergebnis, auch standalone ohne µC. Habe auch unterschiedliche mp3-Auflösungen und wav's getestet, immer dasselbe. Der DFPlayer ist halt ein absolutes Billigprodukt, für halbwegs ernsthafte Anwendungen (hinsichtlich sauberer Audiowiedergabe) nicht zu gebrauchen. Wenn man das Modul z.B. in eine H0-Lokomotive/-Wagen einbaut, um auf einem winzigen Lautsprecher Eisenbahngeräusche abzuspielen, dann mag das vermutlich gehen, weil dieser kleine Lautsprecher nicht bis in diesen unteren Frequenzbereich geht, um überhaupt ein Brummen als Frequenz wiedergeben zu können. Dieses Brummen hört man deutlich, auch im Kopfhörer. Die verwendeten Audiofiles sind definitiv "sauber" und am Anfang und Ende mit einem Fade versehen und gerendert, es kommt also aus dem DFPlayer. Und bei diesem sowohl über den eingebauten 3W-Verstärkerausgang, als auch über den separaten Audio("Line")Ausgang.

    Ich habe ein ähnliches Modul in selber Baugröße (BY8001-16P), bei dem kein Brummen und keine Nebengeräusche auftreten (unter denselben Bedingungen, wie beim DFPlayer getestet). Leider ist die Dokumentation sehr schlecht bis garnicht vorhanden zu diesem Modul - und ebenso der Support. Es gibt zwar eine www, es gibt sogar eine eMail, aber mehrere eMail-Anfragen blieben bisher unbeantwortet. Für 3 EUR macht sich dort keiner die Mühe... Dieses BY8001-Modul käme für meine Zwecke in Frage, aber das Abspielen bzw. Zuordnen der einzelnen Audiofiles konnte ich bisher nicht ergründen. Mehrere Taster angeschlossen (was lt. einziger Dokumentation funktionieren sollte), entsprechend nummerierte Audiofiles auf der SD-Karte hinterlegt, dennoch werden nur 2 Files überhaupt abgespielt. Die anderen Tasten bleiben "still". Dieses "unergründliche" Verhalten des BY8001 kursiert dann auch in mehreren Foren durchs Internet. Läuft also nicht nur bei mir nicht, sondern auch bei anderen Usern. Habe übrigens von beiden Modulen mehrere vorhanden und probiert, kann daher weitgehend ausschliessen, dass eines davon vielleicht ein Montagsgerät ist. Höchstens eine Montags-Charge...

    Preiswert ist ja nett, aber lieber würde ich paar EUR drauflegen und dafür dann anständige Technik bekommen.

    Andi
    Geändert von Andi#87 (24.01.2020 um 10:27 Uhr)

  5. #5
    Erfahrener Benutzer Robotik Einstein Avatar von Moppi
    Registriert seit
    18.03.2018
    Beiträge
    1.891
    Blog-Einträge
    12
    Es gibt Filter-Audioschaltungen für solche Zwecke, Brummen etc. zu entfernen. Kann man auch selber bauen, wenn es nicht auf HiFi-Qualität ankommt. Das ist die Frage, was willst Du damit machen?
    Ein Oszi anschließen, ein WAVE oder MP3 mit Stille abspielen und schauen, welche Brummfrequenz dort ist. Dann kannst Du einen einfachen Hochpass als RC-Glied aufbauen.

    Scheinbar hast Du nur ein Billigteil und eins, das nicht gut dokumentiert ist, bzw. nicht nach Doku funktioniert.

    MfG

  6. #6
    Erfahrener Benutzer Robotik Einstein Avatar von 021aet04
    Registriert seit
    17.01.2005
    Ort
    Niklasdorf
    Alter
    32
    Beiträge
    4.903
    Wenn es nichts mit der Versorgung zu tun hat, könntest du mit Filtern arbeiten. Also das du das Brummen herausfilterst.

    MfG Hannes

  7. #7
    Erfahrener Benutzer Robotik Einstein Avatar von Moppi
    Registriert seit
    18.03.2018
    Beiträge
    1.891
    Blog-Einträge
    12
    Ich habe eine Seite rausgesucht, wo es einen Beispielcode gibt: https://www.instructables.com/id/Tut...of-MP3-TF-16P/
    Vielleicht hilft das etwas weiter.

    Es gibt auch noch WTV020-Module, vielleicht mal so eines ausprobieren?

    MfG

  8. #8
    Benutzer Stammmitglied
    Registriert seit
    31.03.2014
    Beiträge
    72
    Danke für Eure Antworten, Filterschaltungen wäre eine Option. Schöner "wär's" natürlich, wenn einfach die Geräte mal ordentlich funktionieren, und man nicht als User neugekaufte Sachen erstmal so bearbeiten muss, damit sie machen, wozu sie angepriesen und verkauft werden. Das nimmt langsam überhand, dass man beinahe schon davon ausgehen kann, dass solche Sachen verkauft werden, die nicht wirklich 100%ig tun, was sie sollen. Auf der www des Verkäufers fand ich solche Hinweise zum DFPlayer nämlich nicht...


    Andi

  9. #9
    Erfahrener Benutzer Robotik Einstein Avatar von Moppi
    Registriert seit
    18.03.2018
    Beiträge
    1.891
    Blog-Einträge
    12
    Interessant wäre auch, ob diese kleinen Module empfindlich auf Störstrahlung reagieren. Es wäre auch möglich, dass ein im Haushalt betriebenes Gerät irgendwas abstrahlt. Da die MP3-Player sehr klein sind, kann man die vielleicht in eine Schachtel packen, diese in Alufolie einschlagen, einen Draht anbringen und den erden. Ob da was von extern kommt, kann man evtl. schon feststellen, wenn man die Hand über das Modul legt, vielleicht auch in verschiedenen Richtungen. Ändert sich dann das Brummen ist es wohl eine externe Störquelle, wo das Brummen nicht vom MP3-Modul kommt.


    MfG

  10. #10
    Benutzer Stammmitglied
    Registriert seit
    31.03.2014
    Beiträge
    72
    Hab ich alles schon probiert. Allerdings nicht mit Alu, denn meines Wissens ist Alu als Abschirmung nur sehr gering wirksam. Ich habe für alle meine Testschaltungen ein rundum geschlossenes Stahlblechgehäuse in 19", welches komplett an GND angeschlossen ist. Resultat unverändert...
    WTV020 hatte ich schon entdeckt. Nachdem ich einige Kundeneinschätzungen darüber gelesen habe, entfällt auch dieses Modul. Da käme ich vom Regen in die Traufe... Werde mir wohl 10 AKAI Sampler kaufen müssen und jeden separat ansteuern. Ist zwar nicht ganz preiswert, aber funktioniert... (Scherz)

    Andi
    Geändert von Andi#87 (24.01.2020 um 15:36 Uhr)

Seite 1 von 5 123 ... LetzteLetzte

Ähnliche Themen

  1. Arduino Bluetooth Modul HC-06 verbindet nicht mit PC oder Handy
    Von RoboterSindCool im Forum Arduino -Plattform
    Antworten: 3
    Letzter Beitrag: 15.06.2017, 16:43
  2. H-Brücke Modul gesucht
    Von JD1 im Forum Motoren
    Antworten: 3
    Letzter Beitrag: 20.03.2014, 19:31
  3. Arduino uno und hc-05 bt modul probleme
    Von lotsofmuc im Forum Arduino -Plattform
    Antworten: 1
    Letzter Beitrag: 02.01.2014, 17:13
  4. Arduino Duemilanove 328 - LCD Modul
    Von Sim0n im Forum Arduino -Plattform
    Antworten: 6
    Letzter Beitrag: 08.03.2012, 16:12
  5. GPS Modul gesucht
    Von Johannes G. im Forum Elektronik
    Antworten: 34
    Letzter Beitrag: 07.03.2008, 21:37

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •