-         
Ergebnis 1 bis 5 von 5

Thema: Selbstbau AVRIsp-mkII von Ulihome.

  1. #1
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    04.10.2006
    Beiträge
    119

    Selbstbau AVRIsp-mkII von Ulihome.

    Anzeige

    Hallo,
    habe jetzt lange nichts mehr mit Elektronik gemacht. Jetzt habe ich mir von der Webseite "Ulihome.de" Den AVRIsp-mkII Clone nachgebaut. Mit einem externen Programmer habe ich den Bootloader in den ATmega8 geflasht.
    Nach langer Suche habe ich dann einen passenden Treiber für den Bootloader gefunden. Das Gerät wurde auch sogleich von Windows7-64bit erkannt als "USB AVR-Lab". Über die Software "USB AVR-Lab Tool" habe ich dann die Firmware für das AVRIsp mkII per USB in den ATmega8 übertragen.
    Nach erneutem Ab- und wieder Anstecken des Programmers wurde dieser im Gerätemanager als "AVR ISP mkII" unter ATMEL erkannt. Windows7 hat daraufhin einen Treiber automatisch installiert.
    Leider wird im Gerätemanager der Treiber nicht gestartet! Es kommt immer "Das Gerät konnte nicht gestartet werden Code(10)".
    Gibts da eine Lösung?

    Hier noch ein paar Treiberinfos:

    Treiberanbieter: Atmel Norway AS
    Treiberdatum: 31.03.2017
    Treiberversion: 42.0.2.0
    Geändert von rogerberglen (14.09.2019 um 17:19 Uhr)

  2. #2
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    04.10.2006
    Beiträge
    119
    Welchen ISP-Programmer verwenden? Soll mit Studio4 und 7, sowie unter Win7 und Win10 klarkommen

  3. #3
    Erfahrener Benutzer Robotik Visionär Avatar von oberallgeier
    Registriert seit
    01.09.2007
    Ort
    Oberallgäu
    Beiträge
    8.083
    Seit Jahren habe ich dieses Teil von Pololu im Dienst. WinXP, Win7pro, Win10pro, Win10Home etc. Mit Studio4 unter WinXP und Win7pro ok, Studio7 mit Win7pro, Win10pro, Win10Home. Unter W10 macht Studio4 Probleme - nicht der Programmer. Gimmick des Programmers - ein minimalistisches Scope - find ich fürs "Gröbste" praktisch.
    Den Programmer gibts nicht nur in Gods Own Country, hat in DE auch z.B. Exptech, dort gibts den Programmer v2.1 auch zum halben Preis (kenn ich aber nicht).
    Ciao sagt der JoeamBerg

  4. #4
    Erfahrener Benutzer Robotik Einstein Avatar von 021aet04
    Registriert seit
    17.01.2005
    Ort
    Niklasdorf
    Alter
    31
    Beiträge
    4.840
    Ich verwende mehrere Programmer. Ich habe ebenfalls Win7 (Ultimate) und Win10 (Pro Build 1809) und AVR Studio 4 und 7.

    Am Win7 Rechner sind beide Versionen installiert, beim Win10 System habe ich nur das Studio 7.

    1)Bei AVR Studio 4 verwende ich den Programmer von Ullihome, den gibt es glaube ich nicht mehr.

    2)Ich habe auch noch einen Programmer der nicht direkt von den AVR Studio Versionen unterstützt wird. Dieser hat aber den Vorteil das man nicht nur die AVR programmieren kann, sondern auch viele andere Prozessoren und auch EPROMS, GALs, PALs,.... Eine gute Funktion ist das man Logik ICs auf Funktion prüfen kann. Dieser Programmer unterstützt auch HV-Programmierung und In Circuit Programmierung. Der Typ ist ein TL866II Plus http://www.autoelectric.cn/en/tl866_main.html

    3)Mit dem AVR Studio 7 verwende ich das Atmel ICE. Dieser hat den Vorteil das es auch ein Debugger ist und die verschiedensten Schnittstellen unterstützt.

    Vielleicht hilft es weiter.

    MfG Hannes

  5. #5
    Erfahrener Benutzer Fleißiges Mitglied Avatar von avr_racer
    Registriert seit
    01.04.2014
    Ort
    MecklenburgVorpommern
    Beiträge
    165
    Zitat Zitat von rogerberglen Beitrag anzeigen
    Leider wird im Gerätemanager der Treiber nicht gestartet! Es kommt immer "Das Gerät konnte nicht gestartet werden Code(10)".
    Gibts da eine Lösung?

    Hier noch ein paar Treiberinfos:

    Treiberanbieter: Atmel Norway AS
    Treiberdatum: 31.03.2017
    Treiberversion: 42.0.2.0
    Schalte mal die Treibersignatur ab aber wundert mich das Win7 dies so macht. Normalerweise schluckt Win7 fast alles.
    Unter win10 ist es unumgänglich für den MKII dies so durchzuführen.

Ähnliche Themen

  1. AVRISP MKII und Bascom
    Von schmidtkoe im Forum AVR Hardwarethemen
    Antworten: 8
    Letzter Beitrag: 03.03.2014, 17:04
  2. AVR Studio 6 und AVRISP MKII
    Von datatom im Forum AVR Hardwarethemen
    Antworten: 11
    Letzter Beitrag: 08.11.2012, 21:22
  3. AVRISP mkII
    Von mycroc im Forum AVR Hardwarethemen
    Antworten: 10
    Letzter Beitrag: 01.01.2012, 13:22
  4. RN-Control und AVRISP mkII
    Von mr.burns im Forum AVR Hardwarethemen
    Antworten: 8
    Letzter Beitrag: 30.11.2010, 10:34
  5. AVRISP MKII und Bascom
    Von Chill im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 8
    Letzter Beitrag: 26.06.2007, 18:53

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •