-         
Seite 1 von 8 123 ... LetzteLetzte
Ergebnis 1 bis 10 von 72

Thema: GUI Builder - Qt Designer

  1. #1
    Benutzer Stammmitglied Avatar von ces
    Registriert seit
    06.10.2018
    Beiträge
    89

    GUI Builder - Qt Designer

    Anzeige

    Es genügt eine Zeile im LXTerminal (Raspi4b, Raspbian Buster 07.2019 mit Updates):

    sudo apt install qttools5-dev-tools

    Anschließend im Anwendungen/Entwicklung Menü zu finden.

    Qt4 noch nicht ausprobiert. Hier nachzulesen:
    https://wiki.ubuntuusers.de/Qt_Designer/


    Klicke auf die Grafik für eine größere Ansicht

Name:	2019-09-09-130014_1920x1080_scrot.jpg
Hits:	2
Größe:	31,6 KB
ID:	34383

    - - - Aktualisiert - - -

    Code:
    pi@raspberrypi:~ $ sudo apt install qttools5-dev-tools
    
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.       
    Statusinformationen werden eingelesen.... Fertig
    Die folgenden zusätzlichen Pakete werden installiert:
      geoclue-2.0 iio-sensor-proxy libclang1-7 libllvm7 libmbim-glib4
      libmbim-proxy libmm-glib0 libqmi-glib5 libqmi-proxy
      libqt5designercomponents5 libqt5positioning5 libqt5qml5 libqt5quick5
      libqt5quickwidgets5 libqt5sensors5 libqt5webchannel5 libqt5webkit5
      modemmanager qdoc-qt5 qt5-assistant qtchooser
    Vorgeschlagene Pakete:
      qt5-qmltooling-plugins qt5-doc
    Die folgenden NEUEN Pakete werden installiert:
      geoclue-2.0 iio-sensor-proxy libclang1-7 libllvm7 libmbim-glib4
      libmbim-proxy libmm-glib0 libqmi-glib5 libqmi-proxy
      libqt5designercomponents5 libqt5positioning5 libqt5qml5 libqt5quick5
      libqt5quickwidgets5 libqt5sensors5 libqt5webchannel5 libqt5webkit5
      modemmanager qdoc-qt5 qt5-assistant qtchooser qttools5-dev-tools
    0 aktualisiert, 22 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
    Es müssen 32,8 MB an Archiven heruntergeladen werden.
    Nach dieser Operation werden 136 MB Plattenplatz zusätzlich benutzt.
    Möchten Sie fortfahren? [J/n] 
    
    Holen:1 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian buster/main armhf libqt5positioning5 armhf 5.11.3+dfsg-2 [159 kB]
    Holen:2 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian buster/main armhf libqt5qml5 armhf 5.11.3-4 [1.001 kB]
    Holen:3 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian buster/main armhf libqt5quick5 armhf 5.11.3-4 [1.049 kB]
    Holen:4 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian buster/main armhf libqt5sensors5 armhf 5.11.3-2 [94,6 kB]
    Holen:5 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian buster/main armhf libqt5webchannel5 armhf 5.11.3-2 [41,5 kB]
    Holen:6 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian buster/main armhf libqt5webkit5 armhf 5.212.0~alpha2-21+rpi1 [8.306 kB]
    Holen:7 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian buster/main armhf libmm-glib0 armhf 1.10.0-1 [903 kB]
    Holen:8 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian buster/main armhf geoclue-2.0 armhf 2.5.2-1 [75,5 kB]
    Holen:9 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian buster/main armhf iio-sensor-proxy armhf 2.4-2 [42,3 kB]
    Holen:10 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian buster/main armhf libllvm7 armhf 1:7.0.1-8+rpi2 [11,4 MB]
    Holen:11 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian buster/main armhf libclang1-7 armhf 1:7.0.1-8+rpi2 [4.994 kB]
    Holen:12 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian buster/main armhf libmbim-glib4 armhf 1.18.0-1 [142 kB]
    Holen:13 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian buster/main armhf libmbim-proxy armhf 1.18.0-1 [70,7 kB]
    Holen:14 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian buster/main armhf libqmi-glib5 armhf 1.22.0-1.2 [443 kB]
    Holen:15 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian buster/main armhf libqmi-proxy armhf 1.22.0-1.2 [9.032 B]
    Holen:16 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian buster/main armhf libqt5designercomponents5 armhf 5.11.3-4 [596 kB]
    Holen:17 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian buster/main armhf libqt5quickwidgets5 armhf 5.11.3-4 [46,5 kB]
    Holen:18 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian buster/main armhf modemmanager armhf 1.10.0-1 [1.363 kB]
    Holen:19 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian buster/main armhf qtchooser armhf 66-2 [23,1 kB]
    Holen:20 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian buster/main armhf qdoc-qt5 armhf 5.11.3-4 [385 kB]
    Holen:21 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian buster/main armhf qt5-assistant armhf 5.11.3-4 [735 kB]
    Holen:22 http://ftp.agdsn.de/pub/mirrors/raspbian/raspbian buster/main armhf qttools5-dev-tools armhf 5.11.3-4 [923 kB]
    Es wurden 32,8 MB in 8 s geholt (4.360 kB/s).                                                                                                                                                                                                
    Vormals nicht ausgewähltes Paket libqt5positioning5:armhf wird gewählt.
    (Lese Datenbank ... 155089 Dateien und Verzeichnisse sind derzeit installiert.)
    Vorbereitung zum Entpacken von .../00-libqt5positioning5_5.11.3+dfsg-2_armhf.deb ...
    Entpacken von libqt5positioning5:armhf (5.11.3+dfsg-2) ...
    Vormals nicht ausgewähltes Paket libqt5qml5:armhf wird gewählt.
    Vorbereitung zum Entpacken von .../01-libqt5qml5_5.11.3-4_armhf.deb ...
    Entpacken von libqt5qml5:armhf (5.11.3-4) ...
    Vormals nicht ausgewähltes Paket libqt5quick5:armhf wird gewählt.
    Vorbereitung zum Entpacken von .../02-libqt5quick5_5.11.3-4_armhf.deb ...
    Entpacken von libqt5quick5:armhf (5.11.3-4) ...
    Vormals nicht ausgewähltes Paket libqt5sensors5:armhf wird gewählt.
    Vorbereitung zum Entpacken von .../03-libqt5sensors5_5.11.3-2_armhf.deb ...
    Entpacken von libqt5sensors5:armhf (5.11.3-2) ...
    Vormals nicht ausgewähltes Paket libqt5webchannel5:armhf wird gewählt.
    Vorbereitung zum Entpacken von .../04-libqt5webchannel5_5.11.3-2_armhf.deb ...
    Entpacken von libqt5webchannel5:armhf (5.11.3-2) ...
    Vormals nicht ausgewähltes Paket libqt5webkit5:armhf wird gewählt.
    Vorbereitung zum Entpacken von .../05-libqt5webkit5_5.212.0~alpha2-21+rpi1_armhf.deb ...
    Entpacken von libqt5webkit5:armhf (5.212.0~alpha2-21+rpi1) ...
    Vormals nicht ausgewähltes Paket libmm-glib0:armhf wird gewählt.
    Vorbereitung zum Entpacken von .../06-libmm-glib0_1.10.0-1_armhf.deb ...
    Entpacken von libmm-glib0:armhf (1.10.0-1) ...
    Vormals nicht ausgewähltes Paket geoclue-2.0 wird gewählt.
    Vorbereitung zum Entpacken von .../07-geoclue-2.0_2.5.2-1_armhf.deb ...
    Entpacken von geoclue-2.0 (2.5.2-1) ...
    Vormals nicht ausgewähltes Paket iio-sensor-proxy wird gewählt.
    Vorbereitung zum Entpacken von .../08-iio-sensor-proxy_2.4-2_armhf.deb ...
    Entpacken von iio-sensor-proxy (2.4-2) ...
    Vormals nicht ausgewähltes Paket libllvm7:armhf wird gewählt.
    Vorbereitung zum Entpacken von .../09-libllvm7_1%3a7.0.1-8+rpi2_armhf.deb ...
    Entpacken von libllvm7:armhf (1:7.0.1-8+rpi2) ...
    Vormals nicht ausgewähltes Paket libclang1-7 wird gewählt.
    Vorbereitung zum Entpacken von .../10-libclang1-7_1%3a7.0.1-8+rpi2_armhf.deb ...
    Entpacken von libclang1-7 (1:7.0.1-8+rpi2) ...
    Vormals nicht ausgewähltes Paket libmbim-glib4:armhf wird gewählt.
    Vorbereitung zum Entpacken von .../11-libmbim-glib4_1.18.0-1_armhf.deb ...
    Entpacken von libmbim-glib4:armhf (1.18.0-1) ...
    Vormals nicht ausgewähltes Paket libmbim-proxy wird gewählt.
    Vorbereitung zum Entpacken von .../12-libmbim-proxy_1.18.0-1_armhf.deb ...
    Entpacken von libmbim-proxy (1.18.0-1) ...
    Vormals nicht ausgewähltes Paket libqmi-glib5:armhf wird gewählt.
    Vorbereitung zum Entpacken von .../13-libqmi-glib5_1.22.0-1.2_armhf.deb ...
    Entpacken von libqmi-glib5:armhf (1.22.0-1.2) ...
    Vormals nicht ausgewähltes Paket libqmi-proxy wird gewählt.
    Vorbereitung zum Entpacken von .../14-libqmi-proxy_1.22.0-1.2_armhf.deb ...
    Entpacken von libqmi-proxy (1.22.0-1.2) ...
    Vormals nicht ausgewähltes Paket libqt5designercomponents5:armhf wird gewählt.
    Vorbereitung zum Entpacken von .../15-libqt5designercomponents5_5.11.3-4_armhf.deb ...
    Entpacken von libqt5designercomponents5:armhf (5.11.3-4) ...
    Vormals nicht ausgewähltes Paket libqt5quickwidgets5:armhf wird gewählt.
    Vorbereitung zum Entpacken von .../16-libqt5quickwidgets5_5.11.3-4_armhf.deb ...
    Entpacken von libqt5quickwidgets5:armhf (5.11.3-4) ...
    Vormals nicht ausgewähltes Paket modemmanager wird gewählt.
    Vorbereitung zum Entpacken von .../17-modemmanager_1.10.0-1_armhf.deb ...
    Entpacken von modemmanager (1.10.0-1) ...
    Vormals nicht ausgewähltes Paket qtchooser wird gewählt.
    Vorbereitung zum Entpacken von .../18-qtchooser_66-2_armhf.deb ...
    Entpacken von qtchooser (66-2) ...
    Vormals nicht ausgewähltes Paket qdoc-qt5 wird gewählt.
    Vorbereitung zum Entpacken von .../19-qdoc-qt5_5.11.3-4_armhf.deb ...
    Entpacken von qdoc-qt5 (5.11.3-4) ...
    Vormals nicht ausgewähltes Paket qt5-assistant wird gewählt.
    Vorbereitung zum Entpacken von .../20-qt5-assistant_5.11.3-4_armhf.deb ...
    Entpacken von qt5-assistant (5.11.3-4) ...
    Vormals nicht ausgewähltes Paket qttools5-dev-tools wird gewählt.
    Vorbereitung zum Entpacken von .../21-qttools5-dev-tools_5.11.3-4_armhf.deb ...
    Entpacken von qttools5-dev-tools (5.11.3-4) ...
    iio-sensor-proxy (2.4-2) wird eingerichtet ...
    iio-sensor-proxy.service is a disabled or a static unit, not starting it.
    libqt5positioning5:armhf (5.11.3+dfsg-2) wird eingerichtet ...
    libqt5designercomponents5:armhf (5.11.3-4) wird eingerichtet ...
    libqt5qml5:armhf (5.11.3-4) wird eingerichtet ...
    libqt5webchannel5:armhf (5.11.3-2) wird eingerichtet ...
    libmm-glib0:armhf (1.10.0-1) wird eingerichtet ...
    libllvm7:armhf (1:7.0.1-8+rpi2) wird eingerichtet ...
    libclang1-7 (1:7.0.1-8+rpi2) wird eingerichtet ...
    libqt5sensors5:armhf (5.11.3-2) wird eingerichtet ...
    libqt5quick5:armhf (5.11.3-4) wird eingerichtet ...
    libmbim-glib4:armhf (1.18.0-1) wird eingerichtet ...
    qtchooser (66-2) wird eingerichtet ...
    qdoc-qt5 (5.11.3-4) wird eingerichtet ...
    geoclue-2.0 (2.5.2-1) wird eingerichtet ...
    geoclue.service is a disabled or a static unit, not starting it.
    libmbim-proxy (1.18.0-1) wird eingerichtet ...
    libqt5webkit5:armhf (5.212.0~alpha2-21+rpi1) wird eingerichtet ...
    libqt5quickwidgets5:armhf (5.11.3-4) wird eingerichtet ...
    qt5-assistant (5.11.3-4) wird eingerichtet ...
    qttools5-dev-tools (5.11.3-4) wird eingerichtet ...
    libqmi-glib5:armhf (1.22.0-1.2) wird eingerichtet ...
    libqmi-proxy (1.22.0-1.2) wird eingerichtet ...
    modemmanager (1.10.0-1) wird eingerichtet ...
    Created symlink /etc/systemd/system/dbus-org.freedesktop.ModemManager1.service → /lib/systemd/system/ModemManager.service.
    Created symlink /etc/systemd/system/multi-user.target.wants/ModemManager.service → /lib/systemd/system/ModemManager.service.
    Trigger für mime-support (3.62) werden verarbeitet ...
    Trigger für hicolor-icon-theme (0.17-2) werden verarbeitet ...
    Trigger für gnome-menus (3.31.4-3) werden verarbeitet ...
    Trigger für libc-bin (2.28-10+rpi1) werden verarbeitet ...
    Trigger für man-db (2.8.5-2) werden verarbeitet ...
    Trigger für dbus (1.12.16-1) werden verarbeitet ...
    Trigger für desktop-file-utils (0.23-4) werden verarbeitet ...
    pi@raspberrypi:~ $

  2. #2
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    11.12.2007
    Ort
    weit weg von nahe Bonn
    Alter
    34
    Beiträge
    3.328
    Das Design kommt mir bekannt vor, kann nur nicht sagen ob es Visual Studio oder WindowBuilder für Eclipse ist.

    Gibt es eine Äquivalent für Windoof? (Zur Not compile ich die DLL mit Borland oder Codebuilder++ und mache die Anwendung unter Linux Cross Compile)
    Es gibt 10 Sorten von Menschen: Die einen können binär zählen, die anderen
    nicht.

  3. #3
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    09.10.2014
    Beiträge
    4.505
    edit:
    sah gerade, dass man den Designer installieren muss, nicht den Creator (der darin enthalten sein soll).
    Wie ist denn nun die komplette, vollständige Installationsanleitung für den qt5 Designer samt aller nötigen libs und tools für den Raspi 2 mit Stretch?

    (ich krieg noch die Krise mit den unsäglichen umständlichen Linux-Installationen)
    ·±≠≡≈³αγελΔΣΩ∞ Schachroboter:www.youtube.com/watch?v=Cv-yzuebC7E Rasenmäher-Robot:www.youtube.com/watch?v=z7mqnaU_9A8

  4. #4
    Benutzer Stammmitglied Avatar von ces
    Registriert seit
    06.10.2018
    Beiträge
    89
    @HaWe
    Qt Designer Installation ist unabhängig von Qt Creator.
    Es genügt die genannte Zeile, ohne jegliche Vorarbeiten.
    Ergänzende vorgeschlagene Pakete für Qt Designer:
    qt5-qmltooling-plugins qt5-doc

    Qt Creator Installation ist unabhängig von Qt Designer:
    sudo apt-get install qtcreator
    https://wiki.ubuntuusers.de/Qt_Creator/
    Es genügt die genannte Zeile, ohne jegliche Vorarbeiten.
    Ergänzende vorgeschlagene Pakete für Qt Creator:
    clang-7-doc ncurses-doc libomp-7-doc llvm-7-doc qtbase5-dev clazy cmake
    kate-data subversion valgrind

    Das wars, mehr ist nicht nötig, alles in einem Rutsch.

    Problem ist das der Server von Raspbian spinnt, man muss einen guten Moment erwischen.
    [Verbindung mit raspbian.raspberrypi.org (2a00:1098:0:80:1000:75:0:3)]

    Code:
     
    pi@raspberrypi4:~ $ sudo apt install qtcreator 
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.       
    Statusinformationen werden eingelesen.... Fertig
    Die folgenden zusätzlichen Pakete werden installiert:
      binfmt-support clang clang-7 libbotan-2-9 libclang-common-7-dev libclang1-7
      libffi-dev libgc1c2 libllvm7 libncurses-dev libncurses6 libncursesw6
      libobjc-8-dev libobjc4 libomp-7-dev libomp5-7 libqbscore1.12
      libqbsqtprofilesetup1.12 libqt5designercomponents5 libqt5positioning5
      libqt5qml5 libqt5quick5 libqt5quicktest5 libqt5quickwidgets5 libqt5script5
      libqt5sensors5 libqt5webchannel5 libqt5webkit5 libqt5xmlpatterns5
      libtinfo-dev libtinfo6 libtspi1 llvm-7 llvm-7-dev llvm-7-runtime qbs-common
      qdoc-qt5 qml-module-qtgraphicaleffects qml-module-qtqml-models2
      qml-module-qtquick-controls qml-module-qtquick-layouts
      qml-module-qtquick-window2 qml-module-qtquick2 qmlscene qt3d5-doc
      qt5-assistant qt5-doc qt5-qmltooling-plugins qtbase5-dev-tools qtbase5-doc
      qtcharts5-doc qtchooser qtconnectivity5-doc qtcreator-data qtcreator-doc
      qtdeclarative5-dev-tools qtdeclarative5-doVorgeschlagene Pakete:
      clang-7-doc ncurses-doc libomp-7-doc llvm-7-doc qtbase5-dev clazy cmake
      kate-data subversion valgrindc qtgraphicaleffects5-doc
      qtlocation5-doc qtmultimedia5-doc qtquickcontrols2-5-doc
      qtquickcontrols5-doc qtscript5-doc qtsensors5-doc qtserialport5-doc
      qtsvg5-doc qttools5-dev-tools qttools5-doc qtvirtualkeyboard5-doc
      qtwayland5-doc qtwebchannel5-doc qtwebengine5-doc qtwebsockets5-doc
      qtwebview5-doc qtx11extras5-doc qtxmlpatterns5-dev-tools qtxmlpatterns5-doc
    Vorgeschlagene Pakete:
      clang-7-doc ncurses-doc libomp-7-doc llvm-7-doc qtbase5-dev clazy cmake
      kate-data subversion valgrind
    Die folgenden NEUEN Pakete werden installiert:
      binfmt-support clang clang-7 libbotan-2-9 libclang-common-7-dev libclang1-7
      libffi-dev libgc1c2 libllvm7 libncurses-dev libobjc-8-dev libobjc4
      libomp-7-dev libomp5-7 libqbscore1.12 libqbsqtprofilesetup1.12
      libqt5designercomponents5 libqt5positioning5 libqt5qml5 libqt5quick5
      libqt5quicktest5 libqt5quickwidgets5 libqt5script5 libqt5sensors5
      libqt5webchannel5 libqt5webkit5 libqt5xmlpatterns5 libtinfo-dev libtspi1
      llvm-7 llvm-7-dev llvm-7-runtime qbs-common qdoc-qt5
      qml-module-qtgraphicaleffects qml-module-qtqml-models2
      qml-module-qtquick-controls qml-module-qtquick-layouts
      qml-module-qtquick-window2 qml-module-qtquick2 qmlscene qt3d5-doc
      qt5-assistant qt5-doc qt5-qmltooling-plugins qtbase5-dev-tools qtbase5-doc
      qtcharts5-doc qtchooser qtconnectivity5-doc qtcreator qtcreator-data
      qtcreator-doc qtdeclarative5-dev-tools qtdeclarative5-doc
      qtgraphicaleffects5-doc qtlocation5-doc qtmultimedia5-doc
      qtquickcontrols2-5-doc qtquickcontrols5-doc qtscript5-doc qtsensors5-doc
      qtserialport5-doc qtsvg5-doc qttools5-dev-tools qttools5-doc
      qtvirtualkeyboard5-doc qtwayland5-doc qtwebchannel5-doc qtwebengine5-doc
      qtwebsockets5-doc qtwebview5-doc qtx11extras5-doc qtxmlpatterns5-dev-tools
      qtxmlpatterns5-doc
    Die folgenden Pakete werden aktualisiert (Upgrade):
      libncurses6 libncursesw6 libtinfo6
    3 aktualisiert, 75 neu installiert, 0 zu entfernen und 184 nicht aktualisiert.
    Es müssen noch 224 MB von 224 MB an Archiven heruntergeladen werden.
    Nach dieser Operation werden 608 MB Plattenplatz zusätzlich benutzt.
    Möchten Sie fortfahren? [J/n]
    @

    - - - Aktualisiert - - -

    Raspi 2 mit Stretch folgt.

    @Ceos
    Ja gibts https://build-system.fman.io/qt-designer-download

  5. #5
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    09.10.2014
    Beiträge
    4.505
    ach so, verstehe ich es richtig:

    sudo apt install qttools5-dev-tools

    installiert den Designer (?) mit allen Zusatzlibs und tools und packages und creator und dem ganzen Rest, dass man sofort loslegen kann?
    (plus das vorgeschlagene
    sudo apt install qt5-qmltooling-plugins qt5-doc)
    ·±≠≡≈³αγελΔΣΩ∞ Schachroboter:www.youtube.com/watch?v=Cv-yzuebC7E Rasenmäher-Robot:www.youtube.com/watch?v=z7mqnaU_9A8

  6. #6
    Benutzer Stammmitglied Avatar von ces
    Registriert seit
    06.10.2018
    Beiträge
    89
    Ja, allerdings ohne qtcreator.
    sudo apt install qttools5-dev-tools
    sudo apt install qt5-qmltooling-plugins qt5-doc


    Sehe gerade das
    sudo apt install qtcreator
    den qtdesigner mit installiert.

    Also das volle Brett:
    sudo apt install qtcreator
    sudo apt install qt5-qmltooling-plugins qt5-doc
    sudo apt install clang-7-doc ncurses-doc libomp-7-doc llvm-7-doc qtbase5-dev clazy cmake kate-data subversion valgrind
    Geändert von ces (09.09.2019 um 16:49 Uhr)

  7. #7
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    09.10.2014
    Beiträge
    4.505
    Zitat Zitat von ces Beitrag anzeigen
    Sehe gerade das
    sudo apt-get install qtcreator
    den qtdesigner mit installiert.

    Also das volle Brett:
    sudo apt-get install qtcreator
    sudo apt install qt5-qmltooling-plugins qt5-doc
    sudo apt install clang-7-doc ncurses-doc libomp-7-doc llvm-7-doc qtbase5-dev clazy cmake kate-data subversion valgrind
    jaaaa... stimmt, hatte ich auch irgendwann gelesen, aber dann nicht mehr wieder gefunden:

    Des Weiteren ist Qt Designer in der Entwicklungsumgebung Qt Creator integriert.
    vielen, vielen Dank!
    mach mich baldmöglichst dran!
    ·±≠≡≈³αγελΔΣΩ∞ Schachroboter:www.youtube.com/watch?v=Cv-yzuebC7E Rasenmäher-Robot:www.youtube.com/watch?v=z7mqnaU_9A8

  8. #8
    Benutzer Stammmitglied Avatar von ces
    Registriert seit
    06.10.2018
    Beiträge
    89
    Hab mich vertippt mit apt-get und apt. apt-get ist deprecated (überholt, veraltet). Ändere es noch.

  9. #9
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    09.10.2014
    Beiträge
    4.505
    jap, alles klar!

    btw: kennst du eine Angabe, wieviel Platz das ganze qt5 auf der Raspi SD benötigt?


    PS

    und noch was gefunden:
    Voraussetzungen

    Um Anwendungen mit Qt Creator zu erstellen, muss Qt installiert sein.
    also das dann doch noch vorher zusätzlich?????

    sudo apt install qt5-default
    Geändert von HaWe (09.09.2019 um 17:02 Uhr)
    ·±≠≡≈³αγελΔΣΩ∞ Schachroboter:www.youtube.com/watch?v=Cv-yzuebC7E Rasenmäher-Robot:www.youtube.com/watch?v=z7mqnaU_9A8

  10. #10
    Benutzer Stammmitglied Avatar von ces
    Registriert seit
    06.10.2018
    Beiträge
    89
    Nein
    https://packages.debian.org/buster/qt5-default

    QtCreator:
    Es müssen noch 224 MB von 224 MB an Archiven heruntergeladen werden.
    Nach dieser Operation werden 608 MB Plattenplatz zusätzlich benutzt.

    Plus die Vorschläge.
    Geändert von ces (09.09.2019 um 17:18 Uhr)

Seite 1 von 8 123 ... LetzteLetzte

Ähnliche Themen

  1. Altium Designer 14
    Von Roboternetz-News im Forum Neuigkeiten / Technik-News / Nachrichten / Aktuelles
    Antworten: 0
    Letzter Beitrag: 24.10.2013, 09:40
  2. Altium Designer 12 angekündigt
    Von Roboternetz-News im Forum Neuigkeiten / Technik-News / Nachrichten / Aktuelles
    Antworten: 0
    Letzter Beitrag: 15.03.2012, 12:20
  3. Layout Designer
    Von Zeroeightfifteen im Forum Konstruktion/CAD/Sketchup und Platinenlayout Eagle & Fritzing u.a.
    Antworten: 1
    Letzter Beitrag: 04.12.2006, 09:36
  4. C++ Builder 5 + Threads + Objekte
    Von lion1984 im Forum Software, Algorithmen und KI
    Antworten: 5
    Letzter Beitrag: 30.08.2006, 11:56
  5. Robot Builder´s Bonanza
    Von Fabian im Forum Buchempfehlungen
    Antworten: 14
    Letzter Beitrag: 20.05.2005, 10:50

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •