-         
Ergebnis 1 bis 3 von 3

Thema: ArduiTouch - Display bleibt dunkel - Transistor schaltet nicht

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    02.05.2007
    Beiträge
    23

    Frage ArduiTouch - Display bleibt dunkel - Transistor schaltet nicht

    Anzeige

    Hallo Zusammen

    Ich habe mir ein ArduiTouch besorgt und zusammengelötet. Ich betreibe es mit einem ESP-32.
    Leider bleibt mein Display dunkel. Nach einigen Tests habe ich den Fehler gefunden.
    Am Transistor T1 (siehe Schaltplan auf der rechten Seite oben) liegt an der Basis 3.3V an. Am Emitter liegen auch 3.3V an. Leider messe ich am Collector aber 0V.

    Ich habe das Display auf einem Breadboard direkt mit Spannung versorgt und 3.3V an den LED-Pin angelegt. Tadaaaa: Das Display leuchtet.

    Erster Gedanke, okay, der Transistor hat beim Löten etwas zu viel Wärme abgekriegt.
    Ich habe mir neue BC557 bestellt und einen neuen Transistor eingelötet. Leider hat dies keine Verbesserung gebracht.

    Ich habe nun den Versuchsaufbau auf dem Breadboard um den Transistor und einen 1kOhm Widerstand an der Basis ergänzt und leider bleibt das Display auch dort dunkel

    Hat einer eine Idee was ich falsch mache? Soweit ich im Internet lesen kann haben andere das ArduiTouch zum laufen gebracht. Ich denke also nicht, dass der Schaltplan generell einen Fehler aufweisen wird...

  2. #2
    Erfahrener Benutzer Robotik Einstein Avatar von 021aet04
    Registriert seit
    17.01.2005
    Ort
    Niklasdorf
    Alter
    31
    Beiträge
    4.799
    Das ist ein PNP-Transistor, dieser sperrt bei einem Highsignal an der Basis. Lege B auf Masse, dann sollte er funktionieren (den GPIO auf Masse schalten, nicht den Pin direkt auf Masse legen).

    MfG Hannes

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    02.05.2007
    Beiträge
    23
    Oh mein Gott

    Vielen Dank Hannes... naja.. Software-Entwickler mit kleinen Elektronikkenntnissen... und normalerweise immer mit NPN-Transistoren unterwegs...

    Hab mich durch ein Demo-Code für die Display-Ansteuerung in die Irre führen lassen, da dort

    digitalWrite(TFT_LED, HIGH); // Display-Beleuchtung einschalten

    geschrieben stand... und ich somit völlig falsch interpretiert habe, dass dies beim ArduiTouch auch so funktionieren soll...

    Es funktioniert nun super, nochmals danke für die rasche Antwort.

    Gruess
    Chruttli

Ähnliche Themen

  1. Antworten: 7
    Letzter Beitrag: 04.09.2016, 14:12
  2. Terminalemulator bleibt dunkel...
    Von display im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 11
    Letzter Beitrag: 27.09.2015, 16:48
  3. Transistor schaltet nicht richtig
    Von -Hurricane- im Forum Elektronik
    Antworten: 17
    Letzter Beitrag: 20.08.2014, 21:33
  4. Transistor schaltet ungewollt Strom durch
    Von xxxmicroxxx im Forum Elektronik
    Antworten: 11
    Letzter Beitrag: 30.12.2013, 18:40
  5. Antworten: 13
    Letzter Beitrag: 24.10.2005, 13:52

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •