-         
Ergebnis 1 bis 5 von 5

Thema: Kleinere Fragen zu einem Eagle Projekt

  1. #1

    Kleinere Fragen zu einem Eagle Projekt

    Anzeige

    Moin Leute,

    wir machen für die Uni ein kleines Projekt, bei dem wir eine Platine für einen MCU zur Regelung eines Schaltaktors entwerfen müssen. Da ich zuvor noch nie mit Platinenentwurf, geschweige denn Eagle gearbeitet hab, hoffe ich hier ein bisschen Feedback zur Vorgehensweise, eventuellen Fehlern und auch Antwort auf ein paar Fragen zu bekommen. Zunächst zu meinem Vorgehen: Ich hab die Bauteile als ECAD Datei in eine Library hinzugefügt, ein Schematic erstellt, und alles angeschlossen. Soweit so gut, das ging ohne Probleme. Dann hab ich ein Board erstellt, die Bauteile angeordnet und zunächst einmal die relevanten großen Leiterbahnen gelegt.

    Klicke auf die Grafik für eine größere Ansicht

Name:	BoardB1.jpg
Hits:	10
Größe:	95,7 KB
ID:	34001

    V_MOT_PL und V_MOT_MIN und einen Teil von V12(12V Anschluss) hab ich als Polygon erstellt und dann dem jeweiligen Signal zugewiesen. Grund für die Wahl als Polygon ist der hohe Strom, der kurzzeitig im Bereich von 50A fließen soll. Weiterhin hab ich noch die Grundrichtung für V12 zu den Voltage-Regulatoren und die folgende Versorgungsschiene V33 in Richtung MCU gelegt. Dann wollte ich Autorouten (ich weiß, eher ungerne gesehen, geht jetzt gerade auch eher um allgemeine Sachen, ich route später noch selbst), aber der hat immer die Polygone zerschossen, also hab ich die "gefährlichen Leitungen" noch manuell verlegt (dazu vielleicht Tipps?). Dann hat das Autorouten funktioniert:

    Klicke auf die Grafik für eine größere Ansicht

Name:	BoardB2.jpg
Hits:	11
Größe:	95,1 KB
ID:	34003

    Sieht für mein ungelerntes Auge nicht so schlimm aus, also gehe ich erstmal davon aus, dass das passt. Zusätzlich habe ich zur besseren Groundverbindung zwischen oberem und unterem Layer noch zwei Vias (im Bild gelb umkreist) gesetzt, damit ich beim erstellen der Ground-Polygone gute Verbindungspunkte zwischen oberem und unterem Layer bekomme (erschien mir sinnvoll, ist vielleicht auch Quatsch?). Den Vias habe ich als Signal GND zugewiesen. Beim erstellen der Polygone sieht das irgendwie komisch aus, sodass ich glaube, dass die nicht mit den GND-Polygonen verbunden sind. Hab ich da einen Fehler gemacht, dass er die gar nicht als richtige Vias akzeptiert?

    Klicke auf die Grafik für eine größere Ansicht

Name:	BoardB3.jpg
Hits:	10
Größe:	64,0 KB
ID:	34004 Klicke auf die Grafik für eine größere Ansicht

Name:	GND_VIAs.jpg
Hits:	4
Größe:	43,1 KB
ID:	34006

    Dann wollte ich noch unter meine Halbbrücken thermische Vias setzen, dazu also darunter noch ein Polygon erstellt mit der selben Potentialzuweisung wie die Fläche unter dem Bauteil, also V_MOT_PL bzw. ..._MIN.

    Klicke auf die Grafik für eine größere Ansicht

Name:	thermalVias.JPG
Hits:	11
Größe:	66,9 KB
ID:	34005

    Wenn ich auf diese Fläche dann Vias setzen möchte, zweigt er mir die allerdings als fehlerhaft an. Hat jemand eine Erklärung warum? Muss ich dabei anders vorgehen?

    Ich hoffe mal man erkennt auf den Bildern genug, wenn nicht, kann ich die auch nochmal detaillierter uploaden. Zerreißt mich bitte nicht, wie gesagt ich bin ein blutiger Anfänger! Hauptsächlich ist meine Angst halt, dass ich grobe Schnitzer begangen habe und die Platine die bestellt wird für Prototyping-Zwecke deswegen dann für die Katz' ist.

    Liebe Grüße und schonmal vielen Dank,
    Johannes
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken BoardB1.JPG   BoardB2.jpg  

  2. #2
    Erfahrener Benutzer Robotik Einstein Avatar von wkrug
    Registriert seit
    17.08.2006
    Ort
    Dietfurt
    Beiträge
    2.043

  3. #3
    Danke für die schnelle Antwort! Das Problem was ich habe spricht er allerdings nicht an. Ich glaube es liegt an dem Footprint meiner Halbbrücke, bei dem das Toplayer für den 8-er Pin ziemlich groß definiert wurde:

    Klicke auf die Grafik für eine größere Ansicht

Name:	footprintHB.JPG
Hits:	7
Größe:	41,3 KB
ID:	34007

    und genau in diesem Bereich kann ich keine Vias setzen. Gibt es eine Möglichkeit diese Fläche als Durchkontaktierbar zu definieren?

  4. #4
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    05.11.2007
    Ort
    Berlin
    Beiträge
    917
    Hallo Johannes,

    du kannst mit den Einstellungen bei DRC den Abstand von Vias zu den SMDs einstellen.
    Den Wert setzt Du auf 0.
    Dann meckert er die VIAs im PAD nicht mehr an,
    solange sie den gleichen Netznamen haben wie die Leitung am Pad.
    Macht man eigentlich nicht, aber als Notlösung



    Klicke auf die Grafik für eine größere Ansicht

Name:	eagle_DRC.jpg
Hits:	4
Größe:	47,4 KB
ID:	34010

    Ob deine VIAs an GND liegen kannst Du recht einfach prüfen.
    Klicke im Menü auf das "i" Info, dann auf dein VIA. Dort steht wo die Leitung angeschlossen ist.

    Klicke auf die Grafik für eine größere Ansicht

Name:	Via1.png
Hits:	5
Größe:	44,9 KB
ID:	34011


    Wenn Du nur TOP Pads und Vias einblendest, Bottom weg.
    und dann "show GND" eingibst, sieht man es meist besser wer da an GND hängt:

    Klicke auf die Grafik für eine größere Ansicht

Name:	Eagle_GND.jpg
Hits:	2
Größe:	100,8 KB
ID:	34012

    Siro

    PS: warum sieht man eigentlich die Bilder nicht, wenn man eingelogged ist....
    Geändert von Siro (19.02.2019 um 14:48 Uhr)

  5. #5
    Hey Siro, sehr gut, das waren die beiden Sachen die ich gesucht hab, perfekt! Inzwischen hab ich auch mit dem Plateninenhersteller telefoniert und der meinte Overlapping sei in dem Fall prinzipiell kein Problem und sie kontrollieren das sowieso nochmal alles.
    Danke

Ähnliche Themen

  1. Fragen zu einem PanTilt-Projekt
    Von inxtremo im Forum Mechanik
    Antworten: 2
    Letzter Beitrag: 24.04.2012, 15:17
  2. erstes Eagle Projekt --Ein paar Fragen bzw. Unklarheiten--
    Von hdtvfreak im Forum Konstruktion/CAD/Sketchup und Platinenlayout Eagle & Fritzing u.a.
    Antworten: 5
    Letzter Beitrag: 30.12.2007, 21:27
  3. Projekt von einem Neuling
    Von stupidman im Forum Vorstellung+Bilder+Ideen zu geplanten eigenen Projekten/Bots
    Antworten: 1
    Letzter Beitrag: 08.06.2007, 21:48
  4. Brauche Hilfe bei einem Projekt
    Von DJMetro im Forum PIC Controller
    Antworten: 9
    Letzter Beitrag: 16.08.2005, 22:55
  5. Fragen für Bluetooth Projekt
    Von Schallhofer im Forum Controller- und Roboterboards von Conrad.de
    Antworten: 0
    Letzter Beitrag: 31.03.2004, 13:58

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •