-         
Ergebnis 1 bis 4 von 4

Thema: Schaltungsproblem bei Differenzverstärke für Li-Ion BMS

  1. #1

    Schaltungsproblem bei Differenzverstärke für Li-Ion BMS

    Anzeige

    Hallo,
    momentan arbeite ich an einem Hochleistungsbalancer für einen großen Li-Ion Akku (24V - 7s).

    Zum Auswerten der einzelnen Zellenspannungen möchte ich einen T074 als Differnzverstärker benuzten.

    Jedoch funktioniert es nicht so wie ich es mir ausgedacht habe.
    Bei der Messung von Zelle 1 bekomme ich nur 3,5V was zu niedrig istm bei Zelle 2 bekomme ich 4,2 was ok wäre, bei den restlichen Zelle bekomme ich 5,5V.
    Die Versorgung des Operantionsverstärkers ist 5V deshalb verstehle ich nicht wie die 5,5V am Ausgang zustande kommen.
    Die Widerstände am OpAmp sind alle 0,1% genau.

    Ich hoffe ihr könnt mir weiterheilfen.


    Der Differenzverstärker soll mit einer 1:1 Verstärkung arbeiten, da die maximale Zellenspannung nur 4,2V beträgt.
    Ich benutze keinen Spannungsteiler, weil mir mit dem OP-Amp eine höhre Genauigkeit erhofft habe.


    Vielen Dank im vorraus.

    Anbei der Schaltplan
    Klicke auf die Grafik für eine größere Ansicht

Name:	bal.jpg
Hits:	21
Größe:	54,0 KB
ID:	33923

    Hohe Auflösung:
    https://i.imgur.com/VKfemTU.jpg
    Geändert von zerobob (06.01.2019 um 20:15 Uhr)

  2. #2
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    05.11.2007
    Ort
    Berlin
    Beiträge
    934
    Hallo,

    Ehrlich gesagt verstehe ich deine Schaltung nicht.
    Wo kommt denn da der Akku dran ? bzw. die Zellen des Balancersteckers

    Wenn ich alle Mosfets durchschalte, habe ich einen Kurzschluss zwischen +24V und Masse.
    Wäre per Software möglich, sollte man unbedingt vermeiden.

    Nun zu Messung selbst, wenn ich falsch liege, verbessert mich bitte:
    Du betreibst die Operationsverstärker mit +5 Volt.
    An den Eingängen liegen aber bis zu 24 Volt an.
    Ich glaube das mögen die OPs nicht sonderlich. Da werden intern irgendwelche PN Übergänge
    Schutzdioden oder was auch immer leitend, das erklärt auch die eigentlich unmögliche Ausgangsspannung.
    Für Eingangsspannugnen größer der Versorgungsspannung gibt es sogenannte "Over The Top" Verstärker,
    dDie weit über den Versorgungsspannungsbereich arbeiten können.
    Der Standard OP hat da wohl eher Probleme.
    Man könnte aber die OPs direkt vom Akku, also mit 24V Volt bertreiben.

    Der Differenzverstärker an sich ist schon okay und je nach Zelle steigt das Common Mode Signal,
    das sollte bei entsprechend hoher Versorgungsspannung des OPs kein Problem darstellen.

    Siro
    Geändert von Siro (07.01.2019 um 20:23 Uhr)

  3. #3
    Danke für deine Antwort. Der Grund mein Problem war wirklich die zu geringe Versorgungsspannung.
    Sie liegt jetzt auf +24V und die gemessenen Spannungen stimmen.

    Die Widerstände sowie die Zellen werden über die Schraubklemmen angeschlossen. Deshalb sind sie nicht im Schaltplan zu sehen.

    Ich hatte auch noch einen Fehler bei dem unbeschalteten Op. Es sollte out auf minus und + auf gnd sein
    Geändert von zerobob (08.01.2019 um 07:47 Uhr)

  4. #4
    Erfahrener Benutzer Fleißiges Mitglied Avatar von avr_racer
    Registriert seit
    01.04.2014
    Ort
    MecklenburgVorpommern
    Beiträge
    164
    Guten Morgen,

    würde noch die Ansteuerung der der P-MosFets ändern 24V-Ugs(2V-4V) = Ug ca 20-22V. Ug(20V-22V) -5V des ULN machen an R37 ein Sannungsfall von 15-17V. Der Fet ist nicht richtig gesperrt eher beträgt der Kanal-Widerstand mehrere kOhm.

    Würde den ULN rausschmeißen und jeden P-Mos über einen BS170 ansteuern sowie den R38 auf 100R-1K abändern damit der P-Mos schneller ab/zuschaltet. hat was mit Umladeströmen des Gate zu tun was ein Kapazität ist.
    Drain des BS170 ans Gate des P-Mos sowie R38an 24V vom Gate-P-Mos und Drain des BS170, Gate des BS170 über 10k an Masse und mit 100R weiter zum Arduino, Source des BS170 auf Masse. Sichere Zustände beim Einschalten da nun nichts von selbst durchsteuert.

    Zum TL07x kann am Eingang typ bis -+Ub sein, am Ausgang kommt er an die -+Ub aber nicht ganz mit ca +-1,5V Abstand.
    Unbeschaltete OPV's entweder beide Eingänge auf Masse, Ausgnag bleibt frei. Oder so wie du es schon abgeändert hast.

    Andere Möglichkeiten wären gleich ausgelegte Differenzverstärker zu nutzen die können auch am Eingang mehr als ihre UB

Ähnliche Themen

  1. Schaltungsproblem: 6 pwm out auf 1 gemeinsamen NF-Verstärker-Eingang?
    Von Ford Prefect im Forum Arduino -Plattform
    Antworten: 10
    Letzter Beitrag: 25.06.2014, 20:09
  2. Antworten: 25
    Letzter Beitrag: 01.07.2008, 23:58
  3. Schaltungsproblem: Spannung bleibt nicht stabil
    Von JanNeustein im Forum Elektronik
    Antworten: 3
    Letzter Beitrag: 24.06.2008, 20:10
  4. Schaltungsproblem mit 74121
    Von pic18fx im Forum Elektronik
    Antworten: 5
    Letzter Beitrag: 03.11.2007, 16:00
  5. AVR-Schaltungsproblem
    Von Rahvin im Forum AVR Hardwarethemen
    Antworten: 17
    Letzter Beitrag: 16.07.2007, 10:16

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •