-         
Ergebnis 1 bis 9 von 9

Thema: Pony2000 Serial Problem

  1. #1
    Benutzer Stammmitglied Avatar von Der bastler
    Registriert seit
    09.05.2011
    Ort
    Langenhorn, Hamburg, Germany, Germany
    Beiträge
    52
    Blog-Einträge
    1

    Frage Pony2000 Serial Problem

    Anzeige

    Hallo Forum und Bastler
    Ich benutze ein Atmel Evaluationboard Ver.2.01 Von Pollin.
    So zu mein problem:
    Der seriale eingang um ISP zu Programieren Funktioniert Reingarnicht, am RS232 Eingang Kann ich im Terminal texte und Daten Anzeigen lassen.

    Ich habe an meinen PC ein Serialen Anschluss da geht der ISP Garnicht kommt Device(-24) aber der RS232 Geht.
    jetzt habe ich ein USB auf Serial adabter da geht der ISP auch nicht Device(-24) aber der RS232 Geht wunderbar.

    Ich bitte euch kann mir Helfen oder verleicht eine Seriale oder LPT Adabter Platine für bin für jeden rat und Tipps Hilfreich.

    Gruß Th.Sch.

    Ach so ich benutze die version von PonyProg2000 Ver. 3.0.0 Oct 1 2017
    Geändert von Der bastler (31.10.2018 um 19:32 Uhr) Grund: Benachrichtigung

  2. #2
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.202
    Hallo Bastler
    Hast du im PonyProg alle Einstellungen vorgenommen und alle Tests gemacht?
    USB-Serial Adapter funktionieren nicht oder nur so langsam das es in der Regel zu einem Abbruch kommt.
    Grüsse Hubert
    ____________

    Meine Projekte findet ihr auf schorsch.at

  3. #3
    Benutzer Stammmitglied Avatar von Der bastler
    Registriert seit
    09.05.2011
    Ort
    Langenhorn, Hamburg, Germany, Germany
    Beiträge
    52
    Blog-Einträge
    1
    Ja habe ich wie immer alles gemacht was Ponypor2000 Möchte nichts rein garnichts immer die selbe fehler meldung
    Device(-24), dann habe ich einen USB nach serial versucht leider der selbe fehler.
    Und das am 3 PC`s.
    ich bin am verzweifeln, hab sogar den Pc komplett Platt gemacht festplatte komplett gelöscht sogra die Partiton hab ich auch komplett neu gemacht....

    Ich BITTTTTEEEEE um HIlfe sowie Rat
    DANKE

  4. #4
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.202
    Hat das schon mal funktioniert?
    Was ist im IO-Port Setup eingestellt?
    Was kommt bei Probe?
    Grüsse Hubert
    ____________

    Meine Projekte findet ihr auf schorsch.at

  5. #5
    Benutzer Stammmitglied Avatar von Der bastler
    Registriert seit
    09.05.2011
    Ort
    Langenhorn, Hamburg, Germany, Germany
    Beiträge
    52
    Blog-Einträge
    1
    Ohja mit den aller ersten Pollin evaluation board als bausatz.
    hierKlicke auf die Grafik für eine größere Ansicht

Name:	<a href=ISP einstellung.PNG Hits: 5 Größe: 9,9 KB ID: 33734" class="thumbnail" style="float:CONFIG" />
    und bei der probe kommt OK

    Und nu

  6. #6
    Erfahrener Benutzer Robotik Visionär Avatar von oberallgeier
    Registriert seit
    01.09.2007
    Ort
    Oberallgäu
    Beiträge
    7.769
    Ja habe ich wie immer alles gemacht was Ponypor2000 Möchte .. dann habe ich einen USB nach serial versucht leider der selbe fehler ..
    Soweit ich weiß braucht man für die Programmierung über ne serielle Schnittstelle fürs PonyProg einen Pegelumsetzer. Ohne Umsetzer läuft das nur mit ner alten Centronics - siehe hier. (gibts noch funktionierende Rechner mit ner >richtigen< Druckerschnittstelle?

    Zum USB<=>Seriell-Umsetzer hat eben Hubert Bedenken angemeldet. Ich kann die nur teilen, ich hatte etliche dieser Wunderdinge benutzt (teils geliehen) aber nur zwei hatten wirklich funktioniert - als RS232-Schnittstelle - fürs PonyProg hatte ich die nie benutzt. Ich hatte vor etlichen Jahren PonyProg benutzt - aber nicht lange. Die von mir benutzten Con troller wurden schon bald von Ponyprog nicht mehr "betreut", daher bin ich schnell auf den üblichen ISP-Programmer nach STK500-Protokoll gekommen. Klar - das war bisher keine Hilfe für Dich.

    Möglicherweise hilft Dir weiter
    dies und
    dies.

    Dabei sind auch Verweise auf die beim Seriell-Programmieren benutzten Zwischeneinbauten.
    Ciao sagt der JoeamBerg

  7. #7
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.202
    Wenn bei Probe ein OK kommt, dann sollte aber auch alles funktionieren.
    Auf meinem PC ist die serielle Schnittstelle COM1, alles höher sind USB-Devices. Daher wundert mich dein COM5, kann aber durchaus stimmen.
    Ich verwende PonyProg allerdings aus den von Oberallgeier genannten Gründen ebenfalls schon einige Jahre nicht mehr.
    Grüsse Hubert
    ____________

    Meine Projekte findet ihr auf schorsch.at

  8. #8
    Benutzer Stammmitglied Avatar von Der bastler
    Registriert seit
    09.05.2011
    Ort
    Langenhorn, Hamburg, Germany, Germany
    Beiträge
    52
    Blog-Einträge
    1
    Hallo Hubert
    erst mal danke für die tipps, beim durch lesen ist mir der Pararell ISP adapter sehr interrissant, kann man den nachbauen

  9. #9
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.202
    Kann nicht sagen ob der Parallel-Programmer heute mit Win7 oder Win10 überhaupt noch funktioniert. Den hatte ich mit XP und Win95 in Betrieb. Heute habe ich keine parallele Schnittstelle mehr, USB Adapter funktionieren nicht.
    PonyProg hat ja auch das Problem das neuere AVR nicht unterstützt werden.
    Grüsse Hubert
    ____________

    Meine Projekte findet ihr auf schorsch.at

Ähnliche Themen

  1. Frage/Problem zu software-serial
    Von Andree-HB im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 2
    Letzter Beitrag: 05.02.2012, 18:38
  2. Problem mit Serial Port (empfang)
    Von Tredory im Forum PC-, Pocket PC, Tablet PC, Smartphone oder Notebook
    Antworten: 1
    Letzter Beitrag: 07.03.2009, 18:23
  3. Serial Kabel problem...
    Von Knuspersuppe im Forum Elektronik
    Antworten: 7
    Letzter Beitrag: 13.11.2006, 18:58
  4. habe problem mit usb to serial
    Von Turbo Dengel im Forum Robby CCRP5
    Antworten: 1
    Letzter Beitrag: 28.09.2006, 12:29
  5. Linux Serial Port Problem
    Von PistolPete im Forum Controller- und Roboterboards von Conrad.de
    Antworten: 7
    Letzter Beitrag: 09.01.2005, 14:27

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •