-         
Ergebnis 1 bis 2 von 2

Thema: Seltsames Verhalten bei AVRISP-MkII - Frage

  1. #1

    Seltsames Verhalten bei AVRISP-MkII - Frage

    Anzeige

    Hallo,

    ich habe ein seltsames Phänomen festgestellt. Habe auf dem Schreibtisch mit dem AVRISP-MkII auf mehrere ATmega328 den Bootloader geschrieben. Zur selben Zeit hatte ich eine andere Schaltung auf Arduino-Basis auf dem Schreibtisch im Testlauf. Diese Testschaltung war NICHT am Computer angeschlossen, sondern nur per Netzteil mit Strom versorgt. Sowohl Bootloader als auch Testschaltung hatten also keine gemeinsame Verbindung z.B. über USB o.ä., ausser dass beide letztlich am 230V-Stromnetz hängen. Beide Schaltungen lagen etwa im Abstand von ca. 15 cm auseinander. Es gab zunächst keinerlei Probleme. Als ich jedoch den AVRISP-MkII nach Beendigung der Bootloader-Sachen aus dem USB-Port rauszog, ging meine Testschaltung aus. Die Testschaltung ist z.Z. auf einem Steckbrett installiert und ist korrekt aufgebaut, Puffern der Stromversorgung (Kondensatoren usw.) alles vorhanden. Die Testschaltung besteht aus einem "reduzierten" Arduino Uno. Es sind also nur die Bauteile verwendet, die für den Betrieb der Arduino-Schaltung notwendig sind, jedoch kein USB-Port usw. Nur die PIN sind belegt, die benötigt werden. Ebenso Reset. Alle nötigen PIN des 328 sind abgefangen mit Widerständen gegen "Plus", um ein stabiles "1" bzw. "0" Potential zu gewährleisten. Für die Stromversorgung der Testschaltung habe ich eine übliche Schaltung mit 7805 verwendet.

    Woran kann das liegen? Ist es möglich, das der AVRISP-MkII beim Abschalten eine Art "Funksignal" sendet, welches auf die Testschaltung einen solchen Einfluss hat? Was kann ich machen, damit solche Einflüsse nicht stattfinden und die Testschaltung ohne solche Störungen läuft?


    Andi

  2. #2
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    18.03.2018
    Beiträge
    356
    Wackelkontakt auf dem Steckbrett vielleicht? Deine Testschaltung könnte durch einen EMP zerstört werden, aber es ist anzunehmen, dass keiner erzeugt wurde, der die Schaltung beeinflusst Schwer zu sagen, was sich da abgespielt hat.

    MfG

Ähnliche Themen

  1. Neuling hat Frage zu AVR Programmmer AVRISP mkII
    Von Redpedro im Forum AVR Hardwarethemen
    Antworten: 2
    Letzter Beitrag: 26.05.2013, 21:32
  2. AVRISP mkII
    Von mycroc im Forum AVR Hardwarethemen
    Antworten: 10
    Letzter Beitrag: 01.01.2012, 13:22
  3. Frage zum Verhalten meines AVRISP mkII
    Von vali im Forum AVR Hardwarethemen
    Antworten: 13
    Letzter Beitrag: 20.02.2011, 23:06
  4. seltsames Verhalten am I2C
    Von liquidus im Forum Elektronik
    Antworten: 12
    Letzter Beitrag: 06.12.2009, 18:42
  5. Seltsames verhalten
    Von Atmelbeginne im Forum Microcontroller allgemeine Fragen/Andere Microcontroller
    Antworten: 6
    Letzter Beitrag: 10.12.2008, 19:37

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •