-         
Seite 3 von 4 ErsteErste 1234 LetzteLetzte
Ergebnis 21 bis 30 von 31

Thema: Arduino soll Schrittmotor NEMA 17 ansteuern; Driver: DRV8825

  1. #21
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    03.04.2013
    Beiträge
    449
    Anzeige

    Gruseliger "Schaltplan", aber egal.
    Es scheint mir, daß dein Treiberbaustein defekt ist. Die gemessenen Ausgangsspannungen sind mit oder ohne angeschlossenen Motor? Ändert sich die Polarität, wenn man einen Step tastet?

  2. #22
    Neuer Benutzer Öfters hier
    Registriert seit
    25.07.2017
    Beiträge
    16
    Hallo hbquax,

    ich habe ENABLE auf GND gelegt. Die gemessenen Ausgansspannungen waren mit angeschlossenem Motor. Wenn ich jetzt den Motor abziehe, dann messe ich, sofort nachdem ich das Labor-Netzteil einschalte, 12 Volt.
    Nachdem ich ENABLE auf GND gelegt habe, änderte sich nichts.

    Nach wie vor, brummt der Motor, wenn ich Ihn anschließe. Drücke ich die Taste, kann ich einen "zucker" feststellen. Ich halte die Achse und drücke. Wie schon im Verlauf geschrieben, ist der Schritt nur minimal.

    Hmmm, ich habe 5 solcher Module bestellt, ich bin mir nicht sicher, 3 Module zeigen das Gleiche. Sicher, bei 5 Modulen ist die Chance immer gegeben, dass ein Modul mal defekt sein kann.
    Ich habe mir die Rezession vorher durch gelesen.

    Diese Artikel hatte ich bestellt: https://www.ebay.de/itm/5x-DRV8825-S...53.m2749.l2649

    Vielleicht kommen wir so dem Fehler auf die Spur.

  3. #23
    Neuer Benutzer Öfters hier
    Registriert seit
    25.07.2017
    Beiträge
    16
    Hallo hbquax,

    ich habe die Schaltung separat aufgebaut, also ein 2. mal. wenn ich das easy-driver board mit einem A3967-chip nehme, dann funktionieren die buttons und der Motor dreht sich.

    Nach diesem Test, gehe ich davon aus, dass die Buttons, so wie ich diese verdrahtet habe, funktionieren. Ein defekter Motor schalte ich auch aus. Da aber dieser Driver ja nur 750 mA verträgt ist das nicht der Richtige. Der Chip wird zu heiß.

    Ich bin also wieder zurück zum DRV8825. Die Grundschaltung habe ich dann noch mal auf einem Breadboard aufgebaut, um irgendwelche Fehler auszuschließen. Gebe ich nun die 12 Volt (VMot/GND) drauf, lege 5 Volt (RST, SLP,GND) am Chip an, habe ich das gleiche Problem, wie ich es oben beschrieben habe. Wenn ich den Anschluss durch prüfe und die Buttons drücke liegen auf dem unbelasteten Anschluss jeweils 12 Volt an und es ändert sich auch das Vorzeichen. Ich gehe also davon aus, dass der Chip grundsätzlich tut, was er soll.

    Ich habe davon, wie oben geschrieben, 5 Stück. Bei allen ist der gleiche "Fehler".

    Was kann man da noch machen? ...mir gehen auch die Ideen aus.

    Grüße
    V

  4. #24
    Erfahrener Benutzer Robotik Einstein Avatar von Andree-HB
    Registriert seit
    10.12.2004
    Ort
    Bremen
    Alter
    48
    Beiträge
    2.596
    Vielleicht wäre soetwas für Dich mal eine Hilfe:
    https://www.amazon.de/Printer-Steppe.../dp/B06WVJX8QP

    ...damit solltenn sich möglichen Verdrahtungsfehler einschränken lassen.

    An "Step" ein einfacher Rechteckgenerator, an "Dir" ein Umschalter zwischen GND/VCC, schon hat mal einen fertigen Motorantrieb mit Richtungsumschaltung ohne Controller.

  5. #25
    Neuer Benutzer Öfters hier
    Registriert seit
    25.07.2017
    Beiträge
    16
    Hi Andree-HB,

    alles klar, Platine ist bestellt, das wird einfacher sein. Das mit Step und Dir ist eine gute Idee, das hab ich ja mit den Tastern mehr oder weniger realisiert.
    Ich hab gesehen, dass er "Steps" macht. Es stört halt das brummen... mit und ohne controller.

    Was mich auch irgendwie stutzig macht ist, dass mit einem weiteren Aufbau nach der Grundschaltung auf Breadboard, das gleiche Problem hab.

    Ich warte mal, bis die Platine da ist und Teste die 5 Treiber. Wäre käse, wenn alle defekt sind.

  6. #26
    Erfahrener Benutzer Robotik Einstein Avatar von Andree-HB
    Registriert seit
    10.12.2004
    Ort
    Bremen
    Alter
    48
    Beiträge
    2.596
    ...mich wundert das "brummen" - wenn über ein vernünftig gleichgerichtetes Labornetzteil eingespeist wird, dann darf da nix brummen...höchstens warm werden oder riechen.

  7. #27
    Neuer Benutzer Öfters hier
    Registriert seit
    25.07.2017
    Beiträge
    16
    Hallo Members,

    ich habe das Platinsche aus China bekommen. ich habe auch gleich einen anderen Treiber A4988 bestellt, um zu sehen, ob meine DRV8825 kaput sind.
    Was soll ich dazu sagen. Ich habe meine Schaltung aufgebaut und das Standard-Programm aufgespielt.

    Ich habe auch schon den Arduino Nano gegen einen Uno ausgetauscht.

    Es sieht so aus, dass sich der Motor nicht bewegt. Ich sehe, dass Leistung verbraten wird, zumindest sehe ich das am Display des Labor-Netzteils.
    Ich habe auch am Poti des Treiberbausteins gedreht. Das hat auch nix gebracht. Eines ist anders, der Motor brummt nicht! Die Achse des Motors ist schwer drehbar, zuckt aber nicht.

    Was ich noch nicht gemacht hab ist, dass ich auf die Schnelle mein Messgerät bemüht habe. Das mache ich am Wochenende.

    Was ich gemacht habe ist, dass die beiden PINS Reset und Sleep verbunden (überbrückt) habe. Auf der Platine, auf dem huckepack der Treiber gesteckt wird, hat noch DIP-Schalter. Die Schalterstellung ist dabei auf "off". Ich gehe davon aus, dass das richtig ist. Eine Anleitung ist leider nicht dabei gewesen.

    Vielleicht hat jemand noch eine Idee, warum das nicht funktioniert.

    Am Samstag halte ich mal das Messgerät ran. Vielleicht kann man die Lösungsvorschläge schon mit berücksichtigen.

    Vielen Dank.
    V

  8. #28
    Erfahrener Benutzer Robotik Einstein Avatar von Andree-HB
    Registriert seit
    10.12.2004
    Ort
    Bremen
    Alter
    48
    Beiträge
    2.596
    ...was sollte denn da auch für eine Anleitung dabei sein ? Die dortigen Pins und deren Beschaltung sollten doch auch für Laien selbsterklärend sein..

    Zudem habe ich weiter oben beschrieben, wie man einen ganz einfachen Testaufbau OHNE Microcontroller durchführen kann, um einen angeschlossenen Motor drehen zu lassen.

  9. #29
    Neuer Benutzer Öfters hier
    Registriert seit
    25.07.2017
    Beiträge
    16
    Hallo Andree-HB,

    danke für die Rückantwort. Ich hatte mir das mit Deiner Schaltung schon angeschaut. Mir fehlt nur der Rechteckgenerator.
    Ich benutze ja den Microcontroller. Ich habe ja das mit den Tasten schon gemacht und geschrieben, dass er ja Steps macht.

    Nachdem ich aber die vorgeschlagene Platine bestellt hatte, hört das "brummen" auf und tut nichts mehr. Ich hatte mir einfach mehr erhofft.

    Ich tippe, dass mein Netzteil nicht so viel liefert. Ich versuche mal ein anderes Netzteil zu organisieren. Einen Fehler in der Schaltung kann ich ausschließen. Der Motor funktioniert ja auch am 3D-Drucker. Die Anschlüsse A1+2 bzw. B1+2, denke ich, sind richtig.

    Wenn ich das Multimeter an GND und A1, A2 bzw B1 und B2 anschließe werden 0.6 V angezeigt.

    Sobald ich die Schaltungen unter Strom setze, geht der Lüfter am Netzteil an. Die Anzeigen am Netzteil gehen runter (0,3 A und 1.7 V). ...was mich an der Stelle verwundert. Eigentlich sollte das doch stabil sein, 3 A und 30 Volt liefern können.

    Ich muss mich auch gleich entschuldigen, wenn meine elektrokenntnisse sich auf die Schule beschränken. Meine Ausstattung ist etwas spärlich.

    Vielleicht hat noch jemand eine Idee.

    ich versuche mal das Netzteil vom 3D Drucker missbrauchen... und gebe bescheid.

    Danke noch mal für Alles... ich bleibe jedenfalls am Ball. Das ware ja gelacht, wenn man den Fehler nicht lokalisieren kann.

    Grüße

    V

  10. #30
    Erfahrener Benutzer Robotik Einstein Avatar von Andree-HB
    Registriert seit
    10.12.2004
    Ort
    Bremen
    Alter
    48
    Beiträge
    2.596
    ...mein Vorschlag mit dem Rechteckgenerator gehen ja auch in die Richtung, dass man damit ausschliessen kann, dass die Verbindung zum Arduino oder die Software die Probleme macht.

    Einen Rechteckgenerator kann man auch ganz einfach über die Soundkarte (Ausgang) und geeignete Software realisieren
    Geändert von Andree-HB (13.08.2018 um 11:06 Uhr)

Seite 3 von 4 ErsteErste 1234 LetzteLetzte

Ähnliche Themen

  1. Arduino und Win 10 USB Driver
    Von oderlachs im Forum Arduino -Plattform
    Antworten: 2
    Letzter Beitrag: 04.07.2016, 06:54
  2. Antworten: 2
    Letzter Beitrag: 03.04.2016, 21:01
  3. Antworten: 2
    Letzter Beitrag: 12.01.2016, 14:01
  4. Antworten: 0
    Letzter Beitrag: 29.08.2015, 07:34
  5. Antworten: 9
    Letzter Beitrag: 20.02.2015, 18:59

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •