-         
Ergebnis 1 bis 8 von 8

Thema: Windows 7 pro 64 Netzwerk Laufwerkfreigabe funktioniert in EINER Richtung nicht.

  1. #1
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    09.10.2014
    Beiträge
    2.859

    Windows 7 pro 64 Netzwerk Laufwerkfreigabe funktioniert in EINER Richtung nicht.

    Anzeige

    hallo,
    ich verzweifle langsam: Die Windows 7 pro 64 Netzwerk Laufwerkfreigabe funktioniert in EINER Richtung nicht.
    Alle Netzwerk Einstellungen im "Netzwerk- und Freigabecenter" sind auf beiden Computern identisch, auch die Arbeitsgruppe, gecheckt hiernach:

    Öffnen Sie das "Netzwerk- und Freigabecenter" aus der Systemsteuerung heraus.
    Klicken Sie links auf "Erweiterte Freigabeeinstellungen".
    Stellen Sie hier sicher, dass die "Datei- und Druckfreigabe" aktiviert ist.
    Wechseln Sie anschließend zurück in die "Systemsteuerung" und hier anschließend "System".
    Klicken Sie unter "Einstellungen für Computernamen, Domäne und Arbeitsgruppe" auf "Einstellungen ändern".
    Wechseln Sie dort in die Registerkarte "Computername" und klicken Sie unten auf "Ändern". Stellen Sie sicher, dass Sie sich in der richtigen Arbeitsgruppe befinden.

    Ich habe auch alle HD Laufwerke freigegeben mit allen Rechten (Lesen, Ändern, Vollzugriff) für "Jeder".

    Trotzdem sind zwar die Computer samt Laufwerkbuchstaben wechselweise sichtbar, aber ich kann nur auf die Desktop Laufwerke vom Notebook aus zugreifen,
    anders herum auf die Notebook Laufwerke bekomme ich die Fehlermeldung, ich besäße nicht die Zugriffsrechte dafür (schon der Lesezugriff zur Ansicht des Inhalts des Netzlaufwerks wird geblockt).
    Auch wenn ich einen einzelnen Unterordner des Laufwerks (z.B. "Akten" oder "Fotos") gesondert freigebe, sehe ich ihn zusätzlich auf dem Desktop angezeigt, aber Doppelklick führt wieder zum selben Block.

    Auch Löschen der Freigabe und dann erneute Freigabe bringt keine Änderung.

    Was habe ich übersehen?


    PS,
    ich habe nur den Button "Erweiterte Freigabe", einen Freigabe-Assistenten, wenn es den geben sollte, sehe ich allerdings nicht, und der "normale" "Freigabe..." Button ist ständig ausgegraut (inaktiviert).
    Auch die Firewall hatte ich zwischenzeitlich deaktiviert, ebenfalls ohne Effekt.
    Geändert von HaWe (20.04.2018 um 12:53 Uhr)
    ·±≠≡≈³αγελΔΣΩ∞ Schachroboter:www.youtube.com/watch?v=Cv-yzuebC7E Rasenmäher-Robot:www.youtube.com/watch?v=z7mqnaU_9A8

  2. #2
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    11.12.2007
    Ort
    weit weg von nahe Bonn
    Alter
    33
    Beiträge
    2.573
    Das köntne vielleicht daran liegen dass einer der PCs vll. durch Firewall die Discover Protokolle unterdrückt und beide PCs nicht die notwendigen User Informationen bereitstellt.

    Hast du für die Freigaben denn auch die Ordnerberechtigungen geprüft, dass "Jeder" lesen darf?

    Ich habe das nur mit SAMBA auf nem Raspi probiert und da muss man beim Zugriff auf den RPI bei der Erstellung der Freigabe in Windows den Benutzernamen udn das Passwort angeben.

    Unter Windows sollten die PCs einer Arbeitsgruppe die Benutzerinformationen über das Discovery Protokoll austauschen, aber wenn das (SCHON BEIM START DES PC) vond er Firewall blockiert wird könnte das dein Problem erklären.

    Schalte die Firewall am besten mal so aus (welche hast du denn, ich könnte dir nur bei Symantec/Norton sagen wie) dass sie auch beim hochfahren nicht aktiv ist.

    Alternativ kannst du in deiner Firewall eventuell auf "Netzwerk" Ebene den Geräten jeweils das "Vertrauen" schenken (so gehts zumindest bei Norton/Symantec, einfach das Gerät auswählen, auf "Vertrauen" stellen und die Arbeitsgruppe funktioniert)
    Es gibt 10 Sorten von Menschen: Die einen können binär zählen, die anderen
    nicht.

  3. #3
    Erfahrener Benutzer Robotik Einstein Avatar von i_make_it
    Registriert seit
    29.07.2008
    Ort
    Raum DA
    Alter
    49
    Beiträge
    2.781
    Shareberechtigungen scheinen erteilt worden zu sein, sonst wären keine Ordner zu sehen.
    Mal die Filerechte prüfen.
    Wenn bei den Sharerechten jeder drauf kann, heist das noch lange nicht, daß das in den Filerechten (ACL) auch der Fall ist.

  4. #4
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    09.10.2014
    Beiträge
    2.859
    Zitat Zitat von i_make_it Beitrag anzeigen
    Shareberechtigungen scheinen erteilt worden zu sein, sonst wären keine Ordner zu sehen.
    Mal die Filerechte prüfen.
    Wenn bei den Sharerechten jeder drauf kann, heist das noch lange nicht, daß das in den Filerechten (ACL) auch der Fall ist.
    verstehe ich nicht - ich kann ja bei den LW nicht "drauf", ich sehe sie nur gelistet.
    Was bzw. wo sind die Filerechte einstellbar und was heißt ACL?

    PS, Firewall hatte ich ja bereits erfolglos zwischenzeitlich deaktiviert. Ich habe nur die Windows Firewall.
    "Vertrauen" verstehe ich nicht.

    alle HD Laufwerke freigegeben mit allen Rechten (Lesen, Ändern, Vollzugriff) für "Jeder".
    Geändert von HaWe (20.04.2018 um 13:31 Uhr)
    ·±≠≡≈³αγελΔΣΩ∞ Schachroboter:www.youtube.com/watch?v=Cv-yzuebC7E Rasenmäher-Robot:www.youtube.com/watch?v=z7mqnaU_9A8

  5. #5
    Erfahrener Benutzer Robotik Einstein Avatar von i_make_it
    Registriert seit
    29.07.2008
    Ort
    Raum DA
    Alter
    49
    Beiträge
    2.781
    ACL = Access control List
    https://msdn.microsoft.com/de-de/lib...(v=vs.85).aspx

    Wenn nur das Laufwerk gelistet ist, sollten die Share rechte OK sein, da man den Share an sich ja schon mal sieht. Ist zumindest in einer Active Directory Landschaft so (kein Sharerecht und das Laufwerk ist gar nicht zu sehen).

    Die ACL's setzt man in der GUI über Kontextmenü des Ordners (ab der Freigabeebene) Eigenschaften > Sicherheit > Erweitert > Berechtigungen ändern.
    In der Console (DOS-Box) mit "ICACLS (Laufwerk\Pfad /grant userdomäne\user: (CI)(OI)(F)" <<< Beispiel mit Full access,

    Natürlich muß man sich an den Share mit einem User anmelden der auch auf dem Server (Rechner mit dem Share) vorhanden ist.
    Oder halt "Jeder" was dem Verlust jeglicher Sicherheit entspricht.

  6. #6
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    09.10.2014
    Beiträge
    2.859
    Zitat Zitat von i_make_it Beitrag anzeigen
    ACL = Access control List
    https://msdn.microsoft.com/de-de/lib...(v=vs.85).aspx

    Wenn nur das Laufwerk gelistet ist, sollten die Share rechte OK sein, da man den Share an sich ja schon mal sieht. Ist zumindest in einer Active Directory Landschaft so (kein Sharerecht und das Laufwerk ist gar nicht zu sehen).

    Die ACL's setzt man in der GUI über Kontextmenü des Ordners (ab der Freigabeebene) Eigenschaften > Sicherheit > Erweitert > Berechtigungen ändern.
    In der Console (DOS-Box) mit "ICACLS (Laufwerk\Pfad /grant userdomäne\user: (CI)(OI)(F)" <<< Beispiel mit Full access,

    Natürlich muß man sich an den Share mit einem User anmelden der auch auf dem Server (Rechner mit dem Share) vorhanden ist.
    Oder halt "Jeder" was dem Verlust jeglicher Sicherheit entspricht.
    ah ja!
    Da hatten "nicht authentifizierte Benutzer" zwar Lese- und Schreibrechte, aber keinen Vollzugriff - das hätte eigtl reichen müssen (alle anderen Benutzer+Admins hatten immer schon Vollzugriff).
    Jetzt habe ich die auch auf "Vollzugriff" gesetzt, und jetzt geht es interessanterweise - dankeschön für den Tipp!
    ·±≠≡≈³αγελΔΣΩ∞ Schachroboter:www.youtube.com/watch?v=Cv-yzuebC7E Rasenmäher-Robot:www.youtube.com/watch?v=z7mqnaU_9A8

  7. #7
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    11.12.2007
    Ort
    weit weg von nahe Bonn
    Alter
    33
    Beiträge
    2.573
    Shareberechtigungen scheinen erteilt worden zu sein, sonst wären keine Ordner zu sehen.
    nicht zwingend!

    ich habs selber erlebt, wenn man keine echte Windows Arbeitgruppe verwendet (genau genommen der kleine Bruder des Active Directory) können die PCs keine Benutzerinformationen austauschen

    Dann kann man den Ordner wzar sehen aber sofern man sich beim "host" nicht authentifiziert bekommt man keinen Inhalt angezeigt.

    Daher gabs ja eigentlich nur die 2 Optionen, Firewall die die Arbeitsgruppe verhindert (ist mit Norton so, bis man ddas entsprechende Gerät oder das ganze Netzwerk auf Vertrauenswürdig setzt)

    Oder eben Keine Zugriffsberechtigungen auf dem Ordner für "Jeder"

    PS Windows Firewall hättest auch gleich sagen können, die kann solche Funktionen quasi nicht blockieren, wäre MS ja schön blöd wenn sie das nciht automatisiert bekommen würden :P
    Es gibt 10 Sorten von Menschen: Die einen können binär zählen, die anderen
    nicht.

  8. #8
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    09.10.2014
    Beiträge
    2.859
    hatte mich auch zu früh gefreut.
    Nach Neustart beider PCs nach Windows Update wieder alles beim alten:

    vom Notebook zum Desktop alles ok,

    anders herum: beide freigegebenen LW auf Notebook vom Desktop aus sichtbar, aber keine Berechtigung vom Desktop aus!!
    trotz Vollzugriff bei LW-Sicherheit für alle Benutzer,
    trotz Freigabe mit Vollzugriff für "jeder" inkl. Lesen und Schreiben
    und trotz dauerhaft abgeschalteter Windows Firewall !


    Ich kriege hier noch echt die Krise!!

    - - - Aktualisiert - - -

    update:
    habe allerdings festgestellt, dass es einen sichtbaren Netzwerk-Ordner
    \\Notebook\Users\Öffentlich
    (lokaler Name: Benutzer\Öffentlich)
    gibt, dort kann ich zugreifen und Datein kopieren/ändern.

    Der liegt aber auf C:, auf andere Ordner dort habe ich keinen Zugriff, und ich brauche ja auch zusätzlich Vollzugriff auf D:

    Kann man Users\Öffentlich nicht vtl. erweitern auf die kompletten LW-Inhalte von C: und D: ?

    - - - Aktualisiert - - -

    Update 2:
    habe jetzt Verknüpfungen der Notebook-Laufwerke C und D in den lokalen Notebook-Ordner \\Notebook\Benutzer\Öffentlich kopiert, und von dort aus habe ich jetzt seltsamerweise Zugriff auf alle Notebook-Ordner vom Desktop aus.
    Aber das war bisher nie so seltsam kompliziert, und vom Notebook zum Desktop klappt ja alles von vornherein direkt.
    Was zum Teufel ist da los???
    Geändert von HaWe (20.04.2018 um 19:35 Uhr)
    ·±≠≡≈³αγελΔΣΩ∞ Schachroboter:www.youtube.com/watch?v=Cv-yzuebC7E Rasenmäher-Robot:www.youtube.com/watch?v=z7mqnaU_9A8

Ähnliche Themen

  1. 2015 im Video: Windows 10, Windows 10 und andere große Themen
    Von Roboternetz-News im Forum Neuigkeiten / Technik-News / Nachrichten / Aktuelles
    Antworten: 0
    Letzter Beitrag: 25.12.2015, 08:20
  2. Windows 10 pro aus W7pro : AVRStudio4 übersetzt nicht mehr!
    Von oberallgeier im Forum C - Programmierung (GCC u.a.)
    Antworten: 4
    Letzter Beitrag: 08.08.2015, 10:08
  3. Atmega16 - Zwei Timer verwenden. - Nur einer funktioniert
    Von Kesandal im Forum C - Programmierung (GCC u.a.)
    Antworten: 8
    Letzter Beitrag: 24.06.2011, 12:52
  4. Windows findet Datei von Treibersoftware nicht
    Von Da_Vinci13 im Forum AVR Hardwarethemen
    Antworten: 2
    Letzter Beitrag: 11.02.2009, 15:09
  5. UART funktioniert nur in eine Richtung...
    Von Murus im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 4
    Letzter Beitrag: 10.11.2006, 16:36

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •