-         
Ergebnis 1 bis 1 von 1

Thema: STM32F103C8T6 Mini Board unter Linux mit STlink und ArduinoIDE

  1. #1
    Erfahrener Benutzer Roboter Genie Avatar von oderlachs
    Registriert seit
    17.05.2010
    Ort
    Oderberg
    Alter
    67
    Beiträge
    1.133
    Blog-Einträge
    1

    STM32F103C8T6 Mini Board unter Linux mit STlink und ArduinoIDE

    Anzeige

    Hallo Leute !
    Ich muss mal wieder die Kenner mit einer Frage belästigen.
    Da mein vorrangiges Betriebssystem Linux (Mint18.3) ist habe ich versucht mittels Arduino-IDE einem ST-Link v.2 das Board zu programmieren....kein Erfolg ..der ST-Link blinkt nicht mal...unter Win7 alles bestens.
    Der St-Link Programmer wird vom Linux-System erkannt. Auch kann ich per Terminalleingabe st.info folgendes erfahren:

    Code:
    st-info --probe
    Found 1 stlink programmers
      serial: 513f6d06496748573557093f
    openocd: "\x51\x3f\x6d\x06\x49\x67\x48\x57\x35\x57\x09\x3f"
      flash: 65536 (pagesize: 1024)
      sram: 20480
      chipid: 0x0410
      descr: F1 Medium-density device
    Die Arduino-IDE habe ich mit dem Download STM32-master und diesen kopieren in den Arduino/Hardware/ Ordner erweitert.
    Doch ist das Flashen mit den Versionen Arduino1.6.1.2 genauso wie unter Arduino 1.8.5 nicht möglich .
    Ich finde das Flashen mittels ST-Link praktisch besser für mich zu handeln, als wie mit dem Anstöpseln eines USB-Ser. Adapter.

    Hatt vielleicht bitte wer einen guten Tip für mich..??

    Gruss und Dank
    Gerhard

    Nachtrag : Ich habe mal die Fehlerausgabe bei der ArduIDE erweitert , da erhalte ich nun beim Upload folgendes:
    /home/gerhard/arduino-1.8.5/hardware/Arduino_STM32-master/tools/linux/stlink/st-flash: error while loading shared libraries: libusb-1.0.so.0: cannot open shared object file: No such file or directory
    Hier die Lösung für ebenfalls 64Bit Anwender(bei 32Bit sollte es funktionieren??) :
    Lösung für Debiansysteme:

    sudo dpkg --add-architecture i386
    sudo apt-get install libusb-1.0-0:i386
    Geändert von oderlachs (08.04.2018 um 16:25 Uhr) Grund: Lösung
    Arduinos, STK-500(AVR), EasyPIC-40, PICKIT 3 & MPLABX-IDE , Linux Mint

Ähnliche Themen

  1. ArduinoIDE(Linux) findet Port nicht
    Von oderlachs im Forum Arduino -Plattform
    Antworten: 4
    Letzter Beitrag: 08.11.2014, 13:57
  2. Mini-System mit Linux
    Von Roboternetz-News im Forum Neuigkeiten / Technik-News / Nachrichten / Aktuelles
    Antworten: 3
    Letzter Beitrag: 29.01.2014, 14:56
  3. 86Duino: Arduino-Board mit x86-CPU unter Linux
    Von Roboternetz-News im Forum Neuigkeiten / Technik-News / Nachrichten / Aktuelles
    Antworten: 0
    Letzter Beitrag: 29.11.2013, 11:20
  4. [erledigt] AVR-Board unter Linux in betrieb nehmen
    Von RedEagle im Forum AVR Hardwarethemen
    Antworten: 3
    Letzter Beitrag: 25.10.2010, 20:17
  5. avr-gcc unter linux
    Von donni im Forum C - Programmierung (GCC u.a.)
    Antworten: 16
    Letzter Beitrag: 06.04.2006, 21:57

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •