-         
Ergebnis 1 bis 3 von 3

Thema: ESP8266 NodeMcu V3 von Lolin läuft nicht, trotz vieler Versuche

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    14.10.2016
    Beiträge
    16

    ESP8266 NodeMcu V3 von Lolin läuft nicht, trotz vieler Versuche

    Anzeige

    Hallo,
    versuche verzweifelt bei 2 Boards NodeMcu V3 von Lolin eine LED blinken zu lassen - es will nicht funktionieren.
    Vieles im Internet gelesen und getestet. Es klappt einfach nicht.
    Anbei mal meine Daten dazu vielleicht kann mir jemand den entscheidenden Hinweis geben?

    Mit 2 Boards NodeMcu V3 von Lolin getestet
    geflashed ai-thinker-0.9.5.2-115200.bin / Baud 115200
    Arduino-SW: 1.8.5
    Treiber CH340G installiert
    mit interner LED auf 16, D0 und LED_BUILTIN getestet und auch mit externer LED getestet
    Arduino-IDE-Boardverwalter:http://arduino.esp8266.com/stable/pa...com_index.json
    Board NodeMcu 1.0(ESP-12E-Modul) eingestellt aber auch andere probiert
    Upload speed 115200
    Programm wird kompiliert und bis 100% hochgeladen - die blaue LED blinkt dabei. Danach ist Schluss mit blinken

    Program:
    void setup() {
    pinMode(LED_BUILTIN, OUTPUT);
    }

    void loop() {
    digitalWrite(LED_BUILTIN, HIGH);
    delay(1000);
    digitalWrite(LED_BUILTIN, LOW);
    delay(1000);
    }

    Danke

    - - - Aktualisiert - - -

    Hallo,
    Fehler gefunden ... mit Boardverwaltung ESP8266 Community 2.3.0 geht es, aber nur mit externer LED.
    Geändert von stepbystep (01.03.2018 um 22:27 Uhr)

  2. #2
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    09.10.2014
    Beiträge
    2.915
    Zitat Zitat von stepbystep Beitrag anzeigen
    Hallo,
    versuche verzweifelt bei 2 Boards NodeMcu V3 von Lolin eine LED blinken zu lassen - es will nicht funktionieren.
    Vieles im Internet gelesen und getestet. Es klappt einfach nicht.
    Anbei mal meine Daten dazu vielleicht kann mir jemand den entscheidenden Hinweis geben?

    Mit 2 Boards NodeMcu V3 von Lolin getestet
    geflashed ai-thinker-0.9.5.2-115200.bin / Baud 115200
    Arduino-SW: 1.8.5
    Treiber CH340G installiert
    mit interner LED auf 16, D0 und LED_BUILTIN getestet und auch mit externer LED getestet
    Arduino-IDE-Boardverwalter:http://arduino.esp8266.com/stable/pa...com_index.json
    Board NodeMcu 1.0(ESP-12E-Modul) eingestellt aber auch andere probiert
    Upload speed 115200
    Programm wird kompiliert und bis 100% hochgeladen - die blaue LED blinkt dabei. Danach ist Schluss mit blinken

    Program:
    void setup() {
    pinMode(LED_BUILTIN, OUTPUT);
    }

    void loop() {
    digitalWrite(LED_BUILTIN, HIGH);
    delay(1000);
    digitalWrite(LED_BUILTIN, LOW);
    delay(1000);
    }

    Danke

    - - - Aktualisiert - - -

    Hallo,
    Fehler gefunden ... mit Boardverwaltung ESP8266 Community 2.3.0 geht es, aber nur mit externer LED.
    die eingebaute LED per LED_BUILTIN klappt oft nicht, es geht aber doch. Probier mal stattdessen GPIO1, GPIO2, GPIO4 oder GPIO16.

    PS,
    der nodeMCU hat glaube ich sogar 2 eingebaute LEDs mit verschiedenen GPIOs.

    D0 = GPIO16;
    D1 = GPIO5;
    D2 = GPIO4;
    D3 = GPIO0;
    D4 = GPIO2;
    D5 = GPIO14;
    D6 = GPIO12;
    D7 = GPIO13;
    D8 = GPIO15;
    D9 = GPIO3;
    D10 = GPIO1;
    LED_BUILTIN = GPIO16 (auxiliary constant for the board LED, not a board pin);
    ·±≠≡≈³αγελΔΣΩ∞ Schachroboter:www.youtube.com/watch?v=Cv-yzuebC7E Rasenmäher-Robot:www.youtube.com/watch?v=z7mqnaU_9A8

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    14.10.2016
    Beiträge
    16
    auch interen LED geht jetzt auf Adresse 02. "Boardpaket" ist 2.4.0
    Fazit: zu lange getestet mit falschen Adressen der internen LED

Ähnliche Themen

  1. NodeMCU - ESP8266 Starthilfe
    Von SuterB im Forum NodeMCU-Board und ESP8266, ESP32-Serie
    Antworten: 15
    Letzter Beitrag: 13.01.2017, 11:58
  2. NodeMCU und ESP8266 – Einstieg in die Programmierung
    Von Roboternetz-News im Forum Neuigkeiten / Technik-News / Nachrichten / Aktuelles
    Antworten: 1
    Letzter Beitrag: 13.01.2017, 08:37
  3. ESP8266/NodeMCU Kommunikationsprobleme
    Von thewulf00 im Forum NodeMCU-Board und ESP8266, ESP32-Serie
    Antworten: 5
    Letzter Beitrag: 30.03.2016, 05:04
  4. Versuche WLAN-Module ESP8266
    Von Andree-HB im Forum NodeMCU-Board und ESP8266, ESP32-Serie
    Antworten: 3
    Letzter Beitrag: 24.11.2014, 12:54
  5. [gelöst]ATmega168 läuft nicht,trotz funktionierender Schaltg
    Von robodriver im Forum AVR Hardwarethemen
    Antworten: 9
    Letzter Beitrag: 19.01.2008, 12:06

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •