-         
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 16

Thema: NodeMCU - ESP8266 Starthilfe

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    02.01.2017
    Beiträge
    10

    NodeMCU - ESP8266 Starthilfe

    Anzeige

    Hallo Zusammen

    Neues Jahr neues Glück. Ich hab mich an den NodeMCU gewagt um Temperatur Daten zu sammeln (mein erstes Projekt). Die Bauanleitung hab ich im Heft "Make: iot Spezial" gefunden ( www.make-magazin.de/x8zq ). Mein NodeMCU hab ich auf einem Steckbrett und die Sensoren sind wie im Baubeschrieb angeordnet.

    Die Firmware hab ich mir auf nodemcu-build.com zusammen geklickt. Folgende Module hab ich ausgewählt: DHT, file, GPIO, I2C, net, node, timer, UART, WiFi.

    Als ich den NodeMCU zum ersten mal via USB mit dem PC verband, blinkte das blaue LED regelmässig ca. alle 0.5 sec. Das Flachen funktionierte nicht auf Anhieb. Ich brauchte fünf Versuche. Während diesen Versuchen hatte die LED nie geblinkt. Nach dem das Flaschen gerückt ist und ich, wie in der Anleitung beschrieben, auf "Reset" gedrückt habe, begann das LED in eine hohen Frequenz an zu blinken.

    Als ich den NodeMCU im ESPlorer aufrufte bekam ich im rechten Fenster folgende Meldung:

    PORT OPEN 115200

    Communication with MCU..Got answer! Communication with MCU established.
    AutoDetect firmware...

    Can't autodetect firmware, because proper answer not received (may be unknown firmware).
    Please, reset module or continue.
    n�|� ����b��nn�l��l`�nn �lnr���n r��`p�n� r�����


    Ein Reset brachte keine Besserung. Ich hab dann in einem Blog ( https://alexbloggt.com/nodemcu-einfuehrung/ ) etwas über Bautrate gelesen und hab die bei meinem NodeMCU verändert. Bei 74880 hatte ich erfolg. Die unleserlichen Zeichen wichen folgender Nachricht:

    ets Jan 8 2013,rst cause:2, boot mode: (3,6)

    load 0x40100000, len 24276, room 16
    tail 4
    chksum 0xce
    load 0x3ffe8000, len 2200, room 4
    tail 4
    chksum 0x21
    load 0x3ffe8898, len 8, room 4
    tail 4
    chksum 0x52
    csum 0x52
    rf_cal[0] !=0x05,is 0x00

    Jedoch wurde diese Meldung immer wieder holt. Ein Anzeigen der Firmwareversion wie im Blog beschrieben, sah ich nie.

    Wenn ich nun im Linken Fenster des ESPlorer ein .lua Script lade und mit dem Button "An ESP senden" sende, geschieht im rechten Fenster nichts. Die oben beschriebene Nachricht, wird unablässig wiederholt.

    Hat jemand eine Idee wo der Hund begraben ist? Kann mir jemand helfen?

    Ich bin um jeden Hinweis froh.

    Gruss SuterB

  2. #2
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    24.06.2004
    Ort
    Berlin
    Alter
    54
    Beiträge
    396
    welches modul hast du?
    das leben ist hart, aber wir müssen da durch.

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    02.01.2017
    Beiträge
    10
    ESP8266 NodeMCU V2 Dev Board mit Lua Firmware

    Auf dem Modul steht:

    1. Instal CP2102 driver. -> hab ich gemacht. Er läuft.
    2. Use 9600 baud rate. -> da kommen nur kryptische Zeichen
    3. Connect to Wi-Fi and enjoy. -> so weit bin ich noch nicht gekommen


    Das ist der Link zum Shop: http://www.play-zone.ch/de/esp8266-n...-firmware.html
    Geändert von SuterB (02.01.2017 um 16:12 Uhr)

  4. #4
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    24.06.2004
    Ort
    Berlin
    Alter
    54
    Beiträge
    396
    geh mal auf 115k bei der bausrate, ansonsten ist das teil eigentlich sehr einfach zu handhaben.

    flash mal wieder die orginale firmware. was nimmst du zum flashen.

    der esplorer sollte eigentlich auch das richtig machen, wenn ich auch schon fetsgestellt habe das das teil etwas empfindliche ist.
    das leben ist hart, aber wir müssen da durch.

  5. #5
    Neuer Benutzer Öfters hier
    Registriert seit
    02.01.2017
    Beiträge
    10
    Zum Flaschen verwende ich "ESP8266Flscher.exe" ( https://github.com/nodemcu/nodemcu-f.../Win64/Release ).

    Meist du mit 115k Bautrate 115200? Das hab ich schon Probiert das gibt:

    PORT OPEN 115200

    Communication with MCU..Got answer! Communication with MCU established.
    AutoDetect firmware...

    Can't autodetect firmware, because proper answer not received (may be unknown firmware).
    Please, reset module or continue.
    n�|� ����b��nn�l��l`�nn �lnr���n r��`p�n� r�����

  6. #6
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    24.06.2004
    Ort
    Berlin
    Alter
    54
    Beiträge
    396
    dann flash noch mal sauber die firmware, die orginale.
    das leben ist hart, aber wir müssen da durch.

  7. #7
    Neuer Benutzer Öfters hier
    Registriert seit
    02.01.2017
    Beiträge
    10
    Hallo Morob

    hab auf dem PC alles gelöscht und nochmals runter geladen. Leider hat alles nichts gebracht Die Situation ist die selbe wie davor. Ist vielleicht der NodeMCU defekt? Wäre ein neuer Hilfreich?

  8. #8
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    24.06.2004
    Ort
    Berlin
    Alter
    54
    Beiträge
    396
    kannst du flashen?
    das leben ist hart, aber wir müssen da durch.

  9. #9
    Neuer Benutzer Öfters hier
    Registriert seit
    02.01.2017
    Beiträge
    10
    Ja. Wenn ich mit dem ESP8266Flscher.exe Flash erscheint unten Links ein grünes Symbol.

  10. #10
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    24.06.2004
    Ort
    Berlin
    Alter
    54
    Beiträge
    396
    welche firware hast du geflasht?
    das leben ist hart, aber wir müssen da durch.

Seite 1 von 2 12 LetzteLetzte

Ähnliche Themen

  1. arduino ide mit esp8266
    Von NotEvil im Forum NodeMCU-Board und ESP8266, ESP32-Serie
    Antworten: 4
    Letzter Beitrag: 12.01.2017, 15:17
  2. esp8266 Vorwiderstand?
    Von NotEvil im Forum NodeMCU-Board und ESP8266, ESP32-Serie
    Antworten: 3
    Letzter Beitrag: 25.11.2016, 10:17
  3. NodeMCU v.1 Webserver wird nicht im WLANi-Netz gefunden/angezeigt
    Von oderlachs im Forum NodeMCU-Board und ESP8266, ESP32-Serie
    Antworten: 4
    Letzter Beitrag: 18.10.2016, 13:38
  4. ESP8266/NodeMCU Kommunikationsprobleme
    Von thewulf00 im Forum NodeMCU-Board und ESP8266, ESP32-Serie
    Antworten: 5
    Letzter Beitrag: 30.03.2016, 06:04
  5. Suche ESP8266-Programmierer
    Von Crazy Harry im Forum Suche bestimmtes Bauteil bzw. Empfehlung
    Antworten: 1
    Letzter Beitrag: 27.01.2015, 02:03

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •