-         
Ergebnis 1 bis 4 von 4

Thema: Probleme beim Auslesen eines magnetischen Encoders

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    13.08.2015
    Beiträge
    7

    Probleme beim Auslesen eines magnetischen Encoders

    Anzeige

    Hallo ihr Lieben,
    ich habe ein ganz großes Problem und hoffe, dass mir hier jemand helfen kann...
    Ich habe einen kleinen micro gear Motor und den dazu passenden Encoder. Hier auch noch einmal der Link:
    https://www.pololu.com/product/2598/blog
    Ich habe die Motoren samt Encoder an den Arduino angeschlossen und der spuckt kontinuierlich den selben Wert aus: sensor= 750
    Hat jemand diesen Encoder schon mal verwendet und könnte mir vielleicht die Ausgabe erklären?
    Ich bin für jede Hilfe dankbar!

    Viele Grüße

  2. #2
    Unregistriert
    Gast
    Sensor = 42 wäre plausibler. Aber im Ernst, was erwartest du von einem Quadraturencoder?

  3. #3
    Erfahrener Benutzer Robotik Visionär Avatar von oberallgeier
    Registriert seit
    01.09.2007
    Ort
    Oberallgäu
    Beiträge
    7.673
    .. ich habe ein ganz großes Problem .. Motoren samt Encoder an den Arduino angeschlossen und der spuckt kontinuierlich den selben Wert aus ..
    Es gibt sicher mehrere Möglichkeiten nen Encoder so anzuschließen, dass immer derselbe Wert "ausgespuckt" wird. Meine Frage ist mal : was soll ausgespuckt werden? Wobei meine Encoder nicht spucken. Schreib doch bitte was GENAU Du willst und was GENAU Du gemacht hast (.. Encoder an den Arduino angeschlossen .. dazu weiß meine Kristallkugel keine Antwort ausser - "schon recht so").

    .. Hat jemand diesen Encoder schon mal verwendet und könnte mir vielleicht die Ausgabe erklären? ..
    Ich habe diese Encoder an zwei 2208-Motörchen dran. Spitzenteile, saubere Ausgabe, ich bin ziemlich zufrieden. Hab die Encoder an nen babyorangutan angeschlossen und der spuckt sauber die Drehzahl in Umdrehungen pro Minute aus. (Nu weißt Du so viel wie ich aus Deinem Post).

    Hilfe gibts hier (klick) - sogar mit Beispielcode (in C - Arduinos IDE will ich nicht) und auch in anderen Quellen. So gibts zu diesen Teilen von Pololu direkt ausführliche Anwendungsinformationen. Noch ne Anmerkung zum Link: Peter Dannegger ist nicht nur bei Encodern wirklich Spitze!



    Sensor = 42 wäre plausibler. Aber im Ernst, was erwartest du von einem Quadraturencoder?
    Soll so etwas weiterhelfen?
    Ciao sagt der JoeamBerg

  4. #4
    Erfahrener Benutzer Robotik Einstein Avatar von i_make_it
    Registriert seit
    29.07.2008
    Ort
    Raum DA
    Alter
    49
    Beiträge
    2.814
    Dieser Encoder ist ja schon mal in einer nicht unerheblichen Stückzahl im Einsatz.
    also vom Prinzip her funktionieren die ganz gut.
    Als erstes ware mal ein Foto vom Aufbau interessant, aus dem ersichtlich ist wie der Encoder angeschlossen ist.
    Und als zweites der Programmcode mit dem der Encoder ausgewertet und das angezeigte Ergebniss erzeugt wird.
    Meine Kristallkugel zeigt, wenn ich sie vor den Monitor halte auch nur ein verschwommenes Bild des selben, da sie mit den Angaben nichts anfangen kann.

Ähnliche Themen

  1. [ERLEDIGT] Problem mit Auslesen des Encoders eines EMG30 Getriebemotors
    Von Unregistriert im Forum Sensoren / Sensorik
    Antworten: 2
    Letzter Beitrag: 07.08.2015, 21:13
  2. Kleine Unstimmigkeit beim Auslesen eines RC-Signals
    Von Henry im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 7
    Letzter Beitrag: 22.05.2010, 21:27
  3. Probleme mit beiden Encoders!!!!!!
    Von alfa-uwek im Forum Robby RP6
    Antworten: 6
    Letzter Beitrag: 20.05.2010, 21:57
  4. Antworten: 12
    Letzter Beitrag: 18.05.2010, 18:00
  5. Probleme beim auslesen eines Strings über UART
    Von Euro im Forum C - Programmierung (GCC u.a.)
    Antworten: 3
    Letzter Beitrag: 28.08.2008, 17:14

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •