-         
Ergebnis 1 bis 3 von 3

Thema: Line Data_ Ergebnisse total unsymmetrisch

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    19.11.2007
    Beiträge
    16

    Line Data_ Ergebnisse total unsymmetrisch

    Anzeige

    Ich habe festgestellt, dass die LineData-werte für den linken und rechten
    Fototransistor auf der ASURO-Unterseite total unterschiedlich sind.
    Es kann vorkommen, dass bei gleichem Untergrund (=Helligkeit) der linke nur 8 , der rechte dagegen 70 anzeigt. Der linke zeigt aber bei hellem Licht auch höhere Werte,
    bei schlechten aber Werte nahe Null.
    Ich fürchte, dass mit dieser Unsymmetrie keine vernünftigen Linienfolge-Experimente möglich sind. Woran könnte es liegen?
    Fototransistor austauschen ? Muss dann vor dem Löten auch der Prozessor entfernt werden ? Könnte man den Linedata[0] Wert einfach mit einem Faktor aufwerten ? Dieser wäre ja aber nicht konstant.
    Könnte eine fehlerhafte Lötstelle die Ursache sein ?
    Schade, bis jetzt hatte sich mein ASURO in technisch einwandfreiem Zustand gezeigt ...

  2. #2
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    26.11.2006
    Ort
    Hamburg
    Alter
    26
    Beiträge
    384
    Bevor du drauflos lötest solltest du dir mal den Schaltplan (in der Anleitung im Anhang vorhanden) anschauen, dort kannst du erkennen, dass die Fototransistoren für die Linienverfolgung (T9,T10) über die Widerstände R14 und R15 mit der Masse verbunden sind, die solltest du mal checken ob da vielleicht kalte Lötstellen entstanden sind oder was mir mal passiert ist die Widerstände in die falschen Löcher gelötet hast (ist da ja auch sehr unübersichtlich auf der Platine ) Bevor du dann anfängst zu löten solltest den Controller rauszunehmen um ihn vorm Grillen zu bewahren. Wenn du die Fototransistoren schief eingelötet haben solltest kann es auch zu Abweichungen kommen, die sich allerdings normalerweise nicht in den Dimensionen abspielen sollten aber man weiß ja nie.
    Dann erstmal viel Glück bei der Fehlersuche.

    mfg
    Erik

  3. #3
    Moderator Robotik Einstein Avatar von damaltor
    Registriert seit
    28.09.2006
    Ort
    Jena
    Alter
    31
    Beiträge
    3.953
    du könntest weiterhin versuchen, die transistoren abzudunkeln bzw mit einer art schirm gegen aussenlich abzuschirmen. so könntest du schonmal sichergehen dass es wirklich nicht am fremdlich liegt.

    biege sie etwas hin und her, der der heller ist bzw den größeren wert hat etwas weiter nach aussen. evtl hilft das schon.

    oder du beginnst, ein programm zu entwickeln dass diese ungenauigkeit ausgleicht...

    wie sehen die werte bei hellem licht aus? und wie bei möglicht völliger verdunkelung?
    kleinschreibung ist cool!

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •