-
        
Ergebnis 1 bis 4 von 4

Thema: Problem mit WinAVR

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    28.02.2005
    Ort
    München
    Beiträge
    45

    Problem mit WinAVR

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Ich hab mir grad die neueste Version installiert und nun das Problem, dass der Compiler immer mit folgendem fehler abbricht:
    avr_gcc: _spawnv: No such file or directory
    Woran kann das liegen?

    Vielen Dank,
    Christoph

  2. #2
    Benutzer Stammmitglied
    Registriert seit
    16.10.2005
    Ort
    Adendorf
    Alter
    36
    Beiträge
    46
    hast du alle verwendeten *.c Files auch in die Makefile geschrieben?

    zum Beispiel:
    # List C source files here. (C dependencies are automatically generated.)
    SRC = $(TARGET).c uart.c timer.c motor.c


    Oder schau mal hier nach http://www.mikrocontroller.net/articles/WinAVR

    Bei WinAVR-20070122 kann es unter VISTA und Windows98SE die Fehlermeldung "avr-gcc: _spawnv: No such file or directory" geben. Verschiedene Binärpatches können diese Probleme beheben.

    Forenbeitrag von MadWizard und Originalseite für VISTA (32-Bit). Bei der 64-Bit Version von VISTA wird berichtet, dass der Linker mit Fehlermeldung abbricht.
    Forenbeitrag von Stefan für Windows98SE
    http://wsgs.blogspot.com

    Wenn deine Freundin denkt,du bist bei deiner Frau,und deine Frau denkt,du bist bei deiner Freundin, dann hast du endlich Zeit ins Labor zu gehen

  3. #3
    Erfahrener Benutzer Robotik Einstein Avatar von SprinterSB
    Registriert seit
    09.06.2005
    Ort
    An der Saar
    Beiträge
    2.801
    Hast du vorher eine alte WinAVR-Version deinstelliert, falls vorhanden?
    Stimmen die Pfade?

    BTW: GCC 4.x ist immer noch im Status "bugfixing + no new features", zudem macht die letzte GCC 3.4.6 (WinAVR-20060421) sichtlich besseren Code.
    Disclaimer: none. Sue me.

  4. #4
    Benutzer Stammmitglied
    Registriert seit
    28.02.2005
    Ort
    München
    Beiträge
    45
    Ich hab jetzt WinAVR-20060421 installiert und es funktioniert einwandfrei!

    Danke

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •