-         
Ergebnis 1 bis 6 von 6

Thema: If abfrage geht nicht.....

  1. #1
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    02.03.2004
    Beiträge
    121

    If abfrage geht nicht.....

    Anzeige

    Hallo, meine IF abfrage lautet wie folgt:

    If Taste = Runter And Mp = 9 Then
    Rel(s) = Rel(s) - 1
    If Rel(s) <= 0 Then
    Rel(s) = 0
    End If
    End If

    Der wert Rel(s) sollte eigendlich bei 0 stehen bleiben, fägt aber wider bei 255 an runter zu zählen. Ist da was Falsch ????

    Danke !!!

  2. #2
    Super-Moderator Robotik Visionär Avatar von PicNick
    Registriert seit
    23.11.2004
    Ort
    Wien
    Beiträge
    6.836
    nehme an, daß es sich um Bascom handelt. Der kenn keine Bytes mit Vorzeichen, d.h. "<= 0 " ist sinnlos. Von führenden Herstellern wird ein Umbau empfohlen:
    Code:
    If Taste = Runter And Mp = 9 Then 
       If Rel(s) > 0 Then 
            Rel(s) = Rel(s) - 1 
       End If 
    End
    mfg robert
    Wer glaubt zu wissen, muß wissen, er glaubt.

  3. #3
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    02.03.2004
    Beiträge
    121
    Super sache, vielen dank für deine Antwort !!!

  4. #4
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    30.07.2005
    Beiträge
    569
    Im übrigen, falsches Forum ....

  5. #5
    Gast
    Wo muß ich denn hin ? Ist doch hier Software ?

  6. #6
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    02.03.2004
    Beiträge
    121
    Hab´s gefunden. Sorry

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •