-         
Ergebnis 1 bis 7 von 7

Thema: Stimmt diese ISP-Beschaltung des ATmega8?

  1. #1
    Murus
    Gast

    Stimmt diese ISP-Beschaltung des ATmega8?

    Anzeige

    Hallo zusammen,
    im Anhang ist der Schaltplan für die ISP-Schnittstelle am AVR... Stimmt diese Beschaltung? Reicht das? Kondis gut dimensioniert?

    Herzlichen Gruss und Danke

    Mario
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken avr-schaltplan_196.gif  

  2. #2
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    01.08.2005
    Ort
    49.80248 8.59252
    Alter
    34
    Beiträge
    172
    Die Schaltung stimmt. Sonst wuerde sie nicht da zu sehen sein: http://www.mikrocontroller.net/tutorial/equipment

  3. #3
    Administrator Robotik Visionär Avatar von Frank
    Registriert seit
    30.10.2003
    Beiträge
    5.016
    Blog-Einträge
    1
    Ich würde gleich den 10 poligen ISP Stecker empfehlen, wird meistens genommen:

    https://www.roboternetz.de/wiki/pmwi...n.RNIspstecker
    https://www.roboternetz.de/wiki/pmwi...?n=Main.AVRISP

  4. #4
    Murus
    Gast
    Ok.
    Ich hab auch den 10-Poler. Auf der Platine hab ich aber nen 6-Poler, platzsparend... Dann kommt das Zeug über nen Adapter da rein und raus...

  5. #5
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    06.02.2005
    Ort
    Hamburg
    Alter
    32
    Beiträge
    4.255
    ich nehme auch nen 6poligen stecker, allerdings mit ner anderen belegung. nämlcihb so, dass er bei nem mega167mega32 genau zu den pins an AVR passt. dann ist das verbinden auf nen steckboard einfacher...

    wenn ich aber in zukunft mal was ätzen werde, werde ich wohl auch 10er stecker nehmen, weils verpolungssicher ist... außerdem ist es der allgemeine standard...

  6. #6
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    08.05.2004
    Ort
    Wilhelmshaven
    Alter
    39
    Beiträge
    324
    ich würde empfehlen, den Oszilator bzw. Quarz+Kondis erstmal wegzulassen. Der Mega8 hat einen internen Oszi standardmäßig eingestellt und wenn du den externen Oszi benutzen möchtest, mußt du die Fusebits verändern. Kannst den Oszi also auch weglassen, dann sparst du bischen Arbeit ein. Die Kondis 47pF und 100nF stimmen aber.

    Ich nehme einen 5 poligen Stecker. (Reichelt: PSK 254/5W,PSS 254/5G) Benutze allerding auch einen Seriellen ISP www.mikrocontroller.COM unter Grundlagen/ISP. Habe ich allerdings nicht in SMD aufgebaut, müßtest also einen anderen Transistor benutzen. Ist auch PonyProg kompatibel. (sollte jemand einen nachbaubaren kennen, mit dem man gleich über AVR Studio schreiben kann, dann nur her mit dem Bauplan)

  7. #7
    Murus
    Gast
    Ne, ich nehm 4Mhz extern, die Fusebits sind ja schnell neu gesetzt....

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •