-         

Ergebnis 1 bis 1 von 1

Thema: externer RAM funktioniert auf einmal nicht mehr

  1. #1
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    17.11.2004
    Beiträge
    263

    externer RAM funktioniert auf einmal nicht mehr

    Anzeige

    Mein externer 32K Ram funktioniert auf einmal nicht mehr.

    Nachdem ich die Schaltung von Steckbrett auf eine vernünftige Platine gelötet habe, bekomme ich mit folgendem Programm Fehler:
    Code:
    $regfile = "8515def.dat"                                    'ATmega8515-Deklarationen
    $crystal = 4000000                                          'Quarz: 4 MHz
    $baud = 9600
    
    Dim I As Byte
    Dim Wert As Byte
    Dim Ar(300) As Xram Byte
    
    Wait 2
    
    For I = 3 To 255
       Ar(i) = I
    Next
    
    For I = 3 To 255
       Wert = Ar(i)
       Printbin Wert;
       Waitms 50
    Next
    
    Do
    Loop
    
    End                                                         'end program
    Die Ergebnisse habe ich mal als Bilder angehängt. Es sieht so aus, das immer der 16te Wert vertauscht ist, also da wo 32 hin soll, steht die 48 und wo die 48 hin soll steht die 32 usw...
    Weiß jemand woran das liegen könnte? Das eine Bild ist übrigens mit Waitstate und das andere ohne Waitstate
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken ohne_waitstate.png   mit_waitstate.png  

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •