-
        

Ergebnis 1 bis 6 von 6

Thema: PIC programmieren mit MPLAB in C! Hilfe!!

  1. #1
    Paul123
    Gast

    PIC programmieren mit MPLAB in C! Hilfe!!

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Hallo!!

    ich habe jetzt mein Programm fertiggeschrieben und möchte ihn auf mein
    PIC brennen. Leider klappt das nicht.

    Ich benutz den soruceboost und MPLAB.
    Also wenn ich in Sourceboost auf Start Programmer drücke öffnet sich
    MPLAB aber dann passiert nichts mehr.
    Unter MPLAB ist kein Code zu sehen oder ähnliches. Und wenn ich dann in
    MPLAB auf Programmer gehe und da den MPLAB ICD 2 auswähle und dann auf
    connect drücke, kommt diese raus:

    Auto-connect not enabled - Not connecting (Try enabling auto-connect on
    the ICD2 settings pages.)
    MPLAB ICD 2 Ready
    Connecting to MPLAB ICD 2
    ...Connected
    Setting Vdd source to MPLAB ICD 2
    Target Device PIC12F629 found, revision = Rev 0xC
    ...Reading ICD Product ID
    Running ICD Self Test
    ...Passed
    MPLAB ICD 2 Ready

    Also für mich heißt das, dass alles ok ist.

    Wenn ich dann auf Programmer-programm klicke, erscheint das:

    Programming Target...
    ...Erasing Part
    Verifying...
    ...Verify Succeeded
    ...Programming succeeded
    MPLAB ICD 2 Ready

    Aber ich nehme an, er programmiert nicht, oder?? er weiß doch garnicht,
    was er progammieren soll.

    Also, wie bekomme ich jetzt mein C-Programm in den PIC??

    Hoffe ihr könnt mir helfen.

    Danke schon jetzt!!!!!

    mfg

  2. #2
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    09.05.2004
    Ort
    Bielefeld / Paderborn
    Beiträge
    1.253
    sorry, keine problemlösung, aber es passt gerad so gut hier rein: welche systemvorraussetzungen hat mplab? hab ich auf der microchip-seite nix drüber gefunden. kann ich es wohl auf nem p1 133mhz mit win95 laufen lassen?

  3. #3
    Super-Moderator Robotik Visionär Avatar von PicNick
    Registriert seit
    23.11.2004
    Ort
    Wien
    Beiträge
    6.836
    @Goblin: MPLAB (die Workbench) geht bei mir nur auf XP und aufwärts.
    auf w98 is nix zu machen
    mfg robert
    Wer glaubt zu wissen, muß wissen, er glaubt.

  4. #4
    Erfahrener Benutzer Roboter Genie Avatar von SlyD
    Registriert seit
    27.11.2003
    Ort
    Paderborn
    Alter
    32
    Beiträge
    1.514
    nicht mit der aktuellen - aber die älteren MPLABs laufen da noch... sofern einem das reicht.

  5. #5
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    09.05.2004
    Ort
    Bielefeld / Paderborn
    Beiträge
    1.253
    naja, ich weiss nicht, was mir reicht. ich hatte nur einmal auf die assembler-seite von sprut geschaut und mich etwas kundig gemacht. kann noch gar kein asm, fände es aber mal ganz interessant. eigentlich reicht aber auch nur der editor und nen compiler, oder?

  6. #6
    Erfahrener Benutzer Fleißiges Mitglied Avatar von drew
    Registriert seit
    06.04.2005
    Beiträge
    150
    Zurück zum Probelm...
    MPLAB braucht zum programmieren nicht unbedingt den Code. Das wichtige ist ja das Hex-File. Zur Kontrolle kannst du ja mal im MPLAB unter File\Import... dein Hexfile angeben.
    Wenn der Pic nach dem Programmieren das tut, was er soll, ist doch alles ok!?

Benutzer, die dieses Thema gelesen haben: 0

Derzeit gibt es keine Benutzer zum Anzeigen.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •