-
        

Ergebnis 1 bis 5 von 5

Thema: Mega 16 Pin PC3 schaltet nicht auf 0?

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    07.11.2003
    Beiträge
    26

    Mega 16 Pin PC3 schaltet nicht auf 0?

    Anzeige

    Ich versteh es nicht. Habe in Bascom eine Mega 16 Portleitung PC3 auf 0 geschaltet und habe trotzdem dauernd eine Spannung drauf.

    Warum funktioniert das nicht?

    config Pinc.3 = Output
    Portc.3 = 0

    Andere Ports gehen

  2. #2
    Gast
    Du musst noch JTAG Fuse setzen. Kannst du auch in Bascom machen

  3. #3
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    29.01.2004
    Beiträge
    2.441
    Muss es nicht heissen:

    config Port.3 = Output
    Portc.3 = 0

    So klappt es bei mir jedenfalls mit Portb.3, aber vielleicht ist das ganz was anderes.

  4. #4
    Gast
    Hallo,
    stimme da recycle zu , den das Pin Register ist ja nur lesbar, nicht aber beschreibbar

    Gruß

    Sven

  5. #5
    Administrator Robotik Einstein Avatar von Frank
    Registriert seit
    30.10.2003
    Beiträge
    4.983
    Blog-Einträge
    1
    Hi,
    hier täuscht ihr Euch glaub beide.

    Config Pinc.3 = Output

    muss richtig sein!

    Ich nehme an recycle meint nicht
    config Port.3 = Output
    sondern
    config Portc.3 = Output

    Aber auch das geht nicht. Der Compiler nimmt nur die Pin-Anweisung an, habs gerade ausprobiert.

    Gruß Frank

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •