-
        

Ergebnis 1 bis 5 von 5

Thema: Geschwindigkeitsproblem mit der C-control 1 Unit

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    12.05.2005
    Beiträge
    6

    Geschwindigkeitsproblem mit der C-control 1 Unit

    Anzeige

    Hallo,

    ich habe da ein Problemm mit der Ansteuerung meines Schrittmotors.
    habe die L297/L298-Schrittmotorschaltung gebaut. Die Schaltung funktioniert ohne Probleme.

    1. Wenn ich nun eine einfache Routine in Basic schreibe dann dreht sich
    sich der Motor ca. 50 U/min. Siehe Code:

    #Main
    Pulse Schritt
    goto Main

    Wenn ich aber nun zusätzlich einen Befehl in die Routine setze, fällt die
    Drehzahl gewaltig ab.Siehe Code:

    #Main
    Pulse Schritt
    Print "Hallo"
    goto Main

    Was kann ich hier machen ???

    2. Wenn mein Motor sich dreht und ich versuche an blßen Welle den Motor zu stoppen, dann ist es schon schieriger.
    Aber sobald ich den Reifen dran mache, läßt sich der Motor ganz leicht stoppen (Hebelwirkung). Wie kann ich herausfinden ob dies die Max-Kraft ist die mein Motor bring ? Wie bekomme ich den Motor stärker?
    Hier die Daten von meinem Schrittmotor: 12V/0,3A

  2. #2
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    03.01.2005
    Ort
    hessen
    Alter
    29
    Beiträge
    1.099
    hi


    also den motor kannst du stärken in dem du ihm eine übersetzung gibts also vor den reifen montierst, aber dadurch wird dein roboter langsam, jedoch auch wiederrum stärker von der Kraft.


    gruß
    patrick

  3. #3
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    14.12.2003
    Alter
    27
    Beiträge
    1.187
    Dass die geschwindigkeit stark abnimmt ist klar. Ich würde dir deshalb die M v2 oder die Micro empfehlen.

    Vielleicht dreht er sich kräftiger, wenn du tog schritt schreibst.

    Was sind das für Stepper? Weist du, ob die genug leistung bringen?
    Back on the road again...

    Falls ihr wissen wollt, was ich so in meiner roboterfreien Zeit gertieben hab: www.plasmaniac.de.vu

  4. #4
    Neuer Benutzer Öfters hier
    Registriert seit
    12.05.2005
    Beiträge
    6
    Das Problem ist, das der Motor sowieso schon zu langsam ist. An eine untersetzung habe ich auch schon gedacht, aber dann wird der Motor noch langsamer wie erschon eh ist.


    Der Motor ist von NC-Step, der Typ leutet: Vexta PX243M-03A

    Mit Tog habe ich es noch nicht probiert. Ich probier es mal kurz aus.

  5. #5
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    14.12.2003
    Alter
    27
    Beiträge
    1.187
    Du kannst ja ne kleine Schaltung aufbauen, die die Schritmotoren direkt taktet, oder pro impuls immer 10 Schritte weitergeht (ich denke da an eine 555-schaltung, die ein mal auf die Treiber und auf einen 10-fach dezimalzähler geht, dessen letzter ausgang den ne555 aausschaltet (flip-flop das davor durch die c-control gesetzt wurdeoder so))
    Back on the road again...

    Falls ihr wissen wollt, was ich so in meiner roboterfreien Zeit gertieben hab: www.plasmaniac.de.vu

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •