-         

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12

Thema: Warum funktioniert diese Schaltung?

  1. #1
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    03.11.2004
    Beiträge
    156

    Warum funktioniert diese Schaltung?

    Anzeige

    Hallo,
    ich möchte eine Gabellichtschranke (CNY36) an den Microcontroller anschließen und habe mir dazu einmal angeschaut, wie ich das beim letzten mal gemacht habe.
    Jetzt aber meine Frage: Ist der Fototransistor nicht eigentlich falsch herum eingebaut? Wenn ja, warum funktioniert die Schaltung dann überhaupt?
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken cny36.jpg  

  2. #2
    Super-Moderator Lebende Robotik Legende Avatar von Manf
    Registriert seit
    30.01.2004
    Ort
    München
    Alter
    64
    Beiträge
    12.366
    Der Tansistor heißt NPN, so wie seine Schichtenfolge.
    Von der anderen Seite heißt er auch NPN, er hat dann nur andere Daten wie zum Beispiel eine geringere Stromverstärkung und eine kleinere Kollektor Basis Kapazität.
    Manfred

  3. #3
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    03.11.2004
    Beiträge
    156
    Das heißt also, dass die Schaltung immer funktioniert, egal ob der Fototransistor so oder andersrum angeschlossen ist?

  4. #4
    Super-Moderator Lebende Robotik Legende Avatar von Manf
    Registriert seit
    30.01.2004
    Ort
    München
    Alter
    64
    Beiträge
    12.366
    Wenn er richtig herum angeschlossen ist kann man die Daten im Datenblatt nachlesen.
    Wird er Spiegelverkehrt angeschlossen dann könnte man vielleicht versuchen das [fliph:b95d5f309c]lesen zu rückwärts Datenblatt [/fliph:b95d5f309c].
    Es sind zumindest andere Daten.
    Manfred

  5. #5
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    03.11.2004
    Beiträge
    156
    OK, danke. Dann werde ich ihn wohl doch lieber anders herum anschließen, schließlich kann ich besser vorwärts lesen

  6. #6
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    03.11.2004
    Beiträge
    156
    ich hab mir die schaltug jetzt mal so eingebaut, aber eben mit + und - (Der Lichtschranke) vertauscht. Allerdings liegt jetz am µC-Pin immer 4V an, egal wie ich das Poti verstelle, die Lichtschranke unterbreche usw. Stimmt noch irgendwas an der Schaltung nicht?

  7. #7
    Benutzer Stammmitglied
    Registriert seit
    30.11.2004
    Ort
    Berlin
    Beiträge
    51
    Sag mal, was ist denn das für ein Fototransistor? Bezeichnung? Typ?

    commary

  8. #8
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    24.04.2004
    Ort
    Karlsruhe
    Alter
    39
    Beiträge
    1.277
    Also wenn du das Poti ganz gegen 0 Ohm gedreht hast kann es gut sein dass der PT sowieso hinüber ist.
    Meiner Meinung nach fehlt da noch ein Widerstand in Serie zum PT, oder Manf?

    Gruß, Sonic
    http://www.dontfeedthetroll.de/images/dftt.gif
    If the world does not fit your needs, just compile a new one...

  9. #9
    Benutzer Stammmitglied
    Registriert seit
    22.01.2005
    Beiträge
    82
    In jedem Fall ist hier ein Vorwiderstand zu empfehlen! Vermutlich ist jetzt nicht nur das Poti kaputt, sondern auch der Optokoppler

  10. #10
    Super-Moderator Lebende Robotik Legende Avatar von Manf
    Registriert seit
    30.01.2004
    Ort
    München
    Alter
    64
    Beiträge
    12.366
    Der Fototransistor soll auf Licht reagieren und dann Strom durchlassen, dann ist die Spannung hoch.
    Verdunkle ihn doch mal und setzte einen Widerstand von 4,7kOhm dazu. Wenn es immer noch 4V sind wird er hinüber sein.
    Für das Poti besteht noch Hoffnung, aber mehr als 1-5mA sollte man über den Fototransistor nicht fließen lassen.
    Manfred

Seite 1 von 2 12 LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •