-
        

Ergebnis 1 bis 2 von 2

Thema: Nebelmaschiene tunen

  1. #1
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    15.03.2005
    Ort
    gerne in den Bergen
    Alter
    33
    Beiträge
    429

    Nebelmaschiene tunen

    Anzeige

    Hallo leute

    Ich habe eine kleine Nebelmaschiene von Conrad (McCrypt). Letzten sommer ist mir die Pumpe und die Temperatursensoren davon geschieden.

    So habe ich mir gedacht könnte man doch daraus en Mini-Maximalnebelmonster bauen. Der Nebel ensteht, nur muss ich das Heizelement manuel ein und ausschalten. Und genau das ist mein Problem.

    Meine Frage: Ich programmiere in Assembler und habe ein ATmega16 als versuchskanienchen! zum testen habe ich an PortA 0-3 jeweils eine LED. der Temperatursensor ist an ADC7 angeschlossen und wird von 5V über eine konstantsromquelle gespiesen (1mA).

    Beim Wert BE sollte die LED abschalten und beim wert AC wieder einschalten! Weiten benötige ich nur die oberen 8 bits. (links augerichtet) ]
    Was könnte an meinem Code falsch sein, dass es nicht funkeioniert?
    Angehängte Dateien Angehängte Dateien

  2. #2
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    15.03.2005
    Ort
    gerne in den Bergen
    Alter
    33
    Beiträge
    429
    Problem gelöst. Nach wieterem Versuchen mit dem Code hat es nun geklappt. Problem lag daran, dass ich das ADMUX register zu früh gesetzt habe.

    Dafür habe ich jetzt en anderes Problem: Der uP schaltet bei den vorgegebenen Temperaturen ein Relais über ein Transistor und Basiswiderstand! (&freilaufdiode)

    Nach dem dritten schaltimpuls hängt sich der uP auf! Kennt jemand das Phönomen???

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •