-
        

Ergebnis 1 bis 4 von 4

Thema: wieder mal das UART

  1. #1
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    17.11.2004
    Beiträge
    263

    wieder mal das UART

    Anzeige

    Hi

    Ich benutze zum testen des UARTs folgenden Code:
    Code:
    $regfile = "M162def.dat"
    $crystal = 1000000
    $baud = 9600
    
    Dim J As Byte
    
    J = 0
    For J = 0 To 254
       Printbin J;
       Waitms 100
    Next I
    
    Do
    Loop
    Ich bekomme dann in meinem Terminalprogram was sinnloses zu sehen, wie auf dem Bild zu sehen ist. Kann mir da jemand helfen?
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken uart.gif  

  2. #2
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    16.06.2004
    Ort
    Bad Schussenried in Oberschwaben
    Alter
    28
    Beiträge
    1.461
    Hi!

    Das kann auch nicht gehen..

    Code:
    For J = 0 To 254 
       Printbin J; 
       Waitms 100 
    Next I  '<-- Deine Variable heißt doch J!!
    Lass das I auch mal weg! Einfach "Next".

    Und vergess am Ende das "End" nicht!

    Grüße,
    Tobi
    http://www.tobias-schlegel.de
    "An AVR can solve (almost) every problem" - ts

  3. #3
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    17.11.2004
    Beiträge
    263
    Verdammt, und wegen sowas such ich stundenlang rum...

  4. #4
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    16.06.2004
    Ort
    Bad Schussenried in Oberschwaben
    Alter
    28
    Beiträge
    1.461
    HI

    Und? Gehts jetzt? ;D
    -> Manchmal sitzt man halt auf der Leitung...

    Grüße,
    Tobi
    http://www.tobias-schlegel.de
    "An AVR can solve (almost) every problem" - ts

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •