-         

Ergebnis 1 bis 2 von 2

Thema: problem mit sleep im turbo c

  1. #1
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    19.02.2005
    Alter
    29
    Beiträge
    830

    problem mit sleep im turbo c

    Anzeige

    ich habe an meinen pc einen Schrittmotor angeschlossen und damit er während des anlaufens keine schritte verliert soll er nach jedem schritt 1,5 ms warten.
    der befehl msleep(1,5); oder usleep(1,5); funktionieren nicht
    hat jemand eine andere lösung?
    danke clemens

  2. #2
    Neuer Benutzer
    Registriert seit
    24.03.2005
    Ort
    bei Hildesheim/Niedersachsen
    Beiträge
    4
    Hallo Clemens,

    ich arbeite zwar unter Linux mit dem Gnu C++ Compiler, aber
    dort gibt es die usleep-Funktion auch. Denke, die ist wie in Turbo-C.
    Diese erwartet einen Parameter, der uebergeben werden muss (Zeit in Mikrosekunden). Du hast wahrscheinlich nur vergessen, statt des Kommas einen Dezimalpunkt zu verwenden. Und wenn Du jetzt noch die 1,5 ms in us umrechnest,
    muesste die Funktion also so aufgerufen werden: usleep(1500).
    Hoffentlich konnte ich Dir weiterhelfen.

    Gruss,
    Clemens

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •