-         

Ergebnis 1 bis 5 von 5

Thema: Arduino CNC Shield GRBL 0.99 Spindle enable

  1. #1

    Arduino CNC Shield GRBL 0.99 Spindle enable

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    hi
    habe mir bei Gearbest die T8 CNC Fräse bestellt. Alles soweit ok aber ich stehe vor 2 komischen Dingen bei denen hier vielleicht ein paar Fachleute nachhelfen können.

    1.) ich habe verstanden, dass seit der Version 0.8 zu 0.9 GRBL der PIN D11/D12 auf dem Arduino getauscht wurde und somit am Shield jetzt nicht mehr der "weiße" Pin von SpnEn zu verwenden ist sondern von den EndStops Z-. Wenn ich das aber nachmesse, liegen auf allen Pins (rechts außen) +4,84 V außer auf Z- und Z+ von den EndStops da liegt 0V. Wenn ich nun M3/M4 als Befehl eingebe wechselt aber der Z- als auch der Z+ nicht auf +4,84 V. Kennt das Phänomen jemand oder kann sich das erklären?

    2.) ich dachte na gut zum testen des Spindel Motor Relais einfach mal einen der anderen Pins genommen (zB SpnEn der ja +4,84 V auf dem Voltmeter anzeigt) aber das Relais zieht nicht an. Also Gegenprobe und die +5V von dem Relais als "Auslöser" genommen siehe da, das Relais zieht an. Auch das ist mir schleierhaft warum die Pins rechts nicht reichen um das Relais auszulösen.

    Ich habe mal sowohl das CNC Shield als auch das Relais als Foto hochgeladen. Es wäre supi wenn da jemand eine Idee hätte.

    dank im Voraus
    hape


    Klicke auf die Grafik für eine größere Ansicht

Name:	Arduino-CNC-Shield-V3-Layout.jpg
Hits:	11
Größe:	135,8 KB
ID:	33229

    Klicke auf die Grafik für eine größere Ansicht

Name:	cnc.jpg
Hits:	12
Größe:	63,6 KB
ID:	33231

    Klicke auf die Grafik für eine größere Ansicht

Name:	cnc_T8_013_800x450.jpg
Hits:	11
Größe:	112,5 KB
ID:	33230

  2. #2
    habe inzwischen folgendes probiert:
    UNO gewechselt -> keine Änderung
    GRBL 1.1 aufgespielt -> keine Änderung
    eine Sache die auch komisch ist: verbinde ich eines der rechten +4,84 V als Signal mit dem Relais messe ich an den Relais Pins nur noch 1,19 V zwischen Relais GND und Signal (sehr seltsam) aber klar ist, dass das natürlich dann kein high Signal ergibt.
    Sollte ich der einzige sein der jemals sowas hatte, bestelle ich mir auch den CNC Shield neu.
    Wäre natürlich gut zu wissen ob jemand hier im Forum so etwas mal hatte oder nicht oder eine Idee hat.
    hape

  3. #3
    Hallo,habe mich gerade hier angemeldet denn ich stehe vor genau dem selben Problem...habe auch die T8 von Gearbest bestellt und bekomme die Spindel so mit Gbrl Befehl M3 nicht ans laufen...in einem Us Forum habe ich gelesen das man das Arduino wohl neu kompilieren muss, bekomme das aber nicht hin, zuwenig Kenntnisse in sowas...Hast du vielleicht schon eine 9gbrl
    .hex File wo der Spindelstart funktioniert ??? Müssen doch mehere sein die das selbe Problem haben...gruss Leonjoeann

  4. #4
    Erfahrener Benutzer Robotik Einstein Avatar von Andree-HB
    Registriert seit
    10.12.2004
    Ort
    Bremen
    Alter
    47
    Beiträge
    2.575
    ...es wird ja kein digitales Signal geschaltet, sondern eine PWM....wenn die Null (bzw. zu niedrig) ist, dann schaltet das Relais nicht

    Setzt die PWM mal auf den höchsten Wert, mit S255...danach sollte M3/M5 klappen.

    M3 S255

  5. #5
    Hallo,macht überhaupt keinen Unterschied...Ich benötige wirklich eine bestätigte funktionierende Hex.file für die T8 Cnc Maschine wo die Spindel auch angeht...wie gesagt habe dasselbe Problem wie der Thread Eröffner und ich kann die Fräse im Auszustand nicht nutzen bzw fräsen...wie soll ich sonst ausschließen ob ein defekt vorliegt bzw.die Fräse und Board reklamieren ???

Ähnliche Themen

  1. Arduino + grbl + G-Code - kamera auslöser steuern???
    Von DANSoLo im Forum Arduino -Plattform
    Antworten: 7
    Letzter Beitrag: 01.01.2018, 15:24
  2. Arduino mit GRBL CNC-Shield
    Von hardyy im Forum Arduino -Plattform
    Antworten: 18
    Letzter Beitrag: 11.02.2016, 16:46
  3. [ERLEDIGT] Arduino Uno und GRBL Nema 17 Schrittmotor ansteuern
    Von Sigma1990 im Forum Motoren
    Antworten: 2
    Letzter Beitrag: 12.01.2016, 14:01
  4. Arduino UNO und CANdiy-Shield
    Von Micro5 im Forum Arduino -Plattform
    Antworten: 0
    Letzter Beitrag: 24.08.2013, 19:04
  5. Arduino UNO Bluetooth Shield
    Von Droggelbecher im Forum Microcontroller allgemeine Fragen/Andere Microcontroller
    Antworten: 2
    Letzter Beitrag: 28.01.2013, 13:10

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •