-         

Ergebnis 1 bis 3 von 3

Thema: BL-Steller steuert BL-Outrunner nur Stufenweise höher

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    08.03.2010
    Beiträge
    66

    BL-Steller steuert BL-Outrunner nur Stufenweise höher

    Anzeige

    Hallo,

    ich habe hier ein seltsames Verhalten von meinem BL-Steller: Robbe Bl-Control 9100-6.
    Und zwar setzt der nur etwa jede vierte PWM um. Dazwischen ändert er die Motordrehzahl nicht.

    Da ich den an einer PID-Regelung betreibe, habe ich dann immer ein paar Werte wo es keine Änderung gibt und dann ist's wieder plötzlich zu schnell.
    Bei manuellem erhöhen der PWM habe ich aber den Nachweis gehabt, das der Steller wirklich nur stufenweise zuschaltet.

    Kennt sich da jemand aus, ist das normal bei dem Steller?

    Ich habe das Programmiergerät dafür, finde aber nix was das beeinflussen könnte.
    Habe "Acceleration" auf "normal" stehen. "Start power" habe ich auf "lowerest". Einzig beim Timing weiß ich nicht ob das so korrekt ist: 8°.
    Müsste aber auch standard sein.
    Na dann noch CAR-Betrieb und "Reverse Function" auf "Two Way".
    Den Motor betreibe ich an 6S.

    Gruß, Andreas

  2. #2
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    05.11.2007
    Ort
    Berlin
    Beiträge
    526
    Hallo Andreas,

    Die Regler müssen eingelernt werden, hast Du das gemacht ?
    Dazu muss das Gas auf Voll (PWM max) gestellt sein und erst dann der Regler mit Spannung versorgt werden.
    Dann ertönen Piepstöne aus dem Motor, dann den PWM Wert auf Min, also Regler runter, dann wieder Töne abwarten.
    Vielleicht liegt es daran.
    8 Grad ist erstmal okay, hier wird nur die Verzögerung eingestellt, wann welche Spule aktiviert wird.
    Wenn das nicht optimal ist, zieht er bissle mehr Strom.
    Was hast Du denn für eine Auflösung mit deiner PWM ? (wieviele Schritte)
    Dann fällt mir noch ein, daß ohne Last (bei meinem Hubi) er Probleme mit der "EMF" hatte
    bei geringer Last kann die Elektronik die rückwirkenden Signale nicht richtig erkennen und er regelte bei mir unendlich hoch.
    Das war zumindest bei dem 40A Regler von Roxxy so.

    Die Motor Polzahl spielt glaube ich auch keine Rolle, braucht er nur für die korrekte Drehzahlberechnung.
    Den Governor (Reglermodus) ist wohl auch nur im Helimodus gültig.

    Ist dein Regler evtl. ein Microchip PIC Controller ?.
    Hier sind die PWM Bits ja "super" verteilt in den Registern...
    Weil bei Dir nur jeder vierte Schritt funktioniert.....
    Geändert von Siro (06.12.2017 um 16:06 Uhr)

  3. #3
    Benutzer Stammmitglied
    Registriert seit
    08.03.2010
    Beiträge
    66
    Hallo,

    der war schon eingelernt, wenn auch auf eine andere Sache. Habe das jetzt nochmal durchgeführt.
    Auf 1800, 1500 und 1200.
    Ist aber das gleiche Ergebnis.

    Also der BL-Control wird von einem Lynxmotion Servo-Controller angesteuert.
    Theoretisch könnte das passen was Du sagst, aber das hätte ich doch bei den Servos und einem auch angeschlossenen (ähnlichen) Robbe Regler gemerkt.

    Aber um da sicher zu sein, werde ich morgen mal ein Servo an den Port hängen oder besser noch ein Oszi.

    Gruß, Andreas

Ähnliche Themen

  1. Antworten: 2
    Letzter Beitrag: 08.10.2017, 14:33
  2. RC-steller mit Regelfunktion
    Von MechMac im Forum Elektronik
    Antworten: 3
    Letzter Beitrag: 27.08.2017, 11:13
  3. Schrittmorot für Hydraulischen Steller
    Von smartsurfer im Forum Motoren
    Antworten: 4
    Letzter Beitrag: 09.02.2007, 16:22
  4. Will nen bl steller selber bauen
    Von bebop im Forum Elektronik
    Antworten: 2
    Letzter Beitrag: 12.03.2006, 10:02
  5. Steller für Sensorless Brushless Motoren
    Von KW Meister im Forum Elektronik
    Antworten: 6
    Letzter Beitrag: 07.06.2004, 12:11

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •