-         

Ergebnis 1 bis 6 von 6

Thema: Roboter soll eigenständig auf die ladestation fahren und von Akku auf Netz schalten

  1. #1

    Roboter soll eigenständig auf die ladestation fahren und von Akku auf Netz schalten

    Anzeige

    Hallo,

    ich habe eine Frage bezüglich dem Laden von RC-Akkus. Ich habe mir einen Akku-Pack mit Tamiya-Stecker (7,2V, NiMH, 5000mAh) besorgt. Das passende Steckerladegerät habe ich auch gleich gekauft. Der Akku ist super, der Bot funktioniert soweit, wie ich will. Ich möchte aber jetzt einen Schritt weiter gehen.

    Ich möchte den Bot auf eine Ladestation steuern. Mir kommt dabei der Gedanke, wie man den Bot von Akku-Betrieb auf Netz umstellt. Er soll, während dem Ladevorgang, weiter mit Strom versorgt werden. Es muss doch möglich sein, das Teil ohne Absturz, weiter zu betreiben, sprich der Raspberry Pi 3 muss ja weiter laufen, damit ich remote darauf zugreifen kann.

    Es geht also im Prinzip um dei Umschaltung von Akku auf Netz. Der Weg, wie man die Ladestation ansteuert ist wieder eine andere Geschichte.

    Ist eine solche Schaltung schwierig? Zu mir selbst, ich habe keine Erfahrung, was die entwicklung von Schaltungen an geht . Ich kann zwar löten und kenne die gebräuchlichsten Bauteile, aber entwickelt hab ich selbst noch nie. Ich denke ein ELKO dürfte doch das für 5 Sekunden schaffen oder?

    Ich habe bereits im Internet gesucht. Es gibt diverse USVs, wobei das ja vermutlich mit meiner Hardware nicht in Frage kommt. Ich will nur so lange der PI auf Akku laufen lassen, bis er eingedockt ist, ein Mechanismus auf "Netzbetrieb" schaltet und die Akkus vom Ladegerät geladen werden.

    Hat jemand eine Idee? Gibt es schon was fertiges?

    Vielen Dank.
    V

  2. #2
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    07.04.2015
    Beiträge
    196
    Die Lösung ist hier vielleicht recht simpel: Lasse den Akku an Deiner Schaltung und schalte das Ladegerät einfach dazu.
    Erklärung: Wenn Dein Robbi im Stillstand z.B. konstant 300mA zieht und das Ladegerät 2A liefert, fließen eben nur 1,7A in den Akku. Auch die Abschaltung des Ladegerätes (typischerweise bei NiMH Delta-U, es wird mit konstantem Strom geladen, das Ladeende wird durch den Rückgang der Zellspannung um ca. 10..20mV detektiert) funktioniert weiterhin, wenn Deine Last während des Ladens konstant bleibt (d.h. Du schaltest während des Ladens keine Motoren und auch den Raspi nicht in unterschiedliche Standby-Stufen).

    Nachtrag noch: Beim Laden steigt die Spannung der Akkus leicht mal eben über 10V. Da musst Du allerdings schauen, ob die Regler hinter dem Akku das mitmachen.
    Geändert von Holomino (02.12.2017 um 05:30 Uhr) Grund: Nachtrag

  3. #3
    Benutzer Stammmitglied Avatar von Defiant
    Registriert seit
    17.04.2005
    Ort
    Hamburg
    Beiträge
    41
    Und was passiert dann nach Ladeschlusserkennung, liefern die Ladegeräte dann nicht nur noch einen minimalen Strom von wenigen mA?

  4. #4
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    03.04.2013
    Beiträge
    374
    Ein Umschaltrelais und ein paar dicke Kondensatoren sollten das Problem doch lösen.

    Frohes Schaffen

    Nils

  5. #5
    Benutzer Stammmitglied Avatar von Defiant
    Registriert seit
    17.04.2005
    Ort
    Hamburg
    Beiträge
    41
    Wenn die Kondensatoren zu groß werden: LM5050-2, Beispiel-Schaltplan im Datenblatt enthalten.

  6. #6
    Danke für den tipp mit dem LM5050-2. Ich schau mir das Beispiel mal an. Ich gebe Bescheid, ob ich damit schon aus komme.
    Bin gespannt.

Ähnliche Themen

  1. Antworten: 6
    Letzter Beitrag: 09.01.2014, 14:48
  2. Roboter soll eine Ladestation anfahren
    Von MartinFunk im Forum Allgemeines zum Thema Roboter / Modellbau
    Antworten: 28
    Letzter Beitrag: 11.12.2006, 18:38
  3. [ERLEDIGT] wie soll ich das zum fahren bringen??
    Von Maria im Forum Robby CCRP5
    Antworten: 14
    Letzter Beitrag: 09.01.2005, 17:52
  4. Ladestation: Akku induktiv laden
    Von Matthias im Forum Elektronik
    Antworten: 21
    Letzter Beitrag: 21.08.2004, 16:19
  5. [ERLEDIGT] wie soll ich das zum fahren bringen??
    Von Maria im Forum Robby CCRP5
    Antworten: 2
    Letzter Beitrag: 17.08.2004, 18:52

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •