-         

Ergebnis 1 bis 2 von 2

Thema: CNC Schield GBRL Problem...

  1. #1

    CNC Schield GBRL Problem...

    Anzeige

    Hallo zusammen als Neuling gleich eine etwas umfassendere Frage samt "Vorgeschichte".... Wenn das langweilt - die eigentliche Frage folgt am Ende (

    Ich hatte schon seit Urzeiten einen kleinen Proxxon Bohrständer samt passendem Kreuztisch mit dem ich gelegentlich Durchbrüche in kleine Kunststoffgehäuse gefräste habe. Dann kam ich irgendwie auf den Arduino und auf Steppermotore. Die ersten Schritte wurden dann mit einem Pack billiger Getriebestepper gemacht und am Ende stand fest den Kreuztisch mit Schrittmotoren auszustatten. Als "Proof of Concept" wurden die beiden X Y Achsen mit diesen kleinen Getriebesteppern erweitert und das funktionierte auch prinzipiell. Da man die beiden Stepper aber nicht gleichzeitig mit der Arduino Library ansteuern kann, war nichts gewonnen, denn rechteckige "Löcher" kann ich auch per Hand zurecht kurbeln. Also wurden die kleinen Stepper erstmal von Unipolar auf Bipolar umgebaut ein eine CNC Schield mit entsprechenden Treibern angeschafft. Auch das funktioniert prinzipiell - zwar lahm, aber bei den Kleinigkeiten die ich ab und an vor habe, spielt das keine Rolle. Ach ja etwas von der Normalität abweichend wird die Z-Achse gesteuert. Bei X und Y ist der vorhandene Kreuztisch mit eine Umdrehung = 1 mm Vorschub = 2048 Vollschritte pro mm. Die Z-Achse wird mit einer Riemenscheibe und einem Stück Zahnriemen nach Unten bewegt was pro 1 mm = 418 Vollschritte ergibt. Das alles ist auch in GBRL so eingegeben und das Ganze funktioniert.

    Nun das Problem mit dem ich nicht weiter komme: Nach meinem Verständnis müsste GBRL immer nur den Motor mit Strom versorgen der Schritte machen muss. Steht er länger als ein paar Millisekunden wird er Stromlos geschaltet. Das stimmt auch soweit, solange sich kein einziger der Stepper bewegt. Bewegen sich meinetwegen X und/oder Y Stepper, bleibt zwar der Z Steppen stehen, wird aber trotzdem warm - genau so warm wie die Stepper die sich bewegen. Nachvollziehen kann man das auch am Stromverbrauch. Ist elektrisch zu Testzwecken nur ein Stepper mechanisch angeschlossen, zieht er 350 mA wenn er sich dreht und null mA wenn er steht. Sind alle drei Stepper an ihren Treibern angeschlossen und nur einer dreht sich, steigt trotzdem der Stromverbrauch auf über 1 A und alle drei Motore erwärmen sich.

    Ist dieses Verhalten ein Fehler von GBRL? Mache ich etwas Grundlegendes falsch? Liegt es daran, das die drei Stepper unterschiedlich konfiguriert sind? Dieses Verhalten müsste doch schon irgendjemandem aufgefallen sein, ich finde da aber keine Hinweise.

    Bin für jeden Vorschlag, Hinweis oder Hilfe dankbar!

    Ulli

  2. #2
    Erfahrener Benutzer Robotik Einstein Avatar von Andree-HB
    Registriert seit
    10.12.2004
    Ort
    Bremen
    Alter
    47
    Beiträge
    2.556
    Hi,
    es gibt beim GRBL nur einen Enable-Pin [8] für alle Treiber/Achsen:
    https://github.com/grbl/grbl/wiki/Connecting-Grbl

    und $1 in den Settings ist ebenfalls nur für alle Achsen einstellbar:

    "$1 - Step idle delay, msec


    Every time your steppers complete a motion and come to a stop, Grbl will delay disabling the steppers by this value. OR, you can always keep your axes enabled (powered so as to hold position) by setting this value to the maximum 255 milliseconds. Again, just to repeat, you can keep all axes always enabled by setting $1=255."



    ...somit kannst Du die nicht einzeln steuern.
    Danke an Alle, die uns bei der erfolgreichen 1.000€-Aktion der IngDiba unterstützt haben! | https://www.hackerspace-bremen.de | http://www.pixelklecks.de |

Ähnliche Themen

  1. ATMega32 UART problem --> Problem gelöst
    Von ChristophB im Forum C - Programmierung (GCC u.a.)
    Antworten: 3
    Letzter Beitrag: 12.03.2010, 19:45
  2. Problem mit Atmega644P Erkennung (Bascom-Versions-Problem)
    Von Rohbotiker im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 3
    Letzter Beitrag: 11.08.2008, 19:52

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •