-
        

Ergebnis 1 bis 5 von 5

Thema: Fehler beim ausführen der make-all datei

  1. #1

    Fehler beim ausführen der make-all datei

    Anzeige

    Ich hab das Problem, dass wenn ich (egal welches Programm) beim compilieren in programmers Notepad, zwischendrin die Meldung kriege:"avr-objcopy.exe-Anwendungsfehler Die Anwendung konnte nicht korrekt gestartet werden (0xC0000142)." und dann am Schluss steht unten:" Error 128 Process Exit Code: 2". Da weiß ich jetzt nicht woran das liegt, oder wie das zu beheben ist.

  2. #2
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    11.12.2007
    Ort
    weit weg von nahe Bonn
    Alter
    32
    Beiträge
    2.293
    https://smallshire.org.uk/sufficient...d-windows-8-1/

    versuchs mal mit nem anderen make wie in dem link beschrieben, ich erinner mich dass ich das gleiche problem auf arbeit hatte, gelöst habe ich es indem ich einfach die aktuellste toolchain von atmel installiert habe statt nur das studio plus integirierte toolchain
    Es gibt 10 Sorten von Menschen: Die einen können binär zählen, die anderen
    nicht.

  3. #3
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    27.08.2013
    Ort
    Region Basel
    Alter
    59
    Beiträge
    2.425
    Zitat Zitat von ANNOProfi Beitrag anzeigen
    " Error 128 Process Exit Code: 2"
    Das ist eigentlich eine Meldung des Betriebssystems.

    Ist dir schon einmal aufgefallen, dass es in C int main(....) heisst?
    Damit gibt main() einen Wert an das Betriebssystem zurück.
    0 bedeutet, dass das Programm normal beendet wurde.
    1 bedeutet bei Compilern, dass Warnings aufgetreten sind. Da Modul wurde komplett übersetzt, aber der Code kann fehlerhaft sein.
    2 Es sind Errors aufgetreten und es wurde kein Code erzeugt.

    Manche Programme liefern auch andere Werte, welche direkt auf einen Fehler hinweisen.

    Definiert ist nur dass 0 bedeutet, dass alles normal gelaufen ist und != 0, dass etwas schief gelaufen ist.

    Sinn und Zweck diese Mechanismus ist es, wenn man das Programm aus einem Batch-Job oder einem Programm startet, eine Rückmeldung hat.

    MfG Peter(TOO)
    Manchmal frage ich mich, wieso meine Generation Geräte ohne Simulation entwickeln konnte?

  4. #4
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    07.03.2011
    Beiträge
    1.372
    Die eigentliche Fehlermeldung steht hier:

    Zitat Zitat von ANNOProfi Beitrag anzeigen
    avr-objcopy.exe-Anwendungsfehler
    Die Anwendung konnte nicht korrekt gestartet werden (0xC0000142).
    Irgendetwas stimmt mit deinem avr-objcopy nicht. Versuch mal, es alleine von der Commandline anzustarten, da kann man möglicherweise mehr erkennen.

    Der Rest sagt nur, daß make nicht sauber durchgelaufen ist.

    MfG Klebwax
    Strom fließt auch durch krumme Drähte !

  5. #5
    @Ceos: Ich hab es probiert, ging aber leider nicht, sowohl auf win10 als auch auf win8.1, da kam wieder die Meldung die ich oben genannt habe.

Ähnliche Themen

  1. Antworten: 3
    Letzter Beitrag: 23.07.2013, 09:28
  2. Fehler beim erstellen der .hex datei
    Von ezo2k3 im Forum Asuro
    Antworten: 5
    Letzter Beitrag: 21.11.2008, 23:41
  3. Fehler beim aufruf von make
    Von 3TageBart im Forum Asuro
    Antworten: 3
    Letzter Beitrag: 11.07.2007, 11:39
  4. Einfachere make-Datei für ASURO C-Programme
    Von SnoopysBot im Forum Asuro
    Antworten: 6
    Letzter Beitrag: 05.10.2005, 15:35
  5. Antworten: 9
    Letzter Beitrag: 14.03.2005, 21:08

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •