-         

Ergebnis 1 bis 2 von 2

Thema: Windows 7 pro 64 bit: USB3 nur mit 10 MB/s und weniger

  1. #1
    Erfahrener Benutzer Robotik Visionär Avatar von oberallgeier
    Registriert seit
    01.09.2007
    Ort
    Oberallgäu
    Beiträge
    7.372

    Windows 7 pro 64 bit: USB3 nur mit 10 MB/s und weniger

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Guten Tag,

    diesmal KEIN Roboterproblem und ja, ich weiß, dass es auch spezielle PC-Foren gibt.

    Problem:
    Gestern hatte ich endlich mal fette USB-Sticks gekauft (USB3,0/128 GB) um meine Roboterprojekte zwischendurch zu sichern. Beim Sichern dieser größeren Datenbestände fiel mir auf, dass die USB-Verbindung, frontseitig am PC, nicht spezifikationsgerecht funktioniert : Der Datendurchsatz USB3.0-PC.HDD => USB3.0-Stick läuft mit weniger als 10 MB/sec. Gestern, nach Umstellung des Bios auf "XHCI-hand-off enabled" liefs so um die 10 MB/sec, heute bei einem kleineren Datenumfang von der gleichen HDD auf den gleichen Stick nur noch unter 4 MB/sec, teils sogar unter 3 MB/s. Eigentlich ETWAS langsam für USB3.0. Warum - kann ich mir nach einigem suchen nicht erklären, dort kommt immer der Hinweis darauf, dass man XHCI-hand-off enablen soll. Und das hab ich getan.

    Auch das Löschen (läuft gerade) wird laut Anzeige durchgeführt mit 25 Elemente/Sekunde - das sieht SEHR langsam aus :-/ - ca. 1 GB pro Minute :-///

    Hat jemand bitte Hilfe für mich?
    Windows 7 professional 64 bit, SP1, installierter Arbeitsspeicher 8 GB (7,82 GB verwendbar), Prozessor i5-4440 CPU 3.10 GHz 3.10 GHz.
    Nachtrag
    Stick: SanDisk USB3.0, 128GB
    Platten: Samsusng SSD 750 EVO 250 G SCSI Disk Drive (System)
    ............ST1000DM 003-1CH162 SCSI Disk Drive (Daten - von denen meist nach USB geschaufelt wird)

    Danke im Voraus.
    Geändert von oberallgeier (04.05.2017 um 11:38 Uhr) Grund: Löschen geht ebenfalls langsam
    Ciao sagt der JoeamBerg

  2. #2
    Erfahrener Benutzer Robotik Einstein Avatar von i_make_it
    Registriert seit
    29.07.2008
    Ort
    Raum DA
    Alter
    48
    Beiträge
    2.358
    Windows 7 unterstützt von hause aus erst mal nur bis USB 2.1. Das hatte ich gemerkt, als ich mit meinem Installationsstick das erste mal ein Notebook das nur noch USB 3 hat, installieren wollte.

    Es gibt einen Treiber von Microsoft, den man integrieren kann (für Installationsmedien per Slipstream).

    Und man benötigt die passenden Treiber von den Hardwareanbietern des eigenen Motherboards, dann kommt man auch auf Geschwindigkeit.
    Im Moment wo ich das hier tippe, kopiere ich ein Clonezilla Image von einer externen USB Platte auf meinen Rechner mit 88 bis 100MB/s, über USB 3.

    In umgekehrte Richtung komme ich auf maximal 35MB/s.
    Bei einer SSD Paltte aber auch auf über 80MB/s.

    Also als erstes mal prüfen, ob Lesen und Schreiben gleich schnell sind, wenn ja ist es USB, wenn nein die Platte.
    Dann entsprechend nach BIOS, Firmware und Gerätetreiber Updates suchen.

    Bei Sticks kommt es oft auf den Controller an wie schnell die schreiben können, da ja zur Verteilung der Schreibzyklen auf alle Flashzellen diese vom Controller blockweise in den Adressierbaren Adressraum eingeblendet werden.
    Sprich jeder Zugriff wird gegenüber der physikalischen Speicheradresse umgeroutet.

    Beim Kopieren von HDD auf USB ist die CPU eigentlich außen vor, die Daten laufen über DMA maximal durchs RAM um bei unterschiedlichen Blockgrößen (Cluster auf HDD und Page im Flash RAM) diese anpassen zu können.

    Habe grade mal einen Intenso 32GB Stick angehängt.
    16 bis 17 MB/s von HDD auf Stick.

    Rechner ist: Win7 Prof. 64Bit.
    Geändert von i_make_it (04.05.2017 um 12:34 Uhr)

Ähnliche Themen

  1. 2015 im Video: Windows 10, Windows 10 und andere große Themen
    Von Roboternetz-News im Forum Neuigkeiten / Technik-News / Nachrichten / Aktuelles
    Antworten: 0
    Letzter Beitrag: 25.12.2015, 09:20
  2. Windows 10 IoT ausprobiert: Finales Windows auf dem Raspberry Pi 2
    Von Roboternetz-News im Forum Neuigkeiten / Technik-News / Nachrichten / Aktuelles
    Antworten: 0
    Letzter Beitrag: 14.08.2015, 09:10
  3. Windows 10 IoT Core angetestet: Windows auf dem Raspberry Pi 2
    Von Roboternetz-News im Forum Neuigkeiten / Technik-News / Nachrichten / Aktuelles
    Antworten: 8
    Letzter Beitrag: 05.05.2015, 17:19
  4. Frage GigaBit-NAS-USB3 Adapter
    Von oderlachs im Forum Offtopic und Community Tratsch
    Antworten: 0
    Letzter Beitrag: 27.03.2015, 11:40
  5. Adc auf weniger als 10 bit schalten
    Von Rohbotiker im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 9
    Letzter Beitrag: 07.03.2008, 00:17

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •