-
        

Ergebnis 1 bis 6 von 6

Thema: NodeMCU an Arduino-IDE, Fehler beim Kompilieren

  1. #1

    NodeMCU an Arduino-IDE, Fehler beim Kompilieren

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Hallo,

    Ich bin durch diesen Beitrag, http://www.mikrocontroller-elektroni...d-arduino-ide/, auf das NodeMCU aufmerksam geworden und möchte damit einiges ausprobieren.
    Zunächst vielen Dank für die ausführliche Anleitung.

    Inzwischen sind 2 Stück, WINGONEER NodeMCU LUA WIFI Internet Development Board Basierend auf ESP8266 CP2102, von JUNTOP GLOBAL angekommen.

    Die neueste Ardoino-IDE (1.8.2) geholt.
    Genau nach obriger Anleitung über die zusätzliche Bordverwalter URL das Paket ESP8266 by ESP8266 Community Version 2.2.0 installiert.
    Danach die NodeMCU angeschlossen und Blink aus Datei-Beispiele-ESP8266-Blink kompiliert.

    Leider kamen Fehlermeldungen:
    Code:
    Arduino: 1.6.13 (Windows XP), Board: "NodeMCU 1.0 (ESP-12E Module), 80 MHz, 115200, 4M (3M SPIFFS)"
    
    In file included from c:\dokumente und einstellungen\gd\lokale einstellungen\anwendungsdaten\arduino15\packages\esp8266\tools\xtensa-lx106-elf-gcc\1.20.0-26-gb404fb9-2\xtensa-lx106-elf\include\c++\4.8.2\memory:62:0,
    
                     from C:\Dokumente und Einstellungen\GD\Lokale Einstellungen\Anwendungsdaten\Arduino15\packages\esp8266\hardware\esp8266\2.2.0\cores\esp8266\Esp.cpp:24:
    
    c:\dokumente und einstellungen\gd\lokale einstellungen\anwendungsdaten\arduino15\packages\esp8266\tools\xtensa-lx106-elf-gcc\1.20.0-26-gb404fb9-2\xtensa-lx106-elf\include\c++\4.8.2\bits\stl_algobase.h:59:28: fatal error: bits/c++config.h: No such file or directory
    
     #include <bits/c++config.h>
    
                                ^
    compilation terminated.
    
    exit status 1
    Fehler beim Kompilieren für das Board NodeMCU 1.0 (ESP-12E Module).
    Ich habe die gesuchte c++config.h im Verzeichnis

    Code:
    C:\Dokumente und Einstellungen\GD\Lokale Einstellungen\Anwendungsdaten\Arduino15\packages\esp8266\tools\xtensa-lx106-elf-gcc\1.20.0-26-gb404fb9-2\xtensa-lx106-elf\include\c++\4.8.2\xtensa-lx106-elf\bits
    gefunden und in das geforderte Verzeichnis

    Code:
    C:\Dokumente und Einstellungen\GD\Lokale Einstellungen\Anwendungsdaten\Arduino15\packages\esp8266\tools\xtensa-lx106-elf-gcc\1.20.0-26-gb404fb9-2\xtensa-lx106-elf\include\c++\4.8.2\bits
    kopiert.
    Neuer Versuch zu kompilieren.
    Es kamen wieder Fehlermeldungen.

    Nächste Möglichkeit die Arduino-IDE Version 1.6.13 installiert.

    1. Versuch: Fehlermeldung wie oben
    /c++config.h fehlt.
    Datei, wie oben beschrieben, gefunden und ins geforderte Verzeichnis kopiert

    2. Versuch: wieder Fehlermeldung
    jetzt fehlt os_defines.h
    Datei gesucht, gefunden und wieder kopiert.

    3. Versuch: wieder Fehlermeldung
    diesmal fehlt cpu_defines.h
    Datei gesucht, gefunden und kopiert.

    4. Versuch: wieder Fehlermeldungen
    jetzt fehlt stl_iterator_base_types.h

    Die gesuchte Datei ist im Verzeichnis vorhanden, wird aber als fehlend ausgewiesen.

    Die gesuchten Dateien fehlen immer im Verzeichnis
    .....\xtensa-lx106-elf\include\c++\4.8.2\bits
    gefunden werden sie immer in
    .....\xtensa-lx106-elf\include\c++\4.8.2\xtensa-lx106-elf\bits

    Nur beim letzten Mal wird die Datei nicht gefunden, obwohl sie vorhanden ist.

    Jetzt bin ich mit meinem Latein am Ende.
    Vor der ESP8266 Installation ist der CCleaner gelaufen.

    Es ist völlig egal ob ESP8266 Version 2.2.0 oder 2.3.0 installiert ist. Die Fehlermeldungen sind identisch.

    Das Ganze läuft unter WIN-XP SP3.
    Bisher gab es mit der Arduino IDE noch keinen Ärger.

    Kann mir jemand helfen ?
    Ich möchte sehr gerne mit der NodeMCU experimentieren.
    Sollten noch weitere Informationen nötig sein, ich werde sie zusammensuchen.


    Gruß und Danke
    Gerhard

  2. #2
    Hallo,

    inzwischen habe ich weitere Versuche gestartet, um das NodeMCU Board zum Leben zu erwecken.

    Betriebssystem: WIN XP

    1. Versuch:
    WIN XP in VirtualBox völlig neu installiert.
    Arduino 1.8.2 und ESP8266-Erweiterung 2.3.0, ohne Fehlermeldung, installiert.
    Als Board NodeMCU 1.0 eingestellt. Blink geladen.
    Schon bei der Sketch-Überprüfung kommen wieder die gleichen Fehlermeldungen, wie schon im 1. Beitrag beschrieben.


    2. Versuch:
    Mit dem Flasher die NodeMCU Firmware geflasht.
    Mit ESPlorer ein Beispielprogramm.lua per „Send to ESP“ ins NodeMCU geladen.
    Keine Fehlermeldungen. Beispielprogramm läuft.
    Damit ist bewiesen, die Hardware ist ok.


    3. Versuch:
    Betriebssystem: Raspian auf einem Raspberry Pi 3.

    Arduino 1.8.2 und ESP8266-Erweiterung 2.3.0 installiert.
    Als Board NodeMCU 1.0 eingestellt. Blink geladen.
    Der Sketch läßt sich fehlerfrei kompillieren und aufs NodeMCU hochladen.
    Das Programm läuft so wie es sein soll.

    4. Versuch:
    Betriebssystem: WIN 7.
    Auch hier wieder Arduino 1.8.2 und ESP8266-Erweiterung 2.3.0 installiert.
    Als Board NodeMCU 1.0 eingestellt. Blink geladen.
    Keine Fehlermeldungen beim Kompillieren und Hochladen. Programm läuft.


    Fazit:
    Man kann die ESP8266-Erweiterung 2.3.0 ohne Fehlermeldung in der Arduino IDE unter WIN XP installieren.
    Kompillieren und Hochladen bringen immer Fehler.
    Offensichtlich kommt die ESP8266-Erweiterung mit dem Ordnersystem von WIN XP nicht klar.
    Somit können alle auf ESP8266 basierende Boards nicht in der Arduino IDE unter in WIN XP programmiert werden.

    Gruß Gerhard

  3. #3
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    09.10.2014
    Beiträge
    2.430
    hallo,
    danke für die Infos, im Prinzip genau was ich seinerzeit hier erfragt hatte:
    http://www.roboternetz.de/community/...-programmieren

    Ich habe es mir jetzt vor ein paar Tagen auch bestellt, allerdings mit CH341 (den Treiber habe ich schon für einen Nano und einen Uno Klon), und ich habe auch eine sehr ausführliche aktuelle Installationsanleitung dafür, die ich aber erst noch selber ausprobieren will bevor ich sie hier veröffentliche.

    Ich werde darüber berichten, ASAP

    - - - Aktualisiert - - -

    ps,
    gleich noch eine Frage dazu:
    Ich habe das Board ESP-12F bestellt, angeblich ist es pinkompatibel zum 12E.
    Was mir nicht ganz klar ist:
    sind die Pins 7+8 ein zusätzlicher UART Port, der (wie beim Arduino Mega oder Due) z.B. per Serial1() oder Serial2() angesprochen werden kann?
    http://www.mikrocontroller-elektroni...inbelegung.png
    Geändert von HaWe (26.05.2017 um 10:22 Uhr)
    ·±≠≡≈³αγελΔΣΩ∞ Schachroboter:www.youtube.com/watch?v=Cv-yzuebC7E Rasenmäher-Robot:www.youtube.com/watch?v=z7mqnaU_9A8

  4. #4
    Hallo HaWe,

    hier in dieser Beschreibung http://www.electrodragon.com/w/ESP-1...266_Wifi_Board sind die Verwendungsmöglichkeiten der Pins erklärt.
    Ich hoffe, es hilft weiter.

    Gruß Gerhard

  5. #5
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    09.10.2014
    Beiträge
    2.430
    dankeschön für den Link!
    es ist zwar ein bisschen wie Memory spielen, aber d.h. dann ja
    Code:
    chip    name   board
    GPIO1  - TX0 - D10
    GPIO3  - RX0 - D9
    GPIO2  - TX1 - D4
           - RX1 -
    RX1 allerdings finde ich nun doch nicht, und GPIO13+15 tragen auf dem Chip andere Bezeichnungen als auf dem Board - wo hat sich der 2. RX versteckt (Arduino Serial1/2 kompatibel), oder gibts den doch nicht?
    ·±≠≡≈³αγελΔΣΩ∞ Schachroboter:www.youtube.com/watch?v=Cv-yzuebC7E Rasenmäher-Robot:www.youtube.com/watch?v=z7mqnaU_9A8

  6. #6
    Hallo HaWe,

    ich lese das so: Den RX1 gibt es nicht.
    Den TX1 kann man als einen zusätzlichen seriellen Sendekanal, z.B. seriellen Monitor, verwenden.

    Gruß Gerhard

Ähnliche Themen

  1. Fehler beim kompilieren des Beispielprogramms
    Von Cookie90 im Forum Asuro
    Antworten: 5
    Letzter Beitrag: 26.03.2016, 15:13
  2. Fehler beim Kompilieren
    Von Quäse im Forum Asuro
    Antworten: 8
    Letzter Beitrag: 24.06.2014, 14:35
  3. fehler beim kompilieren
    Von smusmut im Forum Robby RP6
    Antworten: 12
    Letzter Beitrag: 24.04.2009, 23:50
  4. Fehler beim kompilieren von LCD-Programmen
    Von Vistakiller im Forum Asuro
    Antworten: 4
    Letzter Beitrag: 01.08.2008, 17:39
  5. Fehler beim Kompilieren
    Von jvbsl im Forum Robby RP6
    Antworten: 16
    Letzter Beitrag: 14.07.2008, 17:08

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •