-
        

Ergebnis 1 bis 5 von 5

Thema: Schrittmotor plötzlicher Richtungswechsel

  1. #1

    Schrittmotor plötzlicher Richtungswechsel

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Hallo,
    folgendes Problem: mein Schrittmotor dreht sich von selbst in eine andere Richtung, wenn ich die Geschwindigkeit ändere. Er stottert erst kurz hin und her und dreht dann komplett die Richtung.
    Die Geschwindigkeit wird momentan kontinuierlich erhöht und dann wieder verringert, und zwar alle 10ms um 0,1%.

    Ein paar Informationen:
    Motor: ST6018X2008 von Nanotec
    (Link Datenblatt: https://de.nanotec.com/fileadmin/fil...018M2008-A.pdf)
    Treiber: L298

    Ansteuerungsreihenfolge (Vollschritt) ist korrekt, habe mit dem Oszi nachgemessen.
    Spannung wird auch richtig ausgegeben. Kabel sind alle richtig angeschlossen, verschiedene Konstellationen (seriell, parallel, einphase) bin ich auch schon durch.
    Habe zwei Motoren von diesem Modell hier und bei beiden ist das Problem aufgetreten. Ich gehe also mal nicht davon aus, dass es am Schrittmotor liegen könnte.

    Bin recht neu in dem Gebiet, vielleicht sehe ich ja den Wald vor lauter Bäumen nicht... weiß jemand mir zu helfen?

    Vielen Dank!!

    Sam
    Geändert von SamWise (18.03.2017 um 17:31 Uhr)

  2. #2
    Benutzer Stammmitglied
    Registriert seit
    25.01.2012
    Beiträge
    44
    Vermutung: Resonanzproblem

    tritt der Effekt immer bei der gleichen Drehzahl auf?

    evtl. schneller den Bereich durchfahren (1% in 10ms)
    oder Dämpfer benutzen (allerdings schwierig bei nur einem Wellenabgang)

    KK

  3. #3
    Danke für die Antwort

    Es lag am Treiber, hab ihn ausgetauscht und nun funktionierts, puh!!
    Hab nochmal nachgemessen und gemerkt, dass 2 Phasenanschlüsse auf gleichem Pegel waren, so ein Ärger, aber zum Glück nichts exotisches (Resonanz klingt zumindest etwas exotisch für mich)

    Sam

  4. #4
    Erfahrener Benutzer Robotik Einstein Avatar von i_make_it
    Registriert seit
    29.07.2008
    Ort
    Raum DA
    Alter
    49
    Beiträge
    2.427
    Zitat Zitat von SamWise Beitrag anzeigen
    Ansteuerungsreihenfolge (Vollschritt) ist korrekt, habe mit dem Oszi nachgemessen.
    Spannung wird auch richtig ausgegeben. Kabel sind alle richtig angeschlossen, verschiedene Konstellationen (seriell, parallel, einphase) bin ich auch schon durch.
    Na ja zu den Exoten kommt man wenn alle üblichen Verdächtigen schon durch sind.
    Du hast ja geschrieben das Du mit dem Osziloskop schon gemessen hast und die Ansteuerreihenfolge Korrekt ist.

    Zitat Zitat von SamWise Beitrag anzeigen
    Hab nochmal nachgemessen und gemerkt, dass 2 Phasenanschlüsse auf gleichem Pegel waren
    Nach Deiner Auflösung hast Du anscheinend nur vom Contoller zum Treiber aber nicht vom Treiber zum Motor gemessen.

    Deine Erkenntniss ist demnach wohl, immer wirklich alles durchmessen um sich ein Bild der Situation zu machen.

    An sonsten Gratulation das Du den Fehler gefunden hast und jetzt wieder mit dem weitermachen kannst was Du eigentlich machen willst.

  5. #5
    Zitat Zitat von i_make_it Beitrag anzeigen
    Nach Deiner Auflösung hast Du anscheinend nur vom Contoller zum Treiber aber nicht vom Treiber zum Motor gemessen.

    Deine Erkenntniss ist demnach wohl, immer wirklich alles durchmessen um sich ein Bild der Situation zu machen.
    .
    Ja, das hab ich. Man sollte nichts ausschließen und lieber doppelt und dreifach alles messen


    Sam

Ähnliche Themen

  1. Antworten: 5
    Letzter Beitrag: 20.11.2016, 16:02
  2. Antworten: 4
    Letzter Beitrag: 29.08.2008, 20:32
  3. Plötzlicher Rechtsdrall
    Von D1K0 im Forum Robby RP6
    Antworten: 12
    Letzter Beitrag: 30.07.2008, 17:22
  4. Plötzlicher ATMEGA-Tod....
    Von boeseTURBO-CT im Forum AVR Hardwarethemen
    Antworten: 3
    Letzter Beitrag: 08.09.2005, 09:56
  5. Richtungswechsel des 297
    Von PicNick im Forum Motoren
    Antworten: 6
    Letzter Beitrag: 12.03.2005, 15:32

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •