-
        

Ergebnis 1 bis 1 von 1

Thema: RFM12BSP empfängt aber kein Senden möglich

  1. #1
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    25.03.2006
    Ort
    Hinsdorf
    Alter
    43
    Beiträge
    379

    RFM12BSP empfängt aber kein Senden möglich

    Anzeige

    Liebes Forum,

    ich habe das Problem, das ich mit einem ATmega328p und einem RFM12BSP
    Daten richtig empfange jedoch das Senden will nicht.
    Den Code habe ich bei mehreren RFM12S im Einsatz und ohne Problem kann
    ich senden und empfangen.

    Sendecode:
    Code:
      Call Rf_cmd(&H8238) : Rf12_ready                         ' 20 Sender aktivieren
       Call Sdi_send(&Haa) : Rf12_ready                         'Preamble
       Call Sdi_send(&Haa) : Rf12_ready                         'Preamble
       Call Sdi_send(&Haa) : Rf12_ready                         'Preamble
       Call Sdi_send(&H2d) : Rf12_ready                         'Startzeichen: 2D für den Empfänger                                                                                                                    'Preamble
       Call Sdi_send(&Hd4) : Rf12_ready                         'Startzeichen: D4 für den Empfänger
            For Lv = 1 To Txlen
                Rf12_ready
                Call Sdi_send(rf12_data(lv))
            Next Lv
       Call Sdi_send(&Haa) : Rf12_ready                         'Dummybyte nachschieben
       Call Sdi_send(&Haa) : Rf12_ready
       Call Rf_cmd(&H8208) : Rf12_ready
    Ich habe die SPI Kommunikation mitgeschnitten, alles wurde übertragen.
    Wie könnte ich noch testen, ob mein rfm etwas sendet? Mit meinem
    Testsystem, auch ein RFM im Einsatz, kann ich keine Daten empfangen.

    Gibt es irgend welche unterschiede in der Ansteuerung zwischen RFM12S
    und dem RFM12BSP?

    Grüße MAT
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken RFM-senden.jpg  

Ähnliche Themen

  1. Soft UART sendet, empfängt aber nicht
    Von panier im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 14
    Letzter Beitrag: 02.01.2012, 17:54
  2. RN-Funk sendet, empfängt aber nicht
    Von DEAF BOY im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 1
    Letzter Beitrag: 28.12.2011, 17:59
  3. Antworten: 2
    Letzter Beitrag: 04.08.2008, 04:31
  4. 18f1320 USART sendet aber empfängt nicht
    Von stalky13 im Forum PIC Controller
    Antworten: 1
    Letzter Beitrag: 20.06.2007, 20:06
  5. easy radio empfängt nix weil es mit senden beschäftigt ist
    Von q3 im Forum Schaltungen und Boards der Projektseite Mikrocontroller-Elektronik.de
    Antworten: 3
    Letzter Beitrag: 16.06.2007, 14:11

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •