-
        
+ Antworten
Ergebnis 1 bis 6 von 6

Thema: M-Unit mit M-Unit verbinden; Frage wegen Pull-Ups

  1. #1
    Gast

    M-Unit mit M-Unit verbinden; Frage wegen Pull-Ups

    Hi @all:

    Ich hab eine kurze Frage. Und zwar, funktioniert das Verbinden eines Digital-Ausganges mit Pull-Up Widerstand mit einem Digital-Eingang mit Pull-Up Widerstand einer anderen Unit ?

    Ich komm mit der analogen Stromführung nicht zurecht.

    Digital-Ausgang sei D1, Digital-Eingang D2; D1 und D2 sind verbunden; beide haben einen Pull-Up Widerstand.
    :>> Der Pull-Up von D2 zieht doch auch bei D1 = 0V (Low) D2 auf 5V ,oder? Bei D1 = 5V (High) ist klar, dass D2 auf 5V (High) gesetzt wird.

    Dann würde das doch bedeuten, bei D1=1 ist auch D2=1, und bei D1=0 ist auch D2=1

    Da stimmt doch was nicht, oder ?

    Was muss ich anderst machen, bzw. wo denke ich falsch ?


    MedanoCC

  2. #2
    Neuer Benutzer Öfters hier
    Registriert seit
    10.02.2004
    Beiträge
    29
    Sorry, war nicht eingeloggt.

  3. #3
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    03.01.2004
    Ort
    Pottenstein
    Alter
    37
    Beiträge
    265
    Moin!

    Wenn du auf beiden Seiten M-Units benutzt, solltest du eigentlich kein Problem haben. Die hat naemlich keine internen Pullups (im Gegensatz zur CC1). Man wuerde dort selbst welche anbauen muessen, wenn man Schalter abfragen will, dann braucht man naemlich fuer den Ruhezustand eine definierte Spannung (eben die 5V ueber den Pullup). Schliesst man dann den Schalter gegen Masse, liegt am Eingang die Masse an, was der Controller als "1" erkennt. Siehe auch das Bildchen in der Anleitung der M-Unit.
    Wenn du nun zwei M-Units verbinden willst, lass die Pullups einfach weg. Du brauchst dann naemlich nicht auf diese Weise eine kuenstliche Bezugsspannung fuer den Eingang erzeugen, sondern hast jeweils die Spannung des Ausgangs von der anderen Seite. Und die ist wohldefiniert, naemlich 5V oder 0V, jenachdem ob er gesetzt ist oder nicht. Die Massen muessen natuerlich verbunden sein!!
    Probiers mal aus, schlimmstenfalls liege ich falsch und der Eingang erkennt den Signalwechsel nicht, kaputtgehen kann dabei aber eigentlich nix.

    Gruesse,

    Nils

  4. #4
    Super-Moderator Lebende Robotik Legende Avatar von Manf
    Registriert seit
    30.01.2004
    Ort
    München
    Alter
    63
    Beiträge
    12.204
    Richtig ist sicher, daß bei dem Zusammenschalten von M-Unit Ausgängen nichts kaputt gehen kann.

    Die M-Unit hat Ausgänge, die (open Collector genannt) den Pegel bei Ausgangswert = 0 auf null Volt ziehen.
    Bei Ausgangspegel L ziehen die Ausgangstreiber nicht nach 0V dann ist der Pegel nicht definiert. Ein Pull up (meistens 10k) ist dafür da, den Pegel dann auf 5V zu ziehen. Fehlt der Pull up, dann ist ein ausgegebener 0-L-Pegelwechsel immer noch 0-Pegel für den anderen Eingang und es kommt ein Mißverständnis in der Logik auf.
    Zwei Pull up Widerstände einer pro M-Unit stören auch nicht, dann fließt eben 1mA bei 0-Pegel.

    Manfred

  5. #5
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    03.01.2004
    Ort
    Pottenstein
    Alter
    37
    Beiträge
    265
    Nabend,

    Die M-Unit hat doch intern wirklich keine Pullups, oder? Ich hab die Ausgaenge mal ausprobiert, ohne selber Pullups anzubauen, weil ich der Ansicht bin, dass ein Ausgang ueberhaupt nix mit Pullups zu tun hat (haben sollte). Ich kenne Pullups nur bei Eingaengen.
    Wenn ich da einen Ausgang (ohne Pullup) setze, kommen 5V raus, wenn ich ihn ruecksetze, kommen 0V raus. Demnach braeuchte man keine Pullups bei der Verbindung von zwei Units.

    Abgesehen davon sind wir uns aber einig, dass es auch mit Pullups an jeder Unit funktionieren sollte: Wenn dann naemlich die ausgebende Unit 0V vorgibt, also ihren Ausgangspin intern zur Masse schaltet, fliessen die Stroeme, die ueber die beiden Pullups auf die Signalleitung kommen, in die ausgebende Unit und dort intern zur Masse. Damit hat die Signalleitung selber 0V-Potential und die einlesende Unit sieht den 0V-Pegel. Gibt die ausgebende Unit 5V aus, hat natuerlich auch die Signalleitung 5V, die auch von der einlesenden Unit gesehen werden.
    Also, MedanoCC: Bitte sowohl mit als auch ohne Pullups ausprobieren (Ist ja ungefaehrlich) und dann schreiben, ob beides klappt!

    Gruss,

    Nils

  6. #6
    Neuer Benutzer Öfters hier
    Registriert seit
    10.02.2004
    Beiträge
    29
    Super. Danke!
    Nur kann ich es nicht ausprobieren, da ich gleich hardcore das ganze in ein Platinenlayout packe. Also is nix mit rum und num probieren.
    Aber ich gehe nun davon aus, dass es auch mit Pull-Up Widerständen geht.
    Zu dem Pull-Up Problem für Ausgänge: Jepp, bei Ausgängen ist der Pull-Up unnötig, da hier bereits ein definierter Zustand vorliegt.

+ Antworten

Benutzer, die dieses Thema gelesen haben: 0

Derzeit gibt es keine Benutzer zum Anzeigen.

Berechtigungen

  • Neue Themen erstellen: Ja
  • Themen beantworten: Ja
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •