-         

Ergebnis 1 bis 2 von 2

Thema: Oma lötet / Grundsätzliche Fragen zum Asuro

  1. #1

    Rotes Gesicht Oma lötet / Grundsätzliche Fragen zum Asuro

    Anzeige

    Hi!

    Meine Wenigkeit hat sich einen Kindheitstraum erfüllt und sich einen Asuro gekauft, weil ich schon immer einen Roboter haben wollte und weil mein Sohn seine Lötstation nach seinem Auszug hier gelassen hat.
    Obwohl man meine Löterfahrungen mit " blutiger Anfänger" höflich beschreiben kann, scheint mir der Asuro gelungen zu sein.
    Der original Selbsttest funktioniert.
    Die Programmierumgebung habe ich ebenfalls mit win10.64 hinbekommen und flashen geht mehr oder weniger gut.

    Nun zu den Problemen:
    Das original selftest.hex funktioniert. Nun habe ich mir die neuesten AsuroLib's herunter geladen und die fertigen .hex testweise geflasht damit ich sehe ob der Asuro auch was kann. Das Ergebnis war aber eher nüchtern. U.a. zeigt er oft low Batterie an. Die Motoren sind zu schnell. Linienverfolgung nicht bestanden. Figuren fahren auch irgendwie nicht so das Ergebnis was ich mir erhoffte. Die neue selftest.hex scheint viel Strom zu saugen oder passt nicht zu meinem Auro?
    Kann es sein, dass ich diese .hex Dateien besser nicht benutzen sollte ohne sie neu zu compilieren? Oder ist die neue asuro.h ev. (noch) nicht mit dem jungfräulichen Asuro kompatibel?

    Da der original selftest funktioniert scheint mir die hardware OK zu sein. Also sollte ich richtig gelötet haben. Oder?

    Das alles fragt sich die

    AsuroOma

  2. #2
    Moderator Robotik Visionär Avatar von radbruch
    Registriert seit
    27.12.2006
    Ort
    Stuttgart
    Alter
    54
    Beiträge
    5.775
    Blog-Einträge
    8
    Hallo

    Herzlichen Glückwunsch zum asuro und willkommen im RN-Forum.

    Als "blutiger Lötanfänger" bis zu einem funktionierenden Sebsttest zu kommen ist eher außergewöhnlich. Deshalb auch hierzu herzlichen Glückwunsch. :)

    Wenn du fertige HEX-Dateien flushst, dann ist es erstmal egal, welche Lib du verwendest, weil das Programm ja schon im fertigen Maschinencode vorliegt. Bei der aktuellen Lib kannst du dann aber keine Einstellungen machen die die Eigenheiten deines Asuro beschreiben. Dazu mußt du die Datei myasuro.h (Beschreibung im Wiki) anpassen und die Programme komplett neu übersetzen (=kompilieren). Wie man die Werte anpasst kann ich allerdings nicht erklären, weil ich die aktuelle Lib nicht verwende. In der Doku der Lib wird das aber sicher erklärt.

    Die Einstellungen in myasuro.h betreffen die Tastenauswertung, die Impulszählung der Odometrie und die möglicherweise ungleiche Motordrehzahl der beiden Motoren. Also genau die Funktionen die beim Linienfolgen und beim Figurenfahren benötigt werden.

    "VLVL" oder leere Batterie kann mehrere Ursachen haben: Batterien anstelle von Akkus, kein Jumper gesteckt bei Akkubetrieb, schlechter Kontakt am Batteriehalter, Schalter S1 schaltet nicht richtig, falsche Bauteile beim Spannungsteiler R12/R13 oder an Spule/Widerstand R11, schlechte ("kalte") Lötstellen in diesem Bereich...

    Gruß

    mic

    Atmel’s products are not intended, authorized, or warranted for use
    as components in applications intended to support or sustain life!

Ähnliche Themen

  1. Wie lötet man so?
    Von forgoden im Forum Elektronik
    Antworten: 3
    Letzter Beitrag: 29.09.2012, 14:55
  2. Wie lötet man eine Diode am Besten aus?
    Von Floriam im Forum Elektronik
    Antworten: 7
    Letzter Beitrag: 29.12.2007, 13:17
  3. Asuro-Fragen über Fragen
    Von Meur im Forum Asuro
    Antworten: 27
    Letzter Beitrag: 13.08.2007, 00:49
  4. RN-Control 1.4 / ATMega32 - Grundsätzliche Fragen...
    Von Microknut im Forum AVR Hardwarethemen
    Antworten: 3
    Letzter Beitrag: 30.01.2007, 18:13
  5. L297 / L298 Schaltung, grundsätzliche Fragen...
    Von batti112 im Forum Elektronik
    Antworten: 1
    Letzter Beitrag: 15.09.2004, 01:51

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  

Gearbest