-         

Ergebnis 1 bis 8 von 8

Thema: COM- bzw. USB-Anschluss mit PICAXE-Editor funktioniert nicht

  1. #1
    Erfahrener Benutzer Begeisterter Techniker Avatar von Elu
    Registriert seit
    05.08.2007
    Ort
    Rudolstadt
    Beiträge
    315

    COM- bzw. USB-Anschluss mit PICAXE-Editor funktioniert nicht

    Anzeige

    Hallo,
    ich habe bisher meine einfachen Programmierungen für meine Basteleien mit der PICAXE gemacht. Dafür habe ich den PICAXE-Editor 5.0. Als USB-Verbindung vom PC zum Entwicklungsboard AXE091U habe ich das Spezialkabel AXE027 eingesetzt. Die Treiberinstallation für das Kabel habe ich erfolgreich durchgeführt.

    Mein Problem ist jetzt, dass ich keine Verbindung von einem Seriellen Port des PC über das o.g. USB-Kabel zum Entwicklungsboard bekomme. Wenn ich im Editor einen anderen COM-Anschluss einrichte, kommt sofort die Meldung "Ready for use / Komminikationsanschluss" Alle andere COM-Anschlüsse sind weiter gekennzeichnet mit "Not available". Vom XP weiß ich, dass dabei ein COM-Anschluss als USB-Anschluss ausgewiesen wurde, der dann die Verbindung zum Entwicklungsboard herstellte.

    Kann mir jemand einen Tipp geben, wie ich einen COM-Anschluss als USB-Anschluss einrichten kann?

    Gruß Elu
    Meine Basteleien unter: www.elu-report.de

  2. #2
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    27.06.2008
    Beiträge
    184
    Hallo Elu,

    aus Deinem Post geht nicht hervor, welches Betriebssystem Du verwendest.

    Welche Fehlermeldungen bekommst Du?
    Hat es auf diesem PC schon funktioniert?
    MfG
    Hans

  3. #3
    Erfahrener Benutzer Lebende Robotik Legende Avatar von PICture
    Registriert seit
    10.10.2005
    Ort
    Freyung bei Passau in Bayern
    Alter
    66
    Beiträge
    10.983
    Hallo!

    Zitat Zitat von Elu Beitrag anzeigen
    Vom XP weiß ich, dass dabei ein COM-Anschluss als USB-Anschluss ausgewiesen wurde, der dann die Verbindung zum Entwicklungsboard herstellte.
    Das höre ich zum ersten mal und programmiere PIC's immernoch per LPT.

    Zitat Zitat von Elu Beitrag anzeigen
    Kann mir jemand einen Tipp geben, wie ich einen COM-Anschluss als USB-Anschluss einrichten kann?
    Das machen einige fertige Konverter, aber nicht alle.

    Als beispiel: https://s-huehn.de/elektronik/usb-rs232/usb-rs232.htm .
    MfG (Mit feinem Grübeln) Wir unterstützen dich bei deinen Projekten, aber wir entwickeln sie nicht für dich. (radbruch) "Irgendwas" geht "irgendwie" immer...(Rabenauge) Machs - und berichte.(oberallgeier) Man weißt wie, aber nie warum. Gut zu wissen, was man nicht weiß. Zuerst messen, danach fragen. Was heute geht, wurde gestern gebastelt. http://www.youtube.com/watch?v=qOAnVO3y2u8 Danke!

  4. #4
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    27.06.2008
    Beiträge
    184
    Hallo Picture,

    PICAXE sind PIC's, die einen Basic änlichen interpreter onboard haben.
    Es gibt den oben erwähnten PICAXE-Editor mit dem -in füheren Versionen-
    die compilierten Programme über ein serielles Kabel auf die PICAXE übertragen wurden.

    Nachdem die seriellen Anschlüsse seit einiger Zeit nicht mehr verbaut werden, hat die Firma ein
    neues Übertragungskabel -das über USB läuft- herausgegeben.

    Im Kabel (genauer im Stecker) ist ein USB zu Seriell konverter eingebaut.

    Ich habe das ganze Zeug bei mir herumliegen, habe aber schon einige Jahre nichts mehr damit gemacht.
    MfG
    Hans

  5. #5
    Erfahrener Benutzer Begeisterter Techniker Avatar von Elu
    Registriert seit
    05.08.2007
    Ort
    Rudolstadt
    Beiträge
    315
    Hallo hans 99,

    als ich nach dem Absenden meines Postings den Text nochmals überflogen habe merkte ich schon, dass die von Dir angemahnten Angaben fehlten. Deshalb nachfolgend:

    - Betriebssystem WIN 7
    - "Fehler - Hardware nicht gefunden an COM1" bzw. an dem von mir im Editor eingerichteten COM-Port.
    - Auf diesem PC hatte ich diesen Editor noch nie benutzt.

    Elu
    Meine Basteleien unter: www.elu-report.de

  6. #6
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    27.06.2008
    Beiträge
    184
    Hallo Elu,

    ich habe jetzt das Kabel gefunden und bei meiner WIN 7 Maschine angesteckt.
    Wenn ich im Gerätemanager nachsehe, dann ist das Kabel unter "Andere Geräte" als AXE027 PICAXE USB
    mit einem gelben Warndreieck eingetragen.
    Ich habe dann im Ordner "Programme (x86)" "Programming Editor" ein Verzeichnis "AXE027_USB_cable" gefunden.
    Das darunter befindliche Programm löst das Problem nicht wirklich.

    Ich habe dann im PICAXE Forum nachgesehen und einige Links zur Problembehebung gefunden.

    Ich hoffe, es hilft Dir weiter.

    Hier eine Seite mit Tipps.

    http://www.picaxe.com/FAQs/Fault-Finding

    Hier eine Beschreibung zum installieren des Kabels.

    http://www.picaxe.com/docs/axe027.pdf
    MfG
    Hans

  7. #7
    Erfahrener Benutzer Begeisterter Techniker Avatar von Elu
    Registriert seit
    05.08.2007
    Ort
    Rudolstadt
    Beiträge
    315
    Hallo Hans,
    bei mir erscheint das Kabel nicht unter "Andere Geräte" sondern unter "USB-Controller" Wenn ich hier "AXE027 USB" anklicke komme ich auf "Eigenschaften". Unter "Eigenschafften" steht "Das Gerät funktioniert einwandfrei".

    Soweit ist ja alles in Ordnung. Nur die Funktionsanzeige eines COM-Ports als USB-Ausgang fehlt. Beim Betreiben dieses Editors unter WIN XP kam diese Funktion auf einem COM-Port automatisch. Ich werde weiter versuchen.

    Vielen Dank für Deine Links. Ich muss erst noch ein Übersetzungsprogramm downladen. Werde dann hier darüber berichten.

    Elu
    Meine Basteleien unter: www.elu-report.de

  8. #8
    Erfahrener Benutzer Begeisterter Techniker Avatar von Elu
    Registriert seit
    05.08.2007
    Ort
    Rudolstadt
    Beiträge
    315
    Hallo Hans,
    mit Hilfe dieses Links, den ich bei Googeln gefunden habe, habe ich das Problem über den Geräte-Manager gelöst. Ich kann Dir nicht genau sagen in welcher Reihenfolge und wie. Ich bin nur froh, dass es überhaupt geklappt hat. Um den Text bezüglich WIN7 zu verstehen, habe ich Übersetzungs-Software bemüht. Bei WIN XP, wo ich öfters mal das Entwicklungsboard an einen anderen PC anschließen musste, war das alles viel einfacher.
    Vielen Dank für Deine Bemühungen, mir zu helfen.

    Gruß Elu

    http://www.picaxe.com/docs/axe027.pdf


    Meine Basteleien unter: www.elu-report.de

Ähnliche Themen

  1. Bitte bbcode-Tags für Code auch in den einfachen Editor, nicht nur in den erweiterten
    Von HaWe im Forum Anregungen/Kritik/Fragen zum Forum und zum Wiki RN-Wissen
    Antworten: 0
    Letzter Beitrag: 04.12.2014, 14:51
  2. ds1820 funktioniert nicht (anschluss richtig?)
    Von sonium im Forum Sensoren / Sensorik
    Antworten: 5
    Letzter Beitrag: 12.09.2007, 04:25
  3. Font-Editor: Änderungen werden nicht gespeichert.
    Von m_herr im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 2
    Letzter Beitrag: 22.03.2007, 20:09
  4. arg.... mein pc will sich nicht mit der picaxe verbinden
    Von master_t im Forum PIC Controller
    Antworten: 7
    Letzter Beitrag: 16.03.2007, 14:53
  5. PICAXE-18X rennt nicht
    Von robertll im Forum PIC Controller
    Antworten: 10
    Letzter Beitrag: 05.11.2006, 17:14

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •