-         

Ergebnis 1 bis 4 von 4

Thema: LCD 8*2 von Conrad

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    30.06.2004
    Beiträge
    50

    LCD 8*2 von Conrad

    Anzeige

    Hallo,
    ich habe mir auch mal ein LCD gegönnt. Leider habe ich erst nach dem Kauf gesehen, dass ein 8x2LCD in Bascom gar nicht enthalten ist.
    Kann man so was nicht zum laufen bringen? Ich anscheinend nicht!

    Ich habe das mal wie folgt angeschlossen:
    '1 Vss GND
    '2 Vcc 5V
    '3 Vee Poti
    '4 RS PD5 am AVR
    '5 RW GND
    '6 E PD4 am AVR
    '7 DB0 GND
    '8 DB1 GND
    '9 DB2 GND
    '10 DB3 GND
    '11 DB4 PD3 am AVR
    '12 DB5 PD2 am AVR
    '13 DB6 PD1 am AVR
    '14 DB7 PD0 am AVR

    aber es passiert überhaupt nichts. LCD Vee an Masse ergibt in einer Zeile schwarze Kästen.
    Mit Atmega 8 dran und dem folgenden Code passiert nichts:

    $regfile = "m8def.dat"
    $crystal = 1000000 '1Mhz Default

    Config Lcdpin = Pin , Db4 = Portd.3 , Db5 = Portd.2 , Db6 = Portd.1 , Db7 = Portd.0 , E = Portd.4 , Rs = Portd.5

    Dim A As Byte
    Config Lcd = 16 * 1 'configure lcd screen

    Initlcd

    Cls 'clear the LCD display
    Lcd "Test"
    Do
    Loop

    Ich hoffe ihr könnt mir helfen.
    Danke

  2. #2
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    29.01.2005
    Alter
    45
    Beiträge
    294
    Hallo,

    laß die DB0-3 offen. Die Leitungen haben LCD-Controller interne Pull Ups. Ich weis nicht ob es daran liegt, aber ist mal ein Tipp.

    Dann würde ich das Display als 16x2 konfigurieren, dann kannst Du die zweite Zeile mit "locate 2,x" bequem erreichen. Das das Display nur 8 Zeichen "lang" ist mußt Du Dir natürlich selber merken.

    Zumindest mache ich das mit meinem 8x2 so.

    Gruß Bernd

  3. #3
    Benutzer Stammmitglied
    Registriert seit
    30.06.2004
    Beiträge
    50
    Hallo,
    danke für die schnelle Antwort
    Habe ich gerade ausprobiert, aber es passiert immer noch nichts, nur die 8 schw Kästchen (die sich mit dem Kontrast Vee) verändern lassen.

  4. #4
    Benutzer Stammmitglied
    Registriert seit
    30.06.2004
    Beiträge
    50

    Funktioniert

    Hallo,

    danke für die Hilfe, es funktioniert wunderbar.
    Ich hatte eine kalte Lötstelle.

    Gruß
    Heinz

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •