-
        

Ergebnis 1 bis 3 von 3

Thema: Arduino, Marlin und 3D-Drucker - Probleme beim Compilieren (Bibliotheken)

  1. #1
    Erfahrener Benutzer Roboter-Spezialist Avatar von erik_wolfram
    Registriert seit
    02.12.2009
    Ort
    Berlin
    Beiträge
    405

    Arduino, Marlin und 3D-Drucker - Probleme beim Compilieren (Bibliotheken)

    Anzeige

    Hallo,

    ich bin Besitzer des Pollin DAYCOM 3D-Druckers und relativ zufrieden mit dem Gerät. Leider bin ich mit größeren Bauteilen immer an die Grenze gestoßen, weil sich diese durch den nicht beheizten Tisch, an den Ecken abgehoben haben. Also habe ich mir ein Heizbett gekauft. Da der Drucker über eine vollständige Makerlab "Mega Controller" Steuerung verfügt wollte ich diese zwecks G-Code Unterstützung verwenden und keine externe Lösung umsetzten.
    Elektrisch ist alles vorgesehen für ein Heizbett. Leidglich das Häkchen für die Verwendung eines Heizbetts wurde vom Hersteller nicht vorgesehen.

    Also habe ich mir das komplette Programm mit dem Dragon und ISP runtergezogen (als Sicherheitskopie) und versuche die MARLIN Firmware selbst aufzusetzen.
    Das Grundgerüst habe ich ohne Fehler übertragen können. Die Einstellungen hatte ich mir vorher (hoffentlich alle) ausgelesen.
    Doch beim Einbinden des Displays bekomme ich erhebliche Probleme durch dopppelte Definitionen von Pin-Belegungen und Variablen.

    Ich programmiere eingentlich schon sehr lange, habe aber nur seltenst vorgefertigte Bibliotheken verwendet und kenne mich daher nur schwach mit der Implementierung aus. Ich wunder mich, wie es sein kann, dass es durch vollständig zusammengehörende Bilbliotheken zu solchen doppel-Definitionen kommen kann. Gibt es einen Weg dieses zu umgehen? Oder muss ich hierfür alle Bibliotheken manuell ändern/anpassen? (Das kann doch nicht die Lösung sein)

    Wenn der Drucker wieder läuft, kann ich ihn hier gerne vorstellen - für den Preis halte ich ihn für sehr attraktiv!

    Gruß Erik
    Meine Projekte auf Youtube

  2. #2
    Erfahrener Benutzer Roboter Genie Avatar von Rabenauge
    Registriert seit
    13.10.2007
    Ort
    Osterzgebirge
    Alter
    49
    Beiträge
    1.245
    Versuch mal, die Reihenfolge der Bibliotheken im Quelltext zu ändern.
    Klingt zwar unsinnig, aber geholfen hat es schon nen paar Mal.
    Ansonsten wird dir aber nichts anderers übrig bleiben, als alles anzupassen, oder einfach mal ne andere Bibliothek zu nehmen.
    Grüssle, Sly
    ..dem Inschenör ist nix zu schwör..

  3. #3
    Erfahrener Benutzer Roboter-Spezialist Avatar von erik_wolfram
    Registriert seit
    02.12.2009
    Ort
    Berlin
    Beiträge
    405
    Danke für die Antwort,
    gestern hatte ich wieder ein wenig Zeit um mich damit zu beschäftigen. Die Hauptfehlerursache war wohl, dass ich eine Bibliothek manuell runtergeladen und eingefügt habe, anstatt das dem Updater zu überlassen. Die Meldung "avr-gcc: error: CreateProcess: No such file or directory" hat dann alles gestoppt.
    Jetzt zeigt er mir noch ein paar Warnungen an. U.a. "left shift count negativ" für ein DIDR2-Register des Atmegas2560 und einen Fehler über einen falschen Pointer in der benannten Bibliothek.
    Doch vorerst scheint jetzt alles zu funktionieren, zu mindest manuell: der Drucker verfährt, referenziert und heizt jetzt die Nozzle, sowie (theoretisch) das Bett (Juchuh)!

    Heute werde ich kurz testen ob er den SD-Kartenleser erkennt und Programme ausführen kann.
    Schöner Nebeneffekt: die neue Bibliothek stellt einige neue Funktionen bereit und die Menüführung ist jetzt auch noch auf Deutsch. Die Parameter lassen sich jetzt alle am Drucker selbst einstellen - so kann ich testen und diese in der Bibliothek anpassen.

    Als nächstes werde ich mich dann um die Hardware kümmern - das Heizbett muss noch mechanisch eingebaut werden und das/die Netzteile werden integriert.

    Gruß Erik
    Meine Projekte auf Youtube

Ähnliche Themen

  1. Probleme beim Compilieren
    Von ActiveRobo im Forum Allgemeines zum Thema Roboter / Modellbau
    Antworten: 4
    Letzter Beitrag: 30.07.2012, 14:17
  2. Probleme beim Compilieren
    Von Coop im Forum C - Programmierung (GCC u.a.)
    Antworten: 2
    Letzter Beitrag: 20.11.2010, 00:47
  3. Probleme beim compilieren
    Von Ananas im Forum Bauanleitungen, Schaltungen & Software nach RoboterNetz-Standard
    Antworten: 2
    Letzter Beitrag: 15.09.2010, 16:49
  4. Gelöst: NIBObee Liniensensoren: Probleme beim Compilieren
    Von DerDudeESP im Forum Sonstige Roboter- und artverwandte Modelle
    Antworten: 5
    Letzter Beitrag: 06.03.2010, 14:27
  5. WinFact Probleme beim compilieren
    Von Robo14 im Forum Sonstige Roboter- und artverwandte Modelle
    Antworten: 0
    Letzter Beitrag: 10.05.2006, 09:30

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •