-         

Ergebnis 1 bis 9 von 9

Thema: Verständnisfrage zu defektem Schrittmotor

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    24.11.2009
    Beiträge
    6

    Verständnisfrage zu defektem Schrittmotor

    Anzeige

    Hallo
    habe in einem Gerät einen 5 poligen Schrittmotor der beim kurzzeitigen blockieren auf die andere Seite dreht. Habe diesen durch einen neuen ersetzt und es funktioniert jetzt wieder so wie es soll.
    Jetzt stellt sich mir die Frage welchen Defekt kann so ein Verhalten auslösen?
    Ich habe den Motor aufgeschraubt, mechanische Defekte gibt es nicht, Wicklungen habe ich ausgemessen und kann auch da keine Unregelmässigkeiten feststellen.
    Kann dieses Verhalten durch Wackelkontakt einer Leitung ausgelöst werden?

  2. #2
    Erfahrener Benutzer Robotik Einstein Avatar von 021aet04
    Registriert seit
    17.01.2005
    Ort
    Niklasdorf
    Alter
    29
    Beiträge
    4.544
    Es kann sein das es ein leitungsbruch ist. Dieser kann aber auch erst bei Vibration oder Wärme auftreten. Was auch möglich ist das etwas schwer geht (lagerschaden) oder der Rotor ist defekt. In der Firma hatten wir einmal einen defekten Rotor, dort war die Welle auf der die Hülsen mit der Verzahnung aufgeschoben wurde und mit Spannstift gesichert wurde. Ein Spannstift war defekt und dadurch hat sich die verzahnung etwas bewegt mit gleichem Fehlerbild.

    MfG Hannes

  3. #3
    Erfahrener Benutzer Lebende Robotik Legende Avatar von PICture
    Registriert seit
    10.10.2005
    Ort
    Freyung bei Passau in Bayern
    Alter
    66
    Beiträge
    10.969
    Hallo!

    Zitat Zitat von samussen Beitrag anzeigen
    Jetzt stellt sich mir die Frage welchen Defekt kann so ein Verhalten auslösen?
    Über sowas habe ich bisher noch nicht gehört, aber der Fehler muss dann in labiler Steuerung sein, falls der Motor kein Signal an die Steuerung zurück sendet (z.B. aus Drehenkoder).

    Zitat Zitat von samussen Beitrag anzeigen
    Kann dieses Verhalten durch Wackelkontakt einer Leitung ausgelöst werden?
    Nein.
    MfG (Mit feinem Grübeln) Wir unterstützen dich bei deinen Projekten, aber wir entwickeln sie nicht für dich. (radbruch) "Irgendwas" geht "irgendwie" immer...(Rabenauge) Machs - und berichte.(oberallgeier) Man weißt wie, aber nie warum. Gut zu wissen, was man nicht weiß. Zuerst messen, danach fragen. Was heute geht, wurde gestern gebastelt. http://www.youtube.com/watch?v=qOAnVO3y2u8 Danke!

  4. #4
    Erfahrener Benutzer Robotik Einstein Avatar von 021aet04
    Registriert seit
    17.01.2005
    Ort
    Niklasdorf
    Alter
    29
    Beiträge
    4.544
    Es kommt darauf an was zurück drehen ist. Nur ein kleines Stück, das kann dan von einem Kontaktfehler kommen. Dreht er aber mehrere Grad oder gar Umdrehungen zurück kommt es von der Steuerung (motortreiber bzw deren Ansteuerung).

    MfG Hannes

  5. #5
    Neuer Benutzer Öfters hier
    Registriert seit
    24.11.2009
    Beiträge
    6
    Hallo zusammen
    Spannstift habe ich noch nicht kontrolliert. Er wird nicht drehzahl überwacht. Habe den Motor im ausgebauten Zustand langsam zum blockieren gebracht, er blockierte einfach und drehte sich nie in die andere Richtung. Im eingebauten Zustand werden die Motoren teilweise sehr belastet, bis jetzt wurden die Motoren aber immer blockiert, man konnte es auch am Ton hören, und drehten nie in die andere Richtung. Daher vermute ich dass etwas am Motor nicht stimmt.
    Was meinst du mit "der Fehler muss dann in labiler Steuerung sein"? Habe den Motor ausgewechselt und dieser läuft bis jetzt ohne Probleme, daher sollt die Steuerung funktionieren.
    Komischer weise drehte der Motor wenn er in die falsche richtung drehte völlig normal, also ohne stottern, zitter oder so, einfach kurz blockieren und er drehte in die andere richtung. Irgend wo habe ich das schon mal gesehen, kann mich aber nicht mehr daran erinnern.
    Ich wollte schon die Steuerung wechseln, aber mit dem anderen Motor läuft es ja!?
    Werde den Motor nochmal auf mechanische Defekte untersuchen.

    - - - Aktualisiert - - -

    Hallo Hannes
    der Motor dreht endlos in die andere Richtung

  6. #6
    Erfahrener Benutzer Robotik Einstein Avatar von Geistesblitz
    Registriert seit
    16.03.2011
    Ort
    Dresden
    Alter
    30
    Beiträge
    1.937
    Für mich ein eindeutig, eine Phase ist ausgefallen. Durch die Trägheit dreht sich der Rotor auch bei einphasiger Ansteuerung, allerdings ist in diesem Fall die Drehrichtung vom Zufall oder äußeren Einflüssen abhängig und kann kaum vorherbestimmt werden. Ich tippe mal darauf, dass es irgendwo in der Verbindung von einer Phase zur Masseleitung ist, so würde es bei einem unipolaren Motor jedenfalls Sinn ergeben. Hast da schonmal die Kontaktierung überprüft?
    AI - Artificial Idiocy

  7. #7
    Erfahrener Benutzer Lebende Robotik Legende Avatar von PICture
    Registriert seit
    10.10.2005
    Ort
    Freyung bei Passau in Bayern
    Alter
    66
    Beiträge
    10.969
    Zitat Zitat von samussen Beitrag anzeigen
    Was meinst du mit "der Fehler muss dann in labiler Steuerung sein"?
    Sorry, aber ich habe nicht permanente Unterbrechung im Motor selber gemeint, die der Geistesblitz sehr gut Erklärt hat.
    MfG (Mit feinem Grübeln) Wir unterstützen dich bei deinen Projekten, aber wir entwickeln sie nicht für dich. (radbruch) "Irgendwas" geht "irgendwie" immer...(Rabenauge) Machs - und berichte.(oberallgeier) Man weißt wie, aber nie warum. Gut zu wissen, was man nicht weiß. Zuerst messen, danach fragen. Was heute geht, wurde gestern gebastelt. http://www.youtube.com/watch?v=qOAnVO3y2u8 Danke!

  8. #8
    Neuer Benutzer Öfters hier
    Registriert seit
    24.11.2009
    Beiträge
    6
    Hallo zusammen
    habe alles nochmal kontroliert und habe de Fehler gefunden.
    Der Motor bewegt sich im Betrieb auf und ab, das Verbindungskabel vom Treiber zum Motor hate einen Wackelkontakt der sich aber sehr selten bemerkbar machte.
    Kabel gewechselt und gut ist.

    Danke an alle für eure Hilfe

  9. #9
    Erfahrener Benutzer Robotik Einstein Avatar von 021aet04
    Registriert seit
    17.01.2005
    Ort
    Niklasdorf
    Alter
    29
    Beiträge
    4.544
    Schön zu hören wenn es jetzt wieder funktioniert.

    MfG Hannes

Ähnliche Themen

  1. SPI - Verständnisfrage
    Von hae im Forum Microcontroller allgemeine Fragen/Andere Microcontroller
    Antworten: 1
    Letzter Beitrag: 29.03.2012, 11:44
  2. SPI Verständnisfrage
    Von bertl100 im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 9
    Letzter Beitrag: 07.09.2006, 17:54
  3. Verständnisfrage
    Von Shadow² im Forum C - Programmierung (GCC u.a.)
    Antworten: 3
    Letzter Beitrag: 30.08.2006, 12:56
  4. PWM Verständnisfrage
    Von Amri im Forum AVR Hardwarethemen
    Antworten: 9
    Letzter Beitrag: 01.04.2005, 14:36
  5. Verständnisfrage zu einem Schrittmotor ?
    Von Pgame im Forum Motoren
    Antworten: 4
    Letzter Beitrag: 04.12.2004, 19:01

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •