-         

Ergebnis 1 bis 2 von 2

Thema: Problem mit RN-Funk

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    17.02.2005
    Ort
    Nähe Erlangen/Nürnberg/Fürth
    Beiträge
    16

    Problem mit RN-Funk

    Anzeige

    Hallo,
    ich hab mal ne Frage im Bezug auf das RN-Funk-Modul:

    1.) Ich habe zwei RN-Funkmodule jeweils mit einem RT868F4 bestückt gekauft und zum einen an meinem PC und zum anderen an meinem RP5 angeschlossen.
    Beide Module funktionieren auch "Ich bekomme eine richtige Ausgabe beim Testprogramm 013.bas ( Zeit wird auf dem Terminalprogi am PC angezeigt )

    2.) Jetzt aber zu meinem Problem:
    Ich kann nur sehr kleine Programme auf den RP5 übertragen, ist das Programm größer als ca. 200 byte bekomme ich eine Fehlermeldung das sich der RP5 nicht mehr meldet, ich dachte schon das liegt an der Antenne, doch nach anbau einer Stabantenne hat sich der Effekt nicht gebessert!!!!!!

    Muss ich ggf. an den Modulen irgend etwas anderes einstellen?
    Oder ist das Übertragen von Programmen garnicht möglich?

    Danke im voraus für die schnelle Hilfe

    Thomas

  2. #2
    Administrator Robotik Einstein Avatar von Frank
    Registriert seit
    30.10.2003
    Beiträge
    4.990
    Blog-Einträge
    1
    Wurde auch schon im Forum angesprochen. Generell kann man nicht immer Programme mit der STandard-Übertragungssoftware von Compilern/Entwicklungsumgebungen per Funk übertragen.
    Die Übertragungssoftware ist manchmal einfach zu schnell, so das der 128 Byte Buffer in den Funkmodulen überläuft.
    Man müsste somit selbst eine Übertragungssoftware basteln die kleine Pausen beim senden und insbesonderen bei erwatteten Rückmeldungen vorsieht. Zumindest bei den AVR´s ist das nicht so sehr schwierig, dort kann man sich Bootloader selbst basteln.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •