-         

Ergebnis 1 bis 6 von 6

Thema: Fehler 152 nach build

  1. #1
    gonzo1215
    Gast

    Fehler 152 nach build

    Anzeige

    hallo,

    ich bin noch anfänger im bereich der pic's und meine ersten versuche scheitern schon beim build...
    ich arbeite mit der MPLAB IDE 7.0 software.

    folgender fehler erscheint ca 50 mal in der fehlerliste (kleiner ausschnitt):

    Error[152] D:\ ... .ASM 26 : Executable code and data must be defined in an appropriate section
    Error[152] D:\ ... .ASM 27 : Executable code and data must be defined in an appropriate section
    Error[152] D:\ ... .ASM 28 : Executable code and data must be defined in an appropriate section
    Error[152] D:\ ... .ASM 29 : Executable code and data must be defined in an appropriate section

    an den besagten stellen befindet sich dieser code:

    bcf OPTION_REG,7
    clrf TRISB
    bcf TRISA,3
    bcf TRISA,4


    und noch etwas anderes: wo kann man die include datei einsehen ? sie wird scheinbar im code akzeptiert, aber man kann diese datei nirgendwo im dateisystem finden...

    ich hoffe mir kann jemand weiterhelfen!

    gruß,
    stephan

  2. #2
    Super-Moderator Robotik Visionär Avatar von PicNick
    Registriert seit
    23.11.2004
    Ort
    Wien
    Beiträge
    6.836
    Aus einem Grund, der in den Code-Zeilen VORHER liegt, sind die angeflagten Zeilen offenbar in einer data-section gelandet.
    kann man so nix sagen.
    Include-File ist eine normale Text-File: START-> Search -> files & folders
    mfg robert
    Wer glaubt zu wissen, muß wissen, er glaubt.

  3. #3
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    09.05.2004
    Ort
    Bielefeld / Paderborn
    Beiträge
    1.253
    normalerweise müsste der include-file doch mit pfad angegeben sein, wenn er in einem anderen verzeichnis wäre, wie der quellcode, der ihn includet, oder?

  4. #4
    Super-Moderator Robotik Visionär Avatar von PicNick
    Registriert seit
    23.11.2004
    Ort
    Wien
    Beiträge
    6.836
    Der Compiler hat (in der Project-config oder überhaupt als PATH=) gewisse Basisdefinitionen. Sonst wär das Zeugs ja nicht portabel.
    mfg

  5. #5
    Gast
    ein "org 0x0000" zu beginn des programmcodes konnte das problem mit den fehlern beheben.

    die include dateien sind zwar da, aber nicht dort, wo ich sie gerne gehabt hätte. ich habe mplab auf d: installiert, ein teil der daten wurde aber dennoch auf c: abgelegt. toller trick

    vielen dank für eure hilfe!!

    grüße

  6. #6
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    09.05.2004
    Ort
    Bielefeld / Paderborn
    Beiträge
    1.253
    Zitat Zitat von Anonymous
    ich habe mplab auf d: installiert, ein teil der daten wurde aber dennoch auf c: abgelegt. toller trick
    jaaa, lieben wir es nicht alle??? =D>

Benutzer, die dieses Thema gelesen haben: 0

Derzeit gibt es keine Benutzer zum Anzeigen.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •