-         

Seite 3 von 4 ErsteErste 1234 LetzteLetzte
Ergebnis 21 bis 30 von 36

Thema: FTDI-Treiber erkennt blauen USB-IR-Stick nicht

  1. #21
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    01.03.2008
    Ort
    Niederlanden
    Beiträge
    1.167
    Anzeige

    Hier gibt es ein Lösung das den PID zurück setzt unter Linux:

    http://www.minipwner.com/index.php/unbrickftdi000

  2. #22
    Neuer Benutzer Öfters hier
    Registriert seit
    17.12.2009
    Beiträge
    22

    Cool

    Zitat Zitat von Valen Beitrag anzeigen
    Hier gibt es ein Lösung das den PID zurück setzt unter Linux:

    http://www.minipwner.com/index.php/unbrickftdi000
    Nice! Kann ich erst nachher testen, ich gebe dann Bescheid.
    Ich frage mich nur gerade ob 6001 die PID ist die ich brauche.

  3. #23
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    01.03.2008
    Ort
    Niederlanden
    Beiträge
    1.167
    Ich denke schon das PID 6001 richtig ist. Weil diesen alte Asuro-Flash download ein (alte) FTDI treiber drin hat das nur diesen PID in den .inf Datei nennt.

    http://www.arexx.nl/downloads/asuro/...flash_v151.zip

  4. #24
    Neuer Benutzer Öfters hier
    Registriert seit
    17.12.2009
    Beiträge
    22
    Zitat Zitat von Valen Beitrag anzeigen
    Ich denke schon das PID 6001 richtig ist. Weil diesen alte Asuro-Flash download ein (alte) FTDI treiber drin hat das nur diesen PID in den .inf Datei nennt.

    http://www.arexx.nl/downloads/asuro/...flash_v151.zip
    Super hat funktioniert! Das flashen der PID ging wie beschrieben. Danach hat Windows den Stick auch direkt erkannt, automatisch Treiber installiert und einen COM Port dafür angelegt.
    1000 Dank Valen, jetzt kann ich endlich weitermachen.

  5. #25
    Moderator Robotik Visionär Avatar von radbruch
    Registriert seit
    27.12.2006
    Ort
    Stuttgart
    Alter
    54
    Beiträge
    5.774
    Blog-Einträge
    8
    Hallo

    Prima, vielen Dank an alle Beteiligten. Ich habe den Thread in der asuro-Rubrik oben angepinnt.

    Gruß

    mic

    Atmel’s products are not intended, authorized, or warranted for use
    as components in applications intended to support or sustain life!

  6. #26
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    30.12.2008
    Beiträge
    1.416
    Einfach mal noch so als Nachtrag

    http://www.golem.de/news/ftdi-window...10-110039.html

    das hat der BOT scheinbar nicht mit auf dem Schirm gehabt

    wobei andere teilweise doppelt erscheinen hmmm

    mfg
    Thomas$
    was gibt es noch zu sagen

  7. #27
    Erfahrener Benutzer Robotik Visionär Avatar von oberallgeier
    Registriert seit
    01.09.2007
    Ort
    Oberallgäu
    Beiträge
    7.451
    Einfach mal noch so als Nachtrag ... das hat der BOT ... nicht mit auf dem Schirm gehabt ... andere teilweise doppelt ...
    Wenn der Bot evtl. weniger wichtige Meldungen doppelt postet, müssen die wichtigeren halt zurückstehen. Ist nur ein Bot.[/OT]

    Also versuche ich zu verstehen:
    a) Ich kaufe einen USB-Chip, Typ FTDIxxx (oder einen Clon)
    b) Der Chip wird ohne Treiber verkauft
    c) Unter Windows ist ein chipspezifischer Treiber erforderlich
    d) Der Hersteller FTDI stellt im Internet den Treiber unentgeltlich zur Verfügung
    e) Geklonte Chips sind billig erhältlich, ebenso wie der von FTDI ohne mitgelieferten Treiber
    f) Hersteller FTDI stellt sicher, dass seine eigenen Chips mit korrekter PID installiert werden
    g) Hersteller FTDI modifiziert den Treiber so, dass Nicht-FTDI-Chips die PID Null haben
    h) Für den USB-Chip-Nachbau wird also kein für ihn zugeschnittener Treiber bereitgestellt
    i) Der USB-Chip-Nachbau erhält durch den "fremden" Treiber die PID Null
    j) Der USB-Chip-Nachbau funktioniert nicht mit dem "fremden" Treiber bzw der PID Null

    Klingt irgendwie schlüssig.

    Wenn ich für die ABC-Grafikkarte den Treiber der XYZ-Karte installiere, dann ist jedenfalls mir klar, dass diese XYZ nix Sinnvolles macht. Ich bin auch nicht wirklich verwirrt, wenn der XYZ-Treiber mich nicht darauf hinweist, dass ich ihn für eine andere, möglicherweise (weitgehend) baugleiche Karte installiere, obwohl viele Treiber sich das für sie zuständige Teil suchen und es auch melden. Wenn ich meine zehntausend-Steine-Rolex durch eine neunundneunzig-Flocken-Rolex identischen Aussehens (und genauer Uhrzeit) ersetze, kanns schlimmer werden - dann kann ich das Ding los sein und muss noch an den Zoll ne Spende löhnen.
    Geändert von oberallgeier (27.10.2014 um 14:40 Uhr)
    Ciao sagt der JoeamBerg

  8. #28
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    07.03.2011
    Beiträge
    1.334
    Zitat Zitat von oberallgeier Beitrag anzeigen
    ...
    g) Hersteller FTDI modifiziert den Treiber so, dass Nicht-FTDI-Chips die PID Null haben
    Nicht der Treiber wird modifiziert, sondern der Treiber modifiziert den Chip (die PID steht in einem EEPROM). Die Idee dahinter ist wohl, daß FTDI ihre eigenen Chips von Clones unterscheiden kann, und diese so unbrauchbar macht. Bevor man mit einem anderen Programm nicht wieder eine gültige PID in den Chip bekommt, geht der garnicht mehr, egal mit welchem Treiber.

    Ob in den "blauen USB-IR-Sticks" FTDI Originale oder Clones sind, weiß ich nicht. Und ob die Original/Clone Erkennung im FTDI Treiber zuverlässig ist, weiß ich auch nicht.

    MfG Klebwax
    Strom fließt auch durch krumme Drähte !

  9. #29
    Neuer Benutzer Öfters hier
    Registriert seit
    17.12.2009
    Beiträge
    22
    Zitat Zitat von Klebwax Beitrag anzeigen
    Nicht der Treiber wird modifiziert, sondern der Treiber modifiziert den Chip (die PID steht in einem EEPROM). Die Idee dahinter ist wohl, daß FTDI ihre eigenen Chips von Clones unterscheiden kann, und diese so unbrauchbar macht. Bevor man mit einem anderen Programm nicht wieder eine gültige PID in den Chip bekommt, geht der garnicht mehr, egal mit welchem Treiber.

    Ob in den "blauen USB-IR-Sticks" FTDI Originale oder Clones sind, weiß ich nicht. Und ob die Original/Clone Erkennung im FTDI Treiber zuverlässig ist, weiß ich auch nicht.

    MfG Klebwax
    Ihr eigenen Chips sind nicht betroffen. Daher liegt der Verdacht nahe, dass im Tranceiver gefälschte Chips verbaut sind.

  10. #30
    Erfahrener Benutzer Robotik Visionär Avatar von oberallgeier
    Registriert seit
    01.09.2007
    Ort
    Oberallgäu
    Beiträge
    7.451
    Zitat Zitat von Klebwax Beitrag anzeigen
    Nicht der Treiber wird modifiziert, sondern der Treiber modifiziert den Chip (die PID steht in einem EEPROM) ...
    Danke für die Richtigstellung. Mir war vorher nicht ganz klar, dass der PID IM EEPROM geändert wird.

    Trotzdem ist die Sachlage so, dass zu einigen (geklonten) Chips keine rechtmäßig erstellten Treiber/Installer oder wie wir es auch immer nennen wollen existieren. Und der arme Benutzer kann auch den tatsächlichen Hersteller nur schlecht erkennen. Nun wäre es interessant zu wissen, mit welchem Verfahren ich - oder ein anderer Betreiber vom Typ DAU - den tatsächlichen Hersteller erkennen kann, bevor ich mein USB-Device in Betrieb nimmt und den Chip ins temporäre Nirwana modifiziere (modifiziert bekommen). Immerhin kann ja FTDI die eigenen Chips erkennen. Wenn ich FDTI wäre, würde ich auch nicht unbedingt Arbeitszeit investieren um in den eigenen Treiber/Installer neben der Erkennung noch eine Fehlermeldung einbaue. Andererseits würde bei der Installation eines Nicht-FTDI ein wirkungsloser Sprung "zurück" ausreichend sein . . . und eher korrekt.

    Irgendwie glaub ich, dass der verbreitete Geiz-is-geil-Wahn der wesentliche Hintergrund ist. Leider.
    Ciao sagt der JoeamBerg

Seite 3 von 4 ErsteErste 1234 LetzteLetzte

Ähnliche Themen

  1. Laptop bootet nicht von USB Stick
    Von Che Guevara im Forum PC-, Pocket PC, Tablet PC, Smartphone oder Notebook
    Antworten: 15
    Letzter Beitrag: 31.10.2013, 16:42
  2. [ERLEDIGT] USB Treiber lassen sich nicht installieren (xp-prof/sp3)
    Von oderlachs im Forum Offtopic und Community Tratsch
    Antworten: 0
    Letzter Beitrag: 18.01.2013, 10:46
  3. FTDI-Platine an USB-Kabel
    Von Che Guevara im Forum Elektronik
    Antworten: 2
    Letzter Beitrag: 10.07.2012, 01:33
  4. USB ohne FTDI Chip !?
    Von kaktus im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 1
    Letzter Beitrag: 14.01.2009, 21:32
  5. Treiber für ASURO USB geht nicht
    Von Vogon im Forum C - Programmierung (GCC u.a.)
    Antworten: 9
    Letzter Beitrag: 08.09.2005, 21:03

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •