-
        

Ergebnis 1 bis 3 von 3

Thema: C-Control zu langsam?

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    27.02.2005
    Beiträge
    6

    C-Control zu langsam?

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Hallo,

    ich versuche gerade über die C-Control zwei Schrittmotoren (Minebea Schrittmotor 7V / 0,58A - von robotikhardware.de) anzusteueren.
    ich benutze folgendes script (aus dem schrittmotoren.pdf von wolfgang back).

    define motor byteport[1]
    define schritt word

    #rechts
    schritt = schritt + 1
    looktab vollschritt, schritt and 3,motor
    'pause 1 'evtl. Pause einfügen
    goto rechts

    table vollschritt
    9 5 6 10

    das funktioniert gut.
    nun brauche ich aber noch einen kleinen schalter, der wenn gedrückt mir den motor wieder ausschaltet. wenn ich nun eine if-abfrage in die schleife einbaue, also z.B ...

    #rechts
    schritt = schritt + 1
    looktab vollschritt, schritt and 3,motor

    if schalter gedrückt dann mach das und das ...

    goto rechts

    dann verliert der motor einiges an geschwindigkeit und ruckelt.

    hab ich das jetzt blöd programmiert oder ist die C-Control einfach zu langsam für solche sachen. ich verwende die alte C-Control (M-Unit 1).

    Assembler kann ich leider nicht.

    bitte um hilfe,
    sebastian

  2. #2
    Administrator Robotik Einstein Avatar von Frank
    Registriert seit
    30.10.2003
    Beiträge
    4.989
    Blog-Einträge
    1
    Es ist einfach so, das Basic der C-Control ist für solche Sachen zu langsam, dies wurde aber hier im Forum schon recht oft angesprochen und auch kritisiert (Stichwort: Interpreter / kein Maschinencode).
    Du kannst dir nur helfen in dem du etwas Assembler lernst und dieses dort erledigst. Allerdings ist dort der Speicher auch sehr begrenzt, aber für die Aufgabe sollte es reichen.

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    27.02.2005
    Beiträge
    6
    Hallo Frank,

    danke für deinen ratschlag!

    hab jetzt ein bisschen assembler gelernt und versucht das script von wolfgang back für 2 Motoren umzuschreiben.

    http://www.wolfgang-back.com/PDF/Schrittmotor.pdf
    seite 14 - 15

    habs geschafft, die 2 motoren anzusteuern, nur leider nicht gleichzeitig (also z.b motor1 fahr nach links, motor2 nach rechts usw.). sondern entweder nur zusammen, oder abwechselnd.

    hat das vielleicht schon mal jemand hinbekommen und könnte mir einen kleinen tipp geben?

    mfg
    sebastian

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •