-
        

Ergebnis 1 bis 4 von 4

Thema: I2C LCD Schnittstelle defekt ???

  1. #1
    Erfahrener Benutzer Roboter Genie Avatar von oderlachs
    Registriert seit
    17.05.2010
    Ort
    Oderberg
    Alter
    67
    Beiträge
    1.118
    Blog-Einträge
    1

    I2C LCD Schnittstelle defekt ???

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Hallo !
    ich habe aus der Bucht 2 Schnittstellen für den I2C-Lcd Anschluss gekauft, nun funzt nicht eines von den Zweien. Bezeichnung : I2C lcd1602
    Klicke auf die Grafik für eine größere Ansicht

Name:	i2c_lcd_modul.jpg
Hits:	15
Größe:	56,6 KB
ID:	27764
    Mache ich einen Fehler es ist nomal wie auch die anderen Schnittstellen angeschlossen. Die LCD sind i.O. mit einer anderen Art von I2C LCD Schnittstellen geht es, auch habe ich vorher die Adresse mit einem I2C Scanner ausgelesen 0x20.
    Hat wer schon mal ähnliches erlebt, also gleich 2 defekte zu bekommen schliesse ich aus...??

    Gruss Gerhard
    Arduinos, STK-500(AVR), EasyPIC-40, PICKIT 3 & MPLABX-IDE , Linux Mint

  2. #2
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    14.11.2013
    Ort
    SA
    Alter
    64
    Beiträge
    211
    Hallöchen Gerhard,

    Glaube ich nicht. Ist Selectpin für schreiben mit GND verbunden, sollten Zeichen zu sehen sein.

    Tschüß
    fredred

  3. #3
    RN-Premium User Fleißiges Mitglied
    Registriert seit
    19.05.2012
    Ort
    Sigmaringen
    Beiträge
    169
    ein einem arduino Forum fand ich folgenden Thread...
    Klick

    Dort war das Problem das Poti, das wohl so verdreht war, das er wohl einfach die Zeichen am Display nicht gesehen hat.
    JAAAA... Microchips kann man essen... aber der Geschmack ist furchtbar.

  4. #4
    Erfahrener Benutzer Roboter Genie Avatar von oderlachs
    Registriert seit
    17.05.2010
    Ort
    Oderberg
    Alter
    67
    Beiträge
    1.118
    Blog-Einträge
    1
    Hallo JoeM !
    Danke , den link und folgende daraus habe ich alles durch...auch das Poti verstellt von links nach rechts und s..w. Nix. Alle Beispiele die ich dazu fand gingen nicht, gut bei einem leuchtet die BL-LED dauerd..im anderen Beisp. leuchtet sie ca 1..2 sec. dann nie wieder..
    Na mal sehn..leider sind die Beschriftungen der Chips abgeschliffen (???) kann nicht mal feststellen was da für ein Vielfüssler drauf ist... Passiert mir ja nicht wieder bei NoName zu kaufen...

    Gerhard
    Nachtrag : Nachdem ich einige LiquidCrystal_I2C-Libraries in einen Topf geworfen hatte, umgerührt und dann im Editor das Beste davon zusammenfasste klappte es ...

    Nun muss ich nur noch rausfinden wie ich das LCD-Backlight abschalte, dann werde ich die Teile wohl verwqenden können...appropos die Regler da an den Modulen ist grosser....!
    Man solte da was gutes auflöten, wenns auch nur zur einmaligen Einstellung ist.

    Nachtrag 2:
    Ich werde diese Thematik auf meiner Hompage demnächst erläutern, falls sich noch wer damit befassen muss. Diese I2C-LCD Schnittstellen sind recht preiswert zu erhalten über die Bucht,
    leider aber keine konkrete Beschreibung, so das die Verwendung eher Glückssaxche oder mit viel Mühen begleitet ist...

    Gerhard
    Geändert von oderlachs (13.03.2014 um 13:42 Uhr)
    Arduinos, STK-500(AVR), EasyPIC-40, PICKIT 3 & MPLABX-IDE , Linux Mint

Ähnliche Themen

  1. LCD defekt?
    Von Jordi im Forum Robby RP6
    Antworten: 31
    Letzter Beitrag: 16.08.2011, 17:40
  2. LCD defekt?
    Von iK3 im Forum AVR Hardwarethemen
    Antworten: 13
    Letzter Beitrag: 01.02.2009, 18:12
  3. LCD defekt?
    Von Ineedhelp im Forum Elektronik
    Antworten: 3
    Letzter Beitrag: 21.07.2008, 16:01
  4. LCD Defekt?
    Von veryxRV im Forum Controller- und Roboterboards von Conrad.de
    Antworten: 5
    Letzter Beitrag: 09.12.2006, 19:26
  5. LCD defekt?
    Von SeveQ im Forum Elektronik
    Antworten: 11
    Letzter Beitrag: 06.03.2006, 20:55

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •